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Préface

À l'instar de Microsoft Windows pour les systèmes d'exploitation, Microsoft Office est la suite bureautique la plus connue des personnes ayant utilisé l'outil informatique. Ce quasi monopole du marché engendre des problèmes à différents niveaux. Le problème le plus visible est l'amalgame : combien de fois voyez-vous sur des annonces d'embauche ou entendez-vous des gens parler de « Word » en voulant parler d'un logiciel de traitement de texte, ou parler de « Excel » en voulant dire tableur ? Le plus marquant dans ces discours c'est que la plupart du temps ces personnes ne savent pas que « Word » est un logiciel de traitement de texte et « Excel », un tableur. Pour faire une simple analogie, c'est un peu comme si vous ne saviez pas que Renault Clio est en fait une voiture et qu'il en existe d'autres, qui pourraient avoir d'autres avantages et mieux vous correspondre.

Aujourd'hui, les choses changent. Les autres suites bureautiques font de plus en plus parler d'elles et notamment OpenOffice.org. Tout comme la suite bureautique Microsoft Office, OpenOffice.org dispose, entre autres, d'un traitement de texte et d'un tableur. Oui mais pourquoi remplacer un traitement de texte par un autre ? C'est bien là la question fondamentale.

Outre le fait qu'OpenOffice.org est un logiciel libre (voir explications dans le chapitre 1), il utilise un format de fichiers ouvert, normalisé et standardisé : le format OpenDocument, norme ISO 26300. Lorsque vous enregistrez vos documents dans ce format, vous savez que vos données ne sont pas enfermées dans une boîte dont on ne connaît pas le fonctionnement, comme c'est le cas avec par exemple le format .doc utilisé par Microsoft Word.

Savoir que ses données seront toujours accessibles et exploitables, sans être pieds et poings liés au bon vouloir d'une société, ça n'a pas de prix... et c'est ce qui a déjà décidé plusieurs de nos institutions (Gendarmerie, Assemblée Nationale, Ministère de l'agriculture, beaucoup d'universités...), divers grandes villes et pays européens (Amsterdam, Vienne, Munich, Suède, Belgique, Italie, Finlande...) ou non européens (Venezuela, Équateur, Brésil, Afrique du Sud...), plusieurs grandes sociétés (Groupe PSA, Groupe Kingfisher...) à migrer vers OpenOffice.org ; et souvent vers un système d'exploitation entièrement libre lui aussi, tel qu'un système GNU/Linux.

Toutes ces institutions ont fait le choix de l'indépendance économique (plus de frais de licence à payer régulièrement) et politique. La valeur des données prend progressivement sa place aux yeux des différents acteurs économiques. Qu'importe le logiciel avec lequel on y accède, pourvu qu'elles puissent être librement accessibles. Et le format OpenDocument permet ce libre accès. OpenOffice.org n'est pas la seule suite bureautique à utiliser ce format, il y en a bien d'autres (Lotus Symphony d'IBM, StarOffice de Sun, Koffice, Abiword, Gnumeric...) et il y en aura de plus en plus. Seule Microsoft Office préfère faire bande à part.

Changer ses habitudes n'est pas chose toujours facile. Quand on utilise régulièrement un système ou un logiciel, on s'adapte, on prend des repères et des réflexes, des habitudes de travail. Cela nécessite donc quelques efforts au début. Efforts en général très vite récompensés. Ce livre est là pour justement vous aider à retrouver vos marques. Vous utilisiez régulièrement Word, Excel ou PowerPoint et vous saviez exactement quoi faire et comment le faire. Nous avons donc fait ce livre en essayant au maximum de comparer les fonctions de la suite Microsoft Office avec celles d'OpenOffice.org. Certaines fonctions ne sont plus disponibles, de nouvelles apparaitront. OpenOffice.org, comme un grand nombre de logiciels libres, évolue très rapidement. Si aujourd'hui il vous manque LA fonction qui vous est indispensable, vous pouvez faire en sorte qu'elle apparaisse un jour. Selon vos capacités, connaissances, motivations, à différents niveaux vous pouvez contribuer à faire évoluer le logiciel libre : traduction, documentation, communication, tests, codage... n'hésitez pas à participer et faire en sorte que les choses évoluent. C'est ça l'esprit du Libre : être des utilis'acteurs.

Notre Public

Cet ouvrage s'adresse principalement aux utilisateurs de la suite bureautique Microsoft Office souhaitant passer à OpenOffice.org tout en retrouvant leurs marques le plus vite possible. Ce n'est pas un livre d'apprentissage sur les différentes fonctionnalités qu'offre ce type de suite, ni même un manuel d'utilisation d'OpenOffice.org. Il existe pour cela déjà un certain nombre d'ouvrages de très bonne qualité.

Si vous êtes déjà utilisateur avancé d'OpenOffice.org, vous pourrez certainement aussi trouver des informations intéressantes. Mais vous pourrez surtout vous servir des références vers certains sites pour en apprendre encore plus.

Conventions utilisées dans ce livre

Vous trouverez en parcourant cet ouvrage diverses abréviations, mises en pages et symboles afin de mettre en évidence certains points.

Les abréviations utilisées sont :

· OOo, pour OpenOffice.org

· MSO, pour Microsoft Office

Les passages en gras décrivent généralement les suites d'actions obtenues en passant par les menus. Par exemple menu Fichier > Ouvrir... signifie d'aller dans le menu Fichier puis dans le menu Ouvrir...

Les passages en italiques sont là pour montrer que les mots ne sont pas anodins, mais correspondent à quelque chose de très précis, par exemple un clic sur le bouton OK ou un appui sur la touche F1.

Vous rencontrerez également 3 icônes associées à des remarques :
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	Cette note devrait normalement apporter des précisions supplémentaires au sujet précédent. Cependant, ces informations ne sont pas non plus capitales. 
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	Ceci est une note importante, elle essaie d’attirer votre attention sur un point précis à ne pas négliger afin que les opérations indiquées dans le livre se déroulent sans heurts. 
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	Ceci est une astuce qui vous est donnée pour éventuellement vous aider à accomplir une tâche.


Références à d'autres ouvrages

En parcourant ce livre, vous trouverez des références vers d'autres ouvrages également sous licences libres, librement téléchargeables et pour la plupart en langue anglaise.

Vous pouvez vous les procurer sous forme de fichier ODT ou PDF sur le site d'OOoAuthors.

Ces ouvrages sont :

· Getting started Guide :

http://oooauthors.org/en/authors/userguide2/gettingstarted/published_final/
· Writer Guide :

http://oooauthors.org/en/authors/userguide2/writer/published_final/
· Calc Guide :

http://oooauthors.org/en/authors/userguide2/calc/published_final/
· Impress Guide :

http://oooauthors.org/en/authors/userguide2/impress/published/
· Draw Guide :

http://oooauthors.org/en/authors/userguide2/draw/published_final/
· Base Guide :

http://oooauthors.org/en/authors/userguide2/database/
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Versions des logiciels

Cet ouvrage traite de Microsoft Office 2003 et OpenOffice.org 2.3.0.

Chapitre

1

   Introduction

Qu’est-ce qu'OpenOffice.org ?

OpenOffice.org (OOo) est une suite bureautique libre, gratuite et complètement fonctionnelle. Elle comprend les modules suivants :

 XE "Writer" Writer (traitement de texte)
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[Titre [Type [Taille [Date de modification
o Desktop Dossier 29/10/2006, 2312.29
) Downloads Dossier 29/10/2006, 20:5025
) Examples Dossier 14/09/2006, 16:20:08
) icones Dossier 29/10/2006, 19:47:07
) Images Dossier 24/10/2006, 00:3526
) Partage Dossier 17/09/2006, 20:20:07
3 Prog Dossier 17/09/2006, 22:55:57
3 Templates Dossier 29/10/2006, 16:27:45

Nom de fichier - Enregistrer

Type de fichier

Annuler

[Texte OpenbDocument (odt)

Modele de texte OpenDocurment (ott)

Openoffice org 1.0 Texte (.sxw)

[] Enregistrer avec Openoffice.org 1.0 Modele de texte (.stw)
Microsoft Word 97/2000/XP ( doc)

o Microsoft Word 95 ( doc)

Microsoft Word 6.0 ( doc)

Rich Text Format ()

StarWriter 5.0 (.sdw)

StarWriter 5.0 Modéle (.vor)

Aide





	Writer est un outil complet destiné à créer divers types de documents texte : lettres, livres, rapports, bulletins d'information, brochures, etc. Vous pouvez insérer des graphiques, des images et des objets issus d’autres modules dans des documents texte.

Writer est compatible avec le format de fichier Microsoft Word et sait aussi exporter ses fichiers aux formats HTML, XHTML, XML, PDF... Il peut également se connecter à votre client de messagerie électronique.


 XE "Calc" Calc (tableur)
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	Calc possède toutes les fonctions d’analyse avancée, de graphiques et d’aide à la décision que l’on peut attendre d’un tableur de haut niveau. Il possède plus de 300 fonctions permettant d’effectuer, entre autres, des opérations dans les domaines financier, statistique et mathématique. Le gestionnaire de scénarios fournit des « analyses de contingence ».

Calc est compatible avec le format de fichier Microsoft Excel et sait exporter ses feuilles de calcul au format Portable Document Format d’Adobe (PDF) ou encore en HTML. Il peut générer des graphiques 2D et 3D qu’il est possible d’intégrer dans d’autres documents OOo.


 XE "Impress" Impress (présentations)
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	Impress fournit tous les outils standards de multimédia, comme les effets spéciaux, les animations et les outils de dessin. Il partage les capacités graphiques avancées des modules Draw et Math.

Les diaporamas peuvent être améliorés avec les effets spéciaux appliqués aux textes de Fontwork, ou encore en insérant des sons ou des clips vidéo.

Impress est compatible avec le format de fichier Microsoft PowerPoint et peut sauvegarder votre travail dans de nombreux formats graphiques, incluant le Flash Macromedia (SWF).


 XE "Draw" Draw (dessin vectoriel)
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	Draw est un outil de dessin vectoriel qui permet de tout réaliser, du simple schéma à l’organigramme jusqu’au dessin 3D. Sa fonction de Connecteurs Intelligents vous permet de définir vos propres points de connexion.

Vous pouvez utiliser Draw dans n’importe quel module d’OOo, ou créer vos propres ClipArts et les ajouter à la bibliothèque de dessins.

Draw peut importer des illustrations depuis plusieurs formats courants et permet de les sauvegarder sous plus de 20 formats dont PNG, HTML, PDF et Flash.


 XE "Base" Base (base de données)
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	Base fournit des outils pour un travail quotidien sur base de données avec une interface simple. Il permet de créer et d’éditer des formulaires, des rapports, des requêtes, des tables, des vues et des relations, donc de gérer une base de données connectée et très semblable à d’autres applications de bases de données.

Base fournit beaucoup de nouvelles fonctions, comme la capacité à analyser et à éditer les relations dans un diagramme. HSQLDB est le moteur par défaut de la base de données relationnelles de Base. Ce module peut aussi utiliser les bases de données de Base, de Microsoft Access, de MySQL, d’Oracle ou de toute base de données compatible avec le standard ODBC ou JDBC. Base fournit également un support pour un sous-ensemble du SQL ANSI-92.


 XE "Math" Math (éditeur de formules)
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	Math est l’éditeur d’équations et de formules d’OOo. Vous pouvez l’utiliser pour créer des équations complexes comportant des symboles ou des caractères non disponibles dans les jeux de polices standards. Bien que la plupart du temps Math soit utilisé pour créer des formules dans des fichiers Writer ou Impress, il peut aussi fonctionner comme outil indépendant.

Vous pouvez sauvegarder les formules dans le format de Langage Mathématique par Balises (MathML) pour l’inclure dans une page web ou dans des documents créés par des applications autres qu’OOo.


Quels sont les avantages d’OpenOffice.org ?

Voici quelques-uns des  XE "Avantages d’OpenOffice.org" avantages d’OpenOffice.org par rapport à d’autres suites bureautiques :

1) Pas de frais de licence. OOo peut être utilisé et distribué par tous, il n’y a donc aucun coût lié à l’acquisition des licences. Des fonctionnalités disponibles moyennant des frais supplémentaires dans d’autres suites bureautiques (par exemple l’export en PDF) sont gratuites dans OOo. Il n'y a pas de coûts cachés, ni maintenant, ni dans le futur.

2) Logiciel libre. Vous pouvez distribuer, copier et modifier le logiciel comme vous le souhaitez, à la seule condition que cela reste dans le cadre de la licence LGPL.

3) Multi-plateforme. OOo 2.3 fonctionne sur plusieurs architectures matérielles et avec de nombreux systèmes d’exploitation, comme Microsoft Windows, Mac OS X, Linux et Sun Solaris.

4)  XE "Support linguistique étendu" Support linguistique étendu. L’interface d’OOo est disponible dans plus de 80 langues et le projet OOo dispose également de dictionnaires d’orthographe, de césure et de synonymes pour plus de 80 langues et dialectes. De plus, OOo fournit un support aussi bien pour  XE "Les scripts complexes" les scripts complexes (Complex Text Layout - CTL) que pour l’ XE "Écriture de droite à gauche" écriture de droite à gauche (Right to Left [RTL] layout), comme l’hindi, l’hébreu ou l’arabe.

5) Une interface utilisateur homogène. Tous les modules ont un « aspect » et un « comportement » similaires, de façon que leur utilisation et leur maîtrise soient facilitées.

6) Intégration. Les modules d’OpenOffice.org sont bien intégrés les uns aux autres :

7) Tous les composants partagent un correcteur orthographique commun ainsi que d’autres outils utilisés uniformément au sein de la suite. Par exemple, les outils de dessin disponibles dans Writer le sont aussi dans Calc, Draw et Impress et utilisent des versions similaires, mais enrichies dans Impress et Draw. 

8) Vous n’avez pas besoin de savoir quelle application a été utilisée pour générer un fichier donné (par exemple, vous pouvez ouvrir un fichier Draw depuis Writer).

9) Granularité. Généralement, si vous changez une option, cela affecte tous les modules. Cependant, des options peuvent être paramétrées tant au niveau d’un module que d’un document.

10) Compatibilité des fichiers. OOo comporte des capacités d’export aux formats PDF et Flash, ainsi qu’un support pour ouvrir et enregistrer des fichiers dans de nombreux formats couramment utilisés, par exemple ceux de Microsoft Office, HTML, XML, WordPerfect et Lotus 123.

11) Pas de verrouillage propriétaire des fichiers. OOo 2.3 utilise le format de fichier  XE "OpenDocument" OpenDocument, qui est un format XML (eXtensible Markup Language) développé comme un standard industriel par l’ XE "OASIS" OASIS (Organization for the Advancement of Structured Information Standards). Ce format a été validé par  l'Organisation internationale de normalisation (ISO) sous la norme ISO 26300. Ces fichiers peuvent être facilement décompressés et lus avec n’importe quel éditeur de texte : les règles encadrant leur structure sont ouvertes et publiées.

1) Vous avez voix au chapitre. Les améliorations, les dates des corrections logicielles et les sorties des versions majeures sont gérées par la communauté. Vous pouvez vous aussi rejoindre celle-ci et agir sur l’évolution du produit que vous utilisez.

Des articles sur OpenOffice.org, ses objectifs, son histoire et les licences, ainsi que d’autres informations sur son organisation, sont disponibles à l’adresse suivante :  http://fr.openoffice.org/about-information.html (http://www.openoffice.org/about.html en anglais)
Comparaison d'OpenOffice.org avec d'autres suites bureautiques

OpenOffice.org possède les fonctionnalités de la plupart des suites bureautiques existantes et même davantage.

Le tableau ci-dessous compare  ses modules avec ceux des  principales suites bureautiques concurrentes, Microsoft Office 2003 (MSO) et WordPerfect Office X3 (WP).

	Fonction
	OOo
	MSO
	WP

	Traitement de texte
	Writer
	Word®
	WordPerfect X3

	Tableur
	Calc
	Excel®
	Quattro Pro X3

	Dessin vectoriel
	Draw
	non
	non

	Présentations, diaporamas
	Impress
	PowerPoint®
	Presentations X3

	Base de données
	Base
	Access®1
	Paradox 2

	Éditeur d’équations, formules
	Math
	oui
	non


1 Version Professionnel seulement.

2 Seulement dans les éditions Professionnel et Étudiants, Élèves et Enseignants.

Fonctionnalités

Les tableaux suivants comparent certaines  XE "Fonctionnalités importantes d’OpenOffice.org" fonctionnalités importantes d’OpenOffice.org avec ceux des  principales suites bureautiques concurrentes, Microsoft Office 2003 (MSO) et WordPerfect Office X3 (WP).

Styles et formatage

	Fonction
	OOo
	MSO
	WP

	Navigateur
	oui
	limité1
	non

	Fenêtre « Styles et formatage »
	oui
	oui
	non

	Support clavier pour les styles de paragraphes
	oui
	oui
	non

	Support pour les styles de page, cadre et liste
	oui
	non
	non

	Compléter les mots
	oui
	Excel seulement
	non

	Modules d’orthographe et de contrôle de la langue
	+ de 80
	+ de 502
	25

	Outils de formules ou d’équations
	oui
	oui
	non


1 Le mode Plan dans Word offre un sous-ensemble des fonctions du Navigateur d’OOo.

2 Requiert une licence additionnelle pour le Multilingual User Interface Pack.

Interopérabilité

	Fonction
	OOo
	MSO
	WP

	Capacité d’export PDF
	oui
	oui 1
	oui

	Capacité d’export Flash
	oui
	non
	oui

	Capacité d’export XML
	oui
	oui
	oui

	Format ISO OpenDocument
	oui
	oui 2
	non

	Import/Export des fichiers Microsoft Office
	oui
	oui
	oui

	Import des fichiers WordPerfect
	oui
	oui
	oui

	Import des fichiers Lotus 123
	oui
	oui
	oui

	Connexion à des bases de données externes (MySQL, Oracle, Access, etc.)
	oui
	oui
	oui

	Langues disponibles (localisations)
	+ de 80
	+ de 35
	30

	Systèmes d’exploitation supportés
	Windows, Mac OS X, Linux, Solaris
	Windows seulement 3
	Windows seulement

	Support du langage Unicode
	oui
	oui
	non


1 Nécessite des applications tierces, comme PDF Writer ou PDF Converter.

2 Nécessite l'ajout d'un composant externe disponible à l'adresse : http://www.sun.com/software/star/odf_plugin/
3 Microsoft Office Mac et Microsoft Office 2003 n'ont pas la même palette de fonctions.

Programmation

Les macros sont des programmes qui permettent d’automatiser des tâches et peuvent être incorporées au sein d’un document. Le tableau ci-dessous dresse la liste des langages disponibles pour le développement de macros dans chacune des suites bureautiques.

	Langage
	OOo
	MSO
	WP

	Langages dérivés du Basic
	OpenBasic
	VBA
	VBA

	Beanshell
	oui
	non
	non

	Java
	oui
	non
	non

	JavaScript
	oui
	non
	non

	Python
	oui
	non
	non


Au-delà des simples macros, certaines suites bureautiques peuvent être améliorées pour inclure de nouvelles fonctions, généralement sous la forme de modules d'extension (plug-ins). Dans le cas d’OpenOffice.org, il est aussi possible de le faire par des modifications du code source.

	Fonction
	OOo
	MSO
	WP

	C et C++
	oui
	oui
	oui

	Java
	oui
	non
	non

	Python
	oui
	non
	non

	Disponibilité du code source !
	oui
	non
	non


Sécurité

	Fonction
	OOo
	MSO
	WP

	Signatures numériques
	oui
	oui
	oui

	Chiffrement puissant
	oui
	oui
	oui

	Chemins d’accès sécurisés pour l’exécution des macros
	oui
	oui
	non


 XE "Nouvelles fonctions de la version 2.3" Nouvelles fonctions de la version 2.3

OpenOffice.org 2.3 fournit des centaines d’améliorations et de nouvelles fonctions. Voici quelques-unes des améliorations majeures :

1) Le module de diagrammes a été entièrement redéveloppé. Il contient quelques nouvelles fonctionnalités et la réalisation de diagrammes a été simplifiée. Un nouvel assistant, des fonctions 3D améliorées, le remplacement des palettes de couleurs, des options d'axes et d'échelles additionnelles, des barres d'outils améliorées, des sources de données flexibles, un éditeur de données revisité, tout ceci combiné pour offrir à l'utilisateur une expérience de module de diagrammes plus efficace et agréable.

2) Le traitement de texte, Writer, intègre un filtre d'export vers Mediawiki. Le zoom aligne au centre plutôt qu'à gauche de l'écran, une fonction évalue la langue lorsqu'elle n'a pas de dictionnaire d'installé. Le publipostage peut maintenant être fait  dans un seul document à partir de la fenêtre de fusion.

3) Le tableur, Calc, bénéficie d'un filtre d'export vers Excel plus efficace grâce à la conversion des commandes COT, ACOT, COTH et ACOTH. Les paramètres d'impression par défaut ont été modifiés afin de supprimer les pages blanches lors de l'impression ou d'imprimer uniquement les feuilles sélectionnées.

4) La partie présentation, Impress, permet de déplacer des objets le long d'une courbe, et a vu ses performances grandement améliorées.

5) Le module de dessins et de diagrammes, Draw, fournit un export HTML/web amélioré par l'export des images au format Portable Network Graphics (PNG). L'ajout de texte alternatif pour les images, les titres des couches ainsi qu'une description permettent un meilleur support pour l'accessibilité.

Pour une énumération complète et détaillée, consultez la liste des changements  d'OpenOffice.org 2.3 (en anglais) située à l'adresse : http://development.openoffice.org/releases/2.3.0.html

 HYPERLINK ""
 .
Quelles sont les conditions minimales pour utiliser OOo ?

OpenOffice.org 2.3 requiert l’un des systèmes d’exploitation suivants :

1) Microsoft Windows 98, Windows ME, Windows 2000 (Service Pack 2 ou supérieur), Windows XP, Windows 2003 ou Windows Vista.

2) GNU/Linux Noyau version 2.2.13, et la glibc 2.2.0 (ou plus récent).

3) Mac OS X 10.4.x, plus X11.

4) Solaris version 8 ou plus récent.

D’autres systèmes d’exploitation seront supportés à l’avenir. 

Certaines fonctions d’OpenOffice.org (les assistants et le module base de données) nécessitent qu’un moteur d’exécution Java ( XE "Java Runtime Environment [JRE]" Java Runtime Environment [JRE]) soit installé sur votre ordinateur.

Bien qu'OOo puisse parfaitement fonctionner sans support Java, certaines fonctions ne seront pas disponibles. Vous pouvez télécharger la dernière version depuis http://www.java.com.

Pour une liste plus complète (et à jour) des recommandations, voyez : 

 HYPERLINK "http://www.openoffice.org/dev_docs/source/sys_reqs.html"
http://www.openoffice.org/dev_docs/source/sys_reqs_20.html

 HYPERLINK "http://www.openoffice.org/about.html"
 
Où se procurer OpenOffice.org ?

Vous pouvez obtenir une version installable de plusieurs façons :

1) Téléchargez une copie depuis la page d’accueil du projet : http://www.openoffice.org. ou directement en français sur http://fr.openoffice.org/.

2) Téléchargez une copie en utilisant un client poste-à-poste (P2P) ou BitTorrent. Les instructions (en anglais) sont disponibles ici : http://distribution.openoffice.org/p2p/. 

3) Achetez une copie gravée sur CD-ROM ou toute autre forme numérique chez un distributeur tiers. Le projet maintient une liste de ces distributeurs ; toutefois, ces distributeurs ne sont ni liés à, ni agréés par OpenOffice.org : http://distribution.openoffice.org/cdrom/sellers.html.

4) Le Projet de Portage d’OpenOffice.org dispose de liens vers des versions du logiciel qui ont été ou sont en cours de « portage » vers d’autres systèmes d’exploitation : http://porting.openoffice.org/index.html.

5) La plupart des distributions GNU/Linux proposent OpenOffice.org directement dans leurs dépôts. Et souvent, dans les distributions dites grand public, il est installé par défaut.

Comment installer OpenOffice.org ?

Les informations sur l’installation et le paramétrage d’OpenOffice.org dans les systèmes d’exploitation supportés sont disponibles ici : http://fr.openoffice.org/Documentation/Guides/Indexguide.html
Ou en anglais :

http://download.openoffice.org/common/instructions.html
Vous trouverez également un grand nombre de documents et tutoriels à l’adresse : http://fr.openoffice.org/Documentation/Index.html
Comment obtenir de l’aide ?

OOo est fourni avec un système d’aide étendu, qui sera votre première source d’aide dans l’utilisation d’OpenOffice.org.

Pour afficher le système d’aide complet, appuyez sur F1 ou sélectionnez Aide OpenOffice.org dans le menu Aide. De plus, vous pouvez choisir d’activer les infobulles, les infoballons et l’assistant d’aide (dans Outils > Options > Général)
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Si les infobulles sont activées, placez le pointeur de la souris sur n’importe quelle icône pour voir apparaître un message (« Infobulle ») contenant une brève explication de la fonction de l’icône. Pour une description plus détaillée, sélectionnez Aide > Qu’est-ce que c’est ? et replacez le pointeur au-dessus de l’icône.

Assistance gratuite en ligne

En plus de développer le logiciel, la communauté OpenOffice.org fournit une  XE "Assistance" assistance gratuite fonctionnant sur le principe du volontariat. Les utilisateurs d’OOo peuvent aussi obtenir une aide en ligne complète dans les lieux de regroupement de la communauté comme les newsgroups, les forums et les listes de diffusion. Il existe aussi de nombreux sites internet créés par des utilisateurs qui fournissent des astuces et des didacticiels gratuits.

	Assistance gratuite OpenOffice.org

	Aide utilisateur
Projet des FAQ
(Foires aux questions)
	FAQ, informations, base de connaissances.
http://wiki.services.openoffice.org/wiki/Fr.openoffice.org/FAQ

	Liste de diffusion utilisateurs
	Assistance gratuite communautaire, fournie par un réseau de centaines d’utilisateurs expérimentés. Vous devez vous enregistrer pour y envoyer des messages. Pour s’enregistrer, il faut envoyer un courriel vide à : users-subscribe@fr.openoffice.org
Les archives de la liste sont consultables à :


 HYPERLINK "http://fr.openoffice.org/servlets/SummarizeList?listName=users"
http://fr.openoffice.org/servlets/SummarizeList?listName=users

	Projet francophone de
documentation
	Modèles,  XE "Guides d’utilisation" guides d’utilisation, how-to et autre documentation.
http://fr.openoffice.org/Documentation/Index.html

	 XE "Projet en langue locale" Projet en langue locale
	Informations, ressources et listes de diffusion dans votre langue. 
http://projects.openoffice.org/native-lang.html

	Assistance Mac
	Support pour l’installation et l’utilisation de la version pour Mac OS X (basée sur X11)   http://fr.openoffice.org/Mac/index.htm

	Le forum
OpenOffice.org
(en anglais)
	Forum de discussion généraliste pour les difficultés liées à OpenOffice.org, depuis l’installation jusqu’aux problèmes avancés de programmation.
http://www.oooforum.org/

	Forum francophone non officiel
	Vous y trouverez des tutoriels, des vidéos, des modèles 

 HYPERLINK ""
et

 HYPERLINK ""
 un forum : 

 HYPERLINK "http://www.forum-openoffice.org/"
http://www.forum-openoffice.org

	Base de
connaissance OOo
(en anglais)
	Une collection de questions et de réponses que les utilisateurs peuvent consulter. http://mindmeld.cybersite.com.au/


Vous pourrez lire plus d’informations sur les options de support pour OpenOffice.org sur (en anglais) :
http://support.openoffice.org/index.html
Assistance payante et formation

D’autre part, vous pouvez aussi avoir accès à des services de support payants : des contrats de service peuvent être achetés à des sociétés de distribution ou de conseil spécialisées dans OpenOffice.org.

OOo est supporté par Sun Microsystems Inc. au sein du programme de support de logiciel de Sun, comprenant deux niveaux de support : soit dans la journée, soit des services vingt-quatre heures sur vingt-quatre pour des déploiements critiques (en anglais).
http://www.sun.com/service/support/software/openoffice/index.html
Une liste de consultants indépendants, ainsi que des services qu’ils proposent, est classée alphabétiquement par région sur le site francophone d’OpenOffice.org :
http://fr.openoffice.org/about-bizdev.htm
Autres ressources 

Plusieurs sites Web fournissent des ressources additionnelles et des suppléments pour améliorer OpenOffice.org. Le tableau ci-dessous recense une partie de ces sites.

	Modèles, ClipArts et autres suppléments gratuits d'OOo

	OOExtras 
	Fournit des modèles, des exemples et des macros dans plusieurs langues. http://ooextras.sourceforge.net/

	OOoMacros
	Un dépôt de macros, de suppléments, et de la documentation sur l’écriture de macros et/ou d’extensions d’OOo. http://www.ooomacros.org/

	Open Clip Art Library 
	Une archive de ClipArts destinés à tous les usages. http://www.openclipart.org/

	OpenOffice.org Macro Information
	Andrew Pitonyak, l’auteur de « OpenOffice.org Macros Explained », anime un site qui fournit une documentation riche sur les capacités des macros d’OOo. Beaucoup de références de qualité sont disponibles sur :  http://www.pitonyak.org/oo.php

	OOo.HG
	Des ressources pour l'Histoire-Géographie : http://ooo.hg.free.fr/


Qu’implique la migration initiale ?

Partager des fichiers

Reportez-vous au chapitre 2 (« Partager des fichiers avec des utilisateurs de Microsoft Office ») de ce guide pour obtenir des informations sur la façon d’ouvrir et d’enregistrer des fichiers de formats variés.

Comment importer les autres fichiers utilisés par Microsoft Office ?

Consultez le chapitre 3 (« Importer d'autres éléments de Microsoft Office ») de ce guide pour obtenir des informations sur l’importation des dictionnaires personnalisés, les listes d’auto-correction ainsi que les entrées AutoText dans OpenOffice.org.

Que dois-je changer à ma façon de travailler ?

Bien que les interfaces d’OpenOffice.org et de Microsoft Office soient suffisamment proches pour permettre une prise en main immédiate, elles ne sont pas identiques. Certaines fonctions sont basées sur des concepts sous-jacents différents. Les chapitres de ce guide vous renseigneront sur ces différences.

Concrètement, quelles différences d’usage y a-t-il entre OpenOffice.org et Microsoft Office  ?

Consultez d’abord le chapitre 4 de ce guide (« Généralités sur les différences pratiques entre OpenOffice.org et Microsoft Office »), car il donne une vue générale des différences, les autres chapitres construisant leur argumentation sur le contenu de ce chapitre.

Différences entre Writer et Word

Voyez le chapitre 5 de ce guide (« Différences pratiques entre Word et Writer ») pour des informations spécifiques liées aux documents texte.

Différences entre Calc et Excel

Lisez le chapitre 6 de ce guide (« Différences pratiques entre Calc et Excel ») pour des informations spécifiques liées aux tableurs.

Différences entre Impress et PowerPoint  ?

Consultez le chapitre 7 de ce guide (« Différences pratiques entre Impress et PowerPoint »)  pour une documentation spécifique aux présentations.

Comment puis-je personnaliser OpenOffice.org pour me rapprocher au mieux de la façon dont je travaillais  avec Microsoft Office ?

Consultez le chapitre 8 de ce guide (« Personnaliser OpenOffice.org ») pour obtenir des informations sur les changements à effectuer dans OpenOffice.org pour la faire fonctionner à votre convenance. Ce chapitre contient des liens vers des macros écrites pour faciliter la transition.

Y a-t-il un équivalent de  XE "WordArt" WordArt ?

Oui, il s'appelle Fontwork. Consultez le chapitre 2 (« Partager des fichiers avec des utilisateurs de Microsoft Office ») de cet ouvrage, à la section « WordArt et Fontwork (effets de texte) ». Ou pour plus d’informations, voyez le chapitre 15 (« Using Fontwork ») dans le « Getting Started Guide » (en anglais). 

Autres Modules

OOo comprend aussi un éditeur d'équations appelé Math, pour lequel il existe des tutoriels à l'adresse suivante :
http://fr.openoffice.org/Documentation/Outils/index.html.
Ou de manière plus approfondie mais en anglais dans le chapitre 16 (« Objets Math ») du « Writer Guide ».

Un nouveau module « Base » pour la gestion de bases de données a été créé depuis la version 2.0. Informations et tutoriels : http://fr.openoffice.org/Documentation/How-

 HYPERLINK "http://fr.openoffice.org/Documentation/How-to/indexht-base.html"
to/indexht-base.html, ou en anglais le chapitre 10 (« Starting with Base ») du « Getting Started Guide » (en anglais), et le « Database Guide » pour de plus amples détails.

Quels problèmes peuvent survenir lors de la migration de  XE "WordPerfect" WordPerfect vers Writer ?

Puis-je ouvrir les fichiers WordPerfect dans OOo ?

Oui, un filtre WordPerfect est désormais disponible dans l’installation standard d’OpenOffice.org.

Quelles macros sont disponibles pour rendre le fonctionnement de Writer plus proche de celui de WordPerfect ?

Montrer les codes

Writer d’OpenOffice.org n’a pas de codes sous-jacents comme ceux de WordPerfect, mais une macro a été écrite pour donner un résultat similaire à « révéler les codes » de WordPerfect. Voyez RevealCodes3.sxw disponible à l’adresse  http://homepages.paradise.net.nz/hillview/OOo/ pour plus d’information.

Retrait négatif

Le concept du retrait négatif dans Writer est très différent de celui de WordPerfect. La meilleure solution dans OpenOffice.org est d’utiliser les styles. Cependant, pour faciliter la transition, consultez AltKeyHandler.sxw ou encore Indents.sxw sur  http://homepages.paradise.net.nz/hillview/OOo/ pour obtenir une macro se rapprochant de la façon dont WordPerfect implémente les retraits négatifs.

 XE "Quelles licences pour OpenOffice.org ?" Quelles licences pour OpenOffice.org ?
OpenOffice.org est distribuée sous licence  XE "LGPL (Lesser General Public licence)" LGPL (Lesser General Public licence) approuvée par l’OSI (Open Source Initiative). La définition de la licence LGPL peut être consultée sur le site web d’OOo à l’adresse : http://www.openoffice.org/licenses/lgpl_license.html (en anglais).

Pour plus d’informations sur le système de licence d’OOo, merci de vous reporter à l’adresse : http://www.openoffice.org/license.html (en anglais).

Qu’est-ce qu'un « logiciel libre » ?

Le développement du « logiciel libre » peut être résumé en quatre points essentiels qui s’inscrivent dans la «  XE "GPL (General Public License)" General Public License » (GPL) de la « Free Software Foundation » :

1) Le droit d’utiliser le logiciel pour tout usage.

2) La liberté de redistribuer le logiciel gratuitement ou contre une rétribution.

3) Accès à la totalité du code source du logiciel (en quelque sorte son « plan de montage »).

4) Le droit de modifier n’importe quelle partie du code source ou d’en utiliser des portions dans d’autres logiciels.

On trouve dans la Définition de l’Open Source une autre façon d’appréhender cette philosophie :

« L’idée fondamentale qui régit le logiciel libre est très simple : quand les programmeurs ont la possibilité de lire, de redistribuer et de modifier le code source d’un élément de logiciel, le logiciel évolue. On l’améliore, on l’adapte, on corrige des bogues. Et ceci peut se produire à une vitesse qui, comparée à la lenteur du développement traditionnel de logiciel, semble étonnante. » 

Pour plus d’informations sur les logiciels libres et « Open Source », visitez les sites Web suivants :

 XE "Open Source Initiative (OSI)" Open Source Initiative (OSI) :  http://www.opensource.org
 XE "OSI - Version française" Version française (Linux-France) :
http://www.linux-france.org/article/these/osd/fr-osd.html
 XE "Free Software Foundation (FSF)" 

 XE "Free Software Foundation (FSF)" Free Software Foundation (FSF) :  http://www.gnu.org
Licence GPL : http://www.gnu.org/licenses/gpl.html
Framasoft.net : http://www.framasoft.net/
Chapitre
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   Partager des fichiers avec des utilisateurs de Microsoft Office

Formats de fichiers

Cette section a pour but de donner une vue simplifiée des différents formats de fichiers d’OpenOffice.org.

OpenOffice.org stocke ses fichiers dans un format XML compressé (zippé). Ce format est lisible lorsque le fichier est décompressé. Il est documenté de manière ouverte et est disponible pour tous. Le format OpenDocument bénéficie de la norme ISO 26300.

	Remarque[image: image4.png]



	Certains utilitaires de compression vérifient uniquement l’extension du fichier, et pourraient ne pas reconnaître le fichier comme compressé. Pour ouvrir un fichier OpenDocument avec ce type d’utilitaire, il vous suffit de renommer le fichier avec l’extension .zip. 


À l’opposé, les fichiers de Microsoft Office sont stockés dans un format propriétaire qui n’est pas lisible, et qui n’est pas documenté de manière ouverte. Il s’agit de la principale cause de problèmes pour les développeurs de logiciels qui conçoivent des filtres pour importer et exporter des fichiers au format Microsoft Office.

Tableau 1 : Extensions des fichiers OpenOffice.org (les extensions des fichiers des versions OOo 1.1.x sont représentées entre parenthèses).

	Type du document
	Application
	Extension
	Équivalent MS Office

	Traitement de texte
	Writer
	odt (sxw)
	doc

	Modèle de traitement de texte
	Writer
	ott (stw)
	dot

	Modèle de document 
	Writer
	odm (sxg)
	doc

	Document HTML
	Writer
	HTML
	HTML

	Feuille de calcul 
	Calc
	ods (sxc)
	xls

	Modèle de feuille de calcul
	Calc
	ots (stc)
	xlt

	Dessin
	Draw
	odg (sxd)
	aucun

	Modèle de dessin
	Draw
	otg (std)
	aucun

	Présentation
	Impress
	odp (sxi)
	ppt

	Modèle de présentation
	Impress
	otp (sti)
	pot

	Équations mathématiques
	Math
	odf (sxm)
	aucun

	Graphiques
	Graphiques
	odc
	aucun

	Base de données
	Base
	odb
	mdb

	Remarque
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	OOo peut ouvrir des fichiers MSO. La réciproque n’est pas vraie : pour l’instant, Microsoft Office n’ouvre pas les formats OpenOffice.org.

Si vous avez besoin de transmettre des fichiers à un utilisateur de MSO, commencez par enregistrer votre fichier dans le format natif d’OpenOffice.org, puis enregistrez à nouveau votre fichier dans un des formats supportés par Microsoft Office. En procédant ainsi, vous aurez toujours votre original dans son format natif même s'il n'est pas traduit parfaitement aux formats de Microsoft Office.

OpenOffice.org ne peut pas ouvrir ou convertir directement les fichiers Microsoft Access (.mdb), mais peut cependant accéder aux données contenues dans les tables en utilisant DAO et ODBC. Pour plus d’informations, référez-vous aux tutoriels présents à cette adresse :

http://fr.openoffice.org/Documentation/How-to/indexht-base.html


Conversion en bloc

Pour utiliser OpenOffice.org afin de convertir un grand nombre de fichiers, cliquez sur Fichier > Assistants > Convertisseur de documents...

Avant d’effectuer une conversion en bloc de fichiers, assurez-vous que cela soit vraiment nécessaire. Lisez ce document jusqu’au bout pour avoir une appréciation des limites de ce processus de conversion.

	Remarque
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	Convertir un grand nombre de fichiers peut prendre du temps. Il est recommandé de vérifier dans un premier temps votre espace disque disponible, puis de démarrer la conversion à un moment où l’ordinateur ne sera plus utilisé avant un certain temps. En général, les fichiers OOo prennent moins de place que les fichiers Microsoft Office, mais par sécurité vous devriez allouer autant de place pour les fichiers convertis.


 XE "Ouvrir des fichiers" Ouvrir des fichiers

Ouvrir des documents traitement de texte

En plus du format natif OpenDocument (.odt et .ott), OpenOffice.org Writer peut importer les formats de traitement de texte suivants :

	Microsoft Word 6.0/95/97/2000/XP (.doc, .dot)
	 XE "Document WordPerfect" Document WordPerfect (.wpd)

	Microsoft  XE "Word" Word 2003 XML (.xml)
	WPS 2000/Office 1.0 (.wps)

	Microsoft Winword 5 (.doc)
	 XE "DocBook" DocBook (.xml)

	 XE "StarWriter" StarWriter les formats (.sdw, .sgl, .vor)
	 XE "Ichitaro" Ichitaro 8/9/10/11 (.jtd, .jtt)

	 XE "AportisDoc" AportisDoc ( XE "Palm" Palm) (.pdb)
	 XE "Hangul" Hangul WP 97 (.hwp)

	 XE "Pocket Word" Pocket Word (.psw)
	. XE "RTF (Rich Text Format)" rtf, .txt, . XE "CSV" csv

	OpenOffice.org 1.x (.sxw, .stw)
	


Lors de l’ouverture de fichiers .HTM ou . XE "HTML" HTML, OpenOffice.org adapte Writer pour travailler sur ces fichiers. 

Ouvrir des  XE "Feuilles de calcul" feuilles de calcul

En plus du format natif OpenDocument (.ods et .ots), OpenOffice.org Calc peut importer les formats de feuille de calcul suivants :

	Microsoft  XE "Excel" Excel 97/2000/XP (.xls, .xlw, .xlt)
	Rich Text Format (.rtf)

	Microsoft Excel 4.x–5/95 (.xls and .xlw, .xlt)
	Text CSV (.csv et .txt)

	Microsoft Excel 2003 XML (.xml)
	 XE "Lotus 1-2-3" Lotus 1-2-3 (.wk1 and .wk1)

	 XE "Data Interchange Format" Data Interchange Format (.dif)
	 XE "StarCalc" StarCalc formats (.sdc, .vor)

	 XE "dBase" dBase (.dbf)
	 XE "SYLK" SYLK (.slk)

	Fichiers .htm et .html incluant Requête page web
	 XE "Pocket Excel" Pocket Excel (pxl)

	 XE "Quattro Pro" Quattro Pro 6.0 (.wb2)
	OpenOffice.org 1.x (.sxc, .stc)


Ouvrir des  XE "Présentations" présentations

En plus du format natif OpenDocument (.odp et .otp), OpenOffice.org Impress 2.3 peut importer les formats de présentation suivants :

	Microsoft  XE "PowerPoint" PowerPoint 97/2000/XP (.ppt, .pps)
	 XE "Computer Graphics Metafile" Computer Graphics Metafile  XE "CGM" (.cgm)

	Modèles Microsoft PowerPoint 97/2000/XP
(.pot)
	 XE "StarDraw" StarDraw,  XE "StarImpress" StarImpress (.sda, .sdd, .sdp, .vor)

	OpenOffice.org 1.x (.sxi, .sti)
	


Ouvrir des Documents graphiques

En plus du format natif OpenDocument (.odg et .otg), OpenOffice.org Draw peut importer les formats de documents graphiques suivants :

	BMP
	JPEG, JPG
	PCX
	PSD
	SGV
	WMF

	DXF
	MET
	PGM
	RAS
	SVM
	XBM

	EMF
	PBM
	PLT
	SDA
	TGA
	XPM

	EPS
	PCD
	PNG
	SDD
	TIF, TIFF
	SXD

	GIF
	PCT
	PPM
	SGF
	VOR
	STD


Ouvrir des documents d’équations mathématiques

En plus des documents d’équations mathématiques, OpenOffice.org Math peut ouvrir les fichiers  XE "StarMath" StarMath (.smf) et  XE "MathML" MathML (.mml)

Lorsque vous ouvrez un document Word contenant un objet « éditeur d’équations », sélectionnez la case à cocher [C] pour MathType vers OpenOffice.org Math/OpenOffice.org Math vers MathType dans Outils > Options > Chargement/Enregistrement > Microsoft Office et l’objet sera automatiquement converti en objet OpenOffice.org Math.

 XE "Enregistrement des fichiers" Enregistrement des fichiers

Format de fichier par défaut

OpenOffice.org enregistre ses fichiers dans le format OpenDocument par défaut. Ce format par défaut peut être modifié, par exemple, si l’on veut  toujours enregistrer en fichiers Microsoft Office. Pour modifier le format par défaut :

1) Allez dans Outils > Options > Chargement/Enregistrement  > Général (Figure 1)

2) Dans la section Format de fichier par défaut de cette fenêtre, choisissez un type de document (par exemple « Document texte ») et un format de fichier de la liste Enregistrer systématiquement comme.

3) Répéter la manipulation pour chaque type de document 

4) Cliquez sur OK pour enregistrer vos modifications
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	Remarque
	Si l’option « Avertir lorsque l’enregistrement est réalisé dans un format autre qu’OpenDocument ou le format par défaut » est cochée dans la fenêtre Option > Chargement/enregistrement > Général (Figure 11), une boîte de dialogue vous avertissant d’une éventuelle perte dans la mise en forme peut apparaître. Dans la plupart des cas, on ne déplorera aucune perte. Cette option pouvant à la longue devenir agaçante, il vous est possible de la désactiver.

Le Java Runtime Environment est nécessaire à l’exécution des formats pour appareils portables tels que  XE "AportisDoc" AportisDoc ( XE "Palm" Palm),  XE "Pocket Word" Pocket Word et  XE "Pocket Excel" Pocket Excel. 


Exporter en PDF et en XHTML

Chaque application a la possibilité d’exporter directement en PDF (Portable Document Format). Ce format standard de compression et de visualisation universelles est idéal pour envoyer un fichier devant être consulté dans Adobe Reader ou tout autre programme d’affichage de PDF, quel que soit le système d’exploitation.

Vous pouvez directement exporter un document au format PDF en utilisant le bouton de la barre d’outils situé à gauche de l’icône Imprimante, ou en choisissant Fichier > Exporter au format PDF... Passer par le menu permet de régler certains paramètres, tels que la qualité, la vue initiale ou la sécurité.

Pour exporter en XHTML, allez dans Fichier > Exporter... et choisissez XHTML dans le menu déroulant Format de fichier.

Enregistrer des fichiers dans un format différent

Pour enregistrer un fichier dans un format différent, allez dans Fichier > Enregistrer sous... et sélectionnez un format dans la liste déroulante de Type de Fichier (Figure 2).
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Formats d'enregistrement possibles avec Writer

En plus de ses formats natifs (.odt et .ott), Writer peut enregistrer dans les formats suivants :

	OpenOffice.org Writer 1.x (.sxw, .stw)

Microsoft  XE "Word" Word 97/2000/XP (.doc)

Microsoft Word 95 (.doc)

Microsoft Word 6.0 (.doc)

Microsoft Word 2003 XML (.xml)

Microsoft  XE "Pocket Word" Pocket Word (.psw)

 XE "DocBook" DocBook (.xml)

 XE "AportisDoc" AportisDoc ( XE "Palm" Palm) (.pdb)

 XE "RTF (Rich Text Format)" Rich Text Format (.rtf)
	 XE "StarWriter" StarWriter 5.0 (.sdw)

StarWriter Template (.vor)

StarWriter 4.0 (.sdw)

StarWriter 4.0 Template (.vor)

StarWriter 3.0 (.sdw)

StarWriter Template 3.0 (.vor)

Text (.txt)

Text Encoded (.txt)

 XE "HTML" HTML (.html, .htm XE "Compagnon Office " )


	Remarque
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	Le format .rtf est généralement utilisé pour transférer des fichiers texte entre des applications, mais des pertes de mise en forme et d’images peuvent se produire quand le fichier est ouvert dans Microsoft Office. Le meilleur moyen d’ouvrir un fichier Writer dans Microsoft Word est d’enregistrer ce fichier en format Microsoft Word 97/2000/XP (.doc).


Formats d'enregistrement possibles avec Calc

En plus de ses  formats natifs (.ods et .ots), Calc peut enregistrer dans les formats suivants :

	OpenOffice.org Calc 1.x (.sxc, .stc)
	 XE "Data Interchange Format" Data Interchange Format (.dif)

	Microsoft  XE "Excel" Excel 97/2000/XP (.xls, .xlw)
	 XE "dBase" dBase (.dbf)

	Microsoft Excel 97/2000/XP Template (.xlt)
	 XE "SYLK" SYLK (.slk)

	Microsoft Excel 95 (.xls, .xlw)
	Text  XE "CSV" CSV (.csv; .txt)

	Microsoft  XE "Pocket Excel" Pocket Excel (.pxl)
	 XE "StarCalc" Formats StarCalc (.sdc, .vor)

	Microsoft Excel 2003 XML (.xml)
	HTM and  XE "HTML" HTML files


Formats d'enregistrement possibles avec Impress

En plus de ses formats natifs (.odp et .otp), Impress peut  enregistrer dans les formats suivants :

	Microsoft  XE "PowerPoint" PowerPoint 97/2000/XP (.ppt, .pps)

	Microsoft PowerPoint 97/2000/XP Template (.pot)

	 XE "StarDraw" StarDraw,  XE "StarImpress" StarImpress (.sda, .sdd, .vor)


Impress peut aussi exporter vers MacroMedia Flash (.swf), ainsi que dans les différents formats de documents graphiques de Draw énumérés ci-dessous.

Formats d'enregistrement possibles avec Draw

Draw ne peut enregistrer que dans ses formats natifs et en format StarDraw, mais il peut exporter en :

	BMP
	MET
	PPM
	WMF

	EMF
	PBM
	RAS
	XPM

	EPS
	PCT
	SVG
	

	GIF
	PGM
	SVM
	

	JPEG, JPG
	PNG
	TIFF
	


Formats d'enregistrement possibles avec l’éditeur HTML

	Document HTML (.html, .htm)

	OpenOffice.org 1.0 Modèle (.stw)

	Modèle de document HTML (.oth)

	StarWriter/Web 5.0 et 4.0 Modèle (.vor)

	Texte (OpenOffice.org Writer/Web) (.txt)

	Texte codé (OpenOffice.org Writer/Web) (.txt)


L'éditeur HTML peut également exporter un fichier texte au format  XE "MediaWiki" MediaWiki. Pour ce faire, allez dans le menu Fichier > Exporter... et choisissez MediaWiki.

 XE "Objets OLE (Object Linking and Embedding)" Les objets OLE (Object Linking and Embedding)

Pour changer les paramètres des objets Microsoft Office OLE, utilisez le menu Outils > Options > Chargement/enregistrement > Microsoft Office.

Si toutes ces options sont cochées, alors tous les objets inclus seront convertis et donc éditables dans les deux suites bureautiques.

Pour les autres types d’objets OLE, cela dépend de la machine sur laquelle sont édités les fichiers, comme dans Microsoft Office. Bien sûr, des objets OLE issus d’applications Windows ne seront pas éditables dans OpenOffice.org sous  XE "Linux" Linux bien que les objets s’affichent correctement et puissent être redimensionnés.


[image: image8]
Fichiers liés

Sous Microsoft Office il est possible de lier le contenu de plusieurs documents en gardant une liaison avec le fichier source. Par exemple quand vous copiez des cellules depuis Microsoft Excel, vous pouvez les coller sous Microsoft Word. Si sous Word vous faites un collage spécial, vous avez deux possibilités : un coller tout simple, avec plusieurs options ; ou un coller avec liaison, avec plusieurs options également. Sous OpenOffice.org, vous ne pouvez pas copier avec liaison. Par conséquent si sous OpenOffice.org vous ouvrez un fichier au format Microsoft Office contenant une telle liaison, vous perdrez cette liaison.

De même, quand un graphique est copié depuis Microsoft Excel avec un collage spécial avec liaison dans  Microsoft Word, et que ce fichier est ouvert dans Writer, alors le graphique n'apparaîtra pas.

	Attention
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	Les liens des fichiers Microsoft Office entre Word et Excel sont perdus quand les fichiers Microsoft Office sont modifiés avec OpenOffice.org.

Par contre si vous ne faites qu'ouvrir ces fichiers sans les modifier, les liens persistent.


 XE "WordArt" WordArt et  XE "Fontwork (effets de texte)" Fontwork (effets de texte)

Le module d’effets de texte équivalent à WordArt de Microsoft Word se nomme FontWork dans la suite OpenOffice.org. Les objets WordArt sont convertis en objets Fontwork, mais ils peuvent alors avoir un aspect visuel qui diffère quelque peu.

De même, les objets Fontwork sont convertis automatiquement en objets WordArt quand le document est enregistré au format Microsoft Office.

Dessins en mode vectoriel

Les formes vectorielles de base (lignes, flèches, rectangles et ovales) sont toutes importées et exportées sans aucun problème. OpenOffice.org offre un degré de contrôle de certaines propriétés plus élevé que Microsoft Office, ce qui génère parfois des différences lors du passage entre OpenOffice.org et Microsoft Office. Par exemple, la taille des flèches et les styles de lignes peuvent varier de l’un à l’autre.

Les formes automatiques de Microsoft Office, telles les smileys (petites têtes de bonshommes) conservent leurs caractéristiques, par exemple la possibilité d’ajuster le degré de sourire ou de grimace de la tête.

Microsoft Office offre plus d’options pour les styles d’ombre. Lors de l'importation l’aspect peut donc parfois changer. Les styles d’ombre 1, 2, 5, 6, 14, 17 et 18 sont supportés par OpenOffice.org.

Les effets 3D sont importés et exportés sans aucun problème, à part parfois quelques petites variations dans les angles de rotation.

Trames et cadres texte

Lorsque des trames et des cadres texte issus de Microsoft Office sont importés dans OpenOffice.org avec du texte lié, le lien existe toujours, mais est souvent mal rendu. Il faut appuyer soi-même sur Entrée pour faire passer le texte d'un cadre vers un autre.

En revanche l'export d'OpenOffice.org Writer vers Microsoft Word fonctionne très bien.

 XE "Contrôles de formulaires" Contrôles de formulaires

Les contrôles de formulaires de Microsoft Office, disponibles dans la barre d’outils Formulaire sont tous importés sans aucun problème. Cependant, ces contrôles utilisant des macros, ils seront sans aucune utilité, du fait de l’absence de macros construites spécifiquement pour OpenOffice.org.

 XE "Macros" Macros

OpenOffice.org ne peut pas exécuter les macros Microsoft Office. Bien que les langages des macros soient très semblables, les objets sous-jacents sont différents. Pour qu’OpenOffice.org garde les macros incluses dans les documents Word, Excel et PowerPoint (de telle sorte qu’elles soient toujours disponibles dans  Microsoft Office), il faut utiliser Outils > Options > Chargement/Enregistrement > Propriétés  XE "VBA" VBA.

	Remarque
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	On ne court pratiquement aucun risque en ouvrant dans OpenOffice.org un document Microsoft Office infecté par un virus.


Cependant, Novell et Sun travaillent conjointement à l'intégration du support des macros en VBA de Microsoft Office dans OpenOffice.org. Ce support n'est pas encore intégré par défaut car il n'est pas encore efficace à 100%. Mais vous avez toujours la possibilité d'utiliser cette fonction en installant une extension, OOOP-accessories, que vous trouverez sur la page du projet OxygenOffice Professional : http://sourceforge.net/projects/ooop
Une autre version non officielle de OpenOffice.org propose cette possibilité directement : http://go-oo.org/
Et inversement, les macros enregistrées avec le StarBasic d'OpenOffice.org ne peuvent être exécutées avec Microsoft Office.

Problèmes d’importation, d’exportation et de partage des documents texte

Utilisation correcte des documents 

Il est possible d’éviter certains problèmes en appliquant quelques règles simples : 

· Utiliser plutôt les styles de caractère et de paragraphe plutôt que de mettre en page votre texte manuellement. 

· Utiliser le formatage de paragraphe pour les espaces avant et après plutôt que le retour à la ligne, particulièrement pour les listes contenant des puces ou des numéros. 

· Utiliser les propriétés d’enchaînement de paragraphes (par exemple, garder le style de suite) plutôt que les sauts de page manuels. 

· Éviter d’aligner le texte avec de nombreux espaces ou tabulations, vous pouvez vous servir du formatage de tabulation ou, mieux encore, utiliser la fonction d’alignement du texte. 

· N’utiliser que des polices de caractères courantes. 

Réglages de compatibilité dans OpenOffice.org pour le document actif

Les réglages suivants modifient la façon dont OpenOffice.org travaille avec le document actif pour le rendre compatible avec Microsoft Office. 
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Utilisez Outils > Options > OpenOffice.org Writer > Compatibilité (Figure 4). 

Ajout d’un espacement de paragraphe et de tableau en début de page (document actif) 

Dans Writer, lorsque cette option est décochée, si un paragraphe en haut de page (ou une colonne) est formaté avec un espace au-dessus, cet espace est ignoré, alors que dans Word il est inclus. Si cette option est cochée, Writer gérera l’espace comme le ferait Word. 

Utiliser le formatage de tabulation OpenOffice.org 1.1

Cette option indique si les paragraphes centrés et alignés à droite contenant des tabulations sont mis en forme en un bloc centré ou aligné à droite. Si cette case est cochée, seul le texte à droite de la dernière tabulation est aligné à droite, alors que le texte à gauche reste tel quel.

Utiliser l’interligne OpenOffice.org 1.1 

Writer prend en compte le plus grand des deux espacements au-dessus et en dessous des paragraphes ; Microsoft Word fait la somme des deux. Décochez cette option pour que Writer agisse de la même façon que Word. 

Caractères et espacement des caractères 

Les animations de texte sont importées par Writer sous l’attribut clignotement depuis les fichiers Word. Par exemple « Défilé de tirets rouge » devient simplement « clignotement ». 

Dans Word, l’espace entre les caractères en mode normal est plus petit que dans Writer. Vous aurez alors souvent l’impression que Word peut faire entrer plus de caractères par ligne. Il est également possible que l’espacement entre les lignes soit légèrement différent. Le résultat final est que les changements de page se font à des endroits différents du texte. 

Tableaux 

L’auteur n’a pas identifié de problème avec les tableaux. 

Documents de publipostage 

OpenOffice.org possède une approche différente des sources documentaires. Lors de l’importation d’un document Microsoft Word qui est le document principal d’un publipostage, il n’y a pas de connexion avec les sources documentaires. Il ne suffit pas simplement de créer cette connexion, mais chaque champ doit être inséré de nouveau. Vous pouvez vous référer à la partie Publipostage dans le chapitre 5 intitulé « Différences pratiques entre Writer et Word ». Ou pour plus de renseignements, allez consulter les tutoriels d'OpenOffice.org-fr : http://fr.openoffice.org/Documentation/Index.html
Dans Word également, vous pouvez utiliser un autre document Word comme source documentaire pour un publipostage. Dans OpenOffice.org, il n’est pas possible d’indiquer un document Word (ou Writer) comme document source. 

Writer ne possède pas d’option permettant de supprimer les lignes vides quand un champ de données est laissé en blanc, vous devez utiliser des champs conditionnels. 

Writer fusionne les champs exportés sous forme de texte avec le nom du champ entre crochets, par exemple <Nom>. 

Résumé : pour travailler dans un environnement partagé, il faudrait un document différent pour chaque « document principal » : un au format Word, un autre au format OpenOffice.org. Si vous avez un document de publipostage maître au format Word, il serait sûrement plus simple de copier le texte dans Writer et d’utiliser l’assistant de publipostage de Writer pour recréer le document de publipostage depuis le début. 

Formulaires 

Problèmes rencontrés avec les formulaires créés sous Microsoft Office 

Un document verrouillé sous Microsoft Office ne le sera plus après importation dans OpenOffice.org (cette remarque concerne le mode création). 

Les champs de texte de formulaire sont importés dans OpenOffice.org comme des champs de saisie et par conséquent perdent leur type. Par exemple, un champ de texte de type « nombre » ou « date » acceptera n’importe quel texte. Quand on l’utilise sous OpenOffice.org, le champ de texte affiche une boîte de dialogue pour entrer le texte. Quand on utilise à nouveau le document sous Microsoft Office, les champs de texte se transforment en champs « Remplissage ». La date et l’heure courantes ainsi que les calculs sont importés comme du texte simple.

L’importation et l’exportation des cases à cocher ne posent pas de problème. 

Les menus déroulants sont importés en tant que champs de saisie de liste. Comme les champs de texte de formulaire, ils affichent une boîte de dialogue dans laquelle l’utilisateur peut choisir une option. Lors de l’exportation vers Microsoft Office, ils s’affichent à nouveau comme des menus déroulants. 

Problèmes avec les formulaires créés sous OpenOffice.org 

Les contrôles sont exportés comme des contrôles actifs lorsqu’un équivalent existe sous Microsoft Office. Comme Word et Writer ne partagent pas la même base de fonctionnalités et que les macros ne sont pas compatibles, il est très difficile d’avoir un formulaire fonctionnant sur les deux plateformes en utilisant des contrôles standards. 

Pour résumer, travailler dans un environnement partagé avec des formulaires n’est pas chose aisée, mais une astuce consisterait à utiliser d’autres champs comme des champs de saisie et des listes de saisie. Pour ajouter ces champs, utilisez : Insertion > Champ > Autres... > Fonctions. 

Notes de pied de page, notes de fin d’ouvrage, sommaire et index

Les notes de pied de page, les notes de fin d’ouvrage et les index s’importent et s’exportent correctement. Quelques problèmes ont cependant été rencontrés : 

· L’emplacement des notes de fin d’ouvrage peut varier (dans Word, les notes de fin sont placées avant l’index. Dans Writer, elles le sont toujours à la fin du document).

· Les entrées bibliographiques de Writer sont transformées en texte sous Word. 

· Un index à 3 colonnes exporté de Writer vers Word conserve les trois colonnes, mais si l’on repasse de Word à Writer, la mise en forme n’est pas conservée, et l’on n’obtient plus qu’une seule colonne. 

· Lors de l’importation de documents Word contenant des champs d’entrée d’index, ceux-ci sont importés comme des champs à la gauche du texte plutôt que comme des champs contenant le texte. 

Pour résumer, travailler dans un environnement partagé est possible, mais avec quelques petits inconvénients. 

Numérotation des paragraphes, numérotation automatique, renvois 

La numérotation des paragraphes, la numérotation automatique ainsi que les renvois s’importent et s’exportent sans problème, à l’exception des références aux paragraphes numérotés : 

· Les renvois aux numéros des paragraphes numérotés par la numérotation automatique ne fonctionnent pas, car Writer ne gère pas cette fonction. 

· Writer ne possède pas non plus de fonction de numérotation relative dans ses renvois aux nombres. 

· Le renvoi au numéro de chapitre n’utilise pas le même formatage que celui qui est affiché. 

Numérotation des pages 

Une manière rapide et peu élégante sous Word pour ne pas commencer la numérotation des pages à la toute première (afin d’obtenir une page de garde par exemple) et de commencer la numérotation par la seconde page consiste à gérer différemment la première page et à lui attribuer le chiffre zéro. Malheureusement, lors de l’importation dans OpenOffice.org, le numéro de la deuxième page sera 2 à la place de 1. Pour régler ce problème dans Writer :

1) Créer un style de page pour la mise en page des pages au-delà de la première. Le nommer (par exemple) Conversion1. 

2) Placer votre curseur dans le premier paragraphe de la seconde page. 

3) Aller dans le menu Format > Paragraphe > Enchaînements 

4) Dans la partie Sauts de la boîte de dialogue sélectionner Insérer. 

5) Cocher la case Avec le style de la page. 

6) Choisisser le style de page créé dans la première étape. 

7) Garder l'option Devant dans Position et sélectionner 1 pour le numéro de page. 

Quand vous exporterez ce document sous Word, cela fonctionnera, la seule différence étant que le document aura un saut de page en fin de première page. Les documents ainsi créés sous Word avec des sauts de page supporteront sans problème l’importation/exportation avec Writer. Il existe une différence avec Word : il y aura une page blanche entre la page de garde et la page suivante lors de l’impression (ou de l’aperçu avant impression). 

Lorsque l’auteur a testé un document avec différents formats de numérotation pour les pages paires et impaires, les numéros des pages impaires étaient importés comme du texte et non comme un champ. 

Pour résumer, certains documents nécessitent quelques manipulations pour réparer la numérotation des pages après importation. Une fois corrigée, la numérotation des pages pour ces documents pourra être importée/exportée sans problème. 

Les champs « date » et « heure » 

Les fonctions de Word CreateDate et SaveDate ne sont pas importées sous le même format. Par exemple, si les champs dans le document Word sont dans un format qui inclut l’heure, alors ces informations ne seront pas toujours affichées par défaut. Pour ajouter l’heure : 

Faites un clic droit sur le champ > Champs , parcourez jusqu’en bas le menu déroulant Formats > Autres formats... , dans le code du format ajoutez HH:MM:SS 

Lors de l’exportation les fonctions SaveDate/ DocInformation:Modified sont exportées sous forme de texte. 

Les champs de Writer Heure (fixe) et Date (fixe) sont exportés sous forme de texte. 

Importer des champs Word

Tableau 2: Conversion des champs Word importés

	Champ Word :
	Conversion dans Writer :

	ASK 
	Champ de saisie (Input field) 

	AUTHOR 
	DocInformation:Created 

	AUTONUM 
	Number Range AutoNr 

	AUTONUMLGL 
	Number Range AutoNr 

	AUTONUMOUT 
	Number Range AutoNr 

	COMMENTS 
	DocInfomation:Comments 

	CREATEDATE 
	DocInformation:Created 

	DATE 
	Date 

	EDITTIME 
	DocInformation:Modified 

	FILENAME 
	File name 

	FILLIN 
	Input field 

	HYPERLINK 
	(comme un lien hypertexte) 

	INFO xxx 
	DocInformation:xxx 

	KEYWORDS 
	DocInformation:Keywords 

	LASTSAVEDBY 
	DocInformation:Modified 

	MACROBUTTON 
	(le nom de la macro?) 

	MERGEFIELD 
	Mail merge fields (affiché comme le nom du champ) 

	MERGEREC 
	Record number 

	NEXT 
	Next record 

	NOTEREF 
	Show variable 

	NUMCHARS 
	Statistics (with select = Characters) 

	NUMPAGES 
	Statistics (with select = Pages) 

	PAGE 
	Page numbers 

	PAGEREF 
	Bookmarks (displayed as name of bookmark) 

	REVNUM 
	DocInformation:Document number 

	SAVEDATE 
	DocInformation:Modified 

	SEQ 
	Number range 

	SET 
	Set variable 

	SUBJECT 
	DocInformation:Subject 

	TEMPLATE 
	Templates 

	TIME 
	Date 

	TITLE 
	DocInformation:Title 

	TOC 
	(Affiche le sommaire) 


Les champs suivants ne sont pas importés dans OpenOffice.org (seul le texte qu’ils affichaient lors de la dernière sauvegarde est montré) : =, IF, DOCPROPERTY, FILESIZE, LINK, LISTNUM, QUOTE, SECTION, SECTIONPAGES, STYLEREF, TOA, USERADDRESS, USERINITIALS, USERNAME. 

Les champs suivants sont ignorés lors de l’importation : AUTOTEXT, AUTOTEXTLIST, BARCODE, BIDIOUTLINE, DOCVARIABLE, EQ, GOTOBUTTON, INCLUDETEXT, LISTNUM, MERGESEQ, PRINT, RD, SKIPIF, SYMBOL, TA, TC. 

Le champ Word EDITTIME correspond au champ DocInformation:Modified de Writer lors de l’importation, mais la fonction est différente puisqu’il correspond à la date et l’heure de la dernière sauvegarde et non à la durée écoulée depuis que le document est ouvert pour y apporter des modifications. 

Problèmes d’importation, d’exportation et de partage des feuilles de calcul

Les champs de formulaires

Les zones de saisie avec menu déroulant, les boîtes de listes et les cases à cocher avec des liens vers des cellules de feuilles de calcul s’importent et s’exportent toutes correctement, bien qu’en raison du traitement des polices de caractère, le nombre de lignes affichées dans les boîtes de listes puisse varier légèrement. Dans Calc, soit les boîtes de listes autorisent la sélection multiple, soit elles ne l’autorisent pas, tandis que Microsoft Excel permet deux modes de sélection multiple : multiple et étendu. Dans Excel, un lien d’une boîte de liste en mode sélection multiple vers une cellule est ignoré (du moins dans Excel 2000 ; l’auteur n’a pas vérifié dans Excel XP). Dans Calc le lien fonctionne, mais si plus d’un élément est sélectionné, la valeur des cellules est fixée à #N/A.

Les boutons radio s’importent dans Calc, mais le lien vers les cellules fonctionne différemment. Dans Calc chaque bouton radio a son propre lien vers une cellule, déterminant sa valeur comme vraie ou fausse selon que l’option est sélectionnée ou non. Dans Excel, le lien de cellule renvoie le numéro du bouton radio sélectionné. En exportant des boutons radio vers Excel, ils perdent le caractère « radio » de leur mode de fonctionnement ; en d’autres termes, ils ne sont pas groupés de façon à ce que sélectionner l’un désélectionne les autres. Les barres de défilement et les compteurs sont désormais pris en charge dans Calc, mais ne peuvent pas encore être importés.

Fonctions 

Fonctions financières, scientifiques et statistiques

Dans Microsoft Excel, certaines fonctions financières acceptent des paramètres de chaîne pour les dates ; dans OpenOffice.org elles exigent un numéro de série et ne sont donc pas correctement importées dans Calc.

Fonctions de l’utilitaire d’analyse ToolPak 

Les fonctions fournies par ToolPak pour Microsoft Excel sont normalement converties en FONCTION_ADD dans  Calc et renvoient les mêmes résultats.

Autres fonctions qui diffèrent

La fonction LIREDONNEESTABCROISDYNAMIQUE de Microsoft Excel s'appelle GETPIVOTADATA sous OpenOffice.org Calc.

Pilote de données - Tableaux croisés dynamiques

Les pilotes de données sont l’équivalent pour Calc des tableaux croisés dynamiques d’Excel. Il existe cependant un certain nombre de restrictions. On peut importer les tableaux croisés dynamiques d’Excel dans Calc (bien que les cellules n’acceptent pas la mise en couleur des tableaux dynamiques) mais dès que l’on commence à travailler avec, ces restrictions deviennent évidentes.

Ces restrictions sont les suivantes :

· Il n’y a pas de rapport de graphique croisé dynamique, mais un Pilote de données peut servir de source de données pour un graphique.

· L’interface utilisateur autorise un maximum de 8 champs dans les zones de données, de lignes ou de colonnes. (Une interface alternative qui en autorise davantage est disponible ici : http://homepages.paradise.net.nz/hillview/OOo/ dans un document intitulé MyDataPilot3.ods).

· Il existe la possibilité de regrouper les données (par exemple, regrouper le champ date par semaine ou trimestre, mais pas par mois). La solution consiste à créer une nouvelle colonne avec une formule pour calculer le regroupement, par exemple  =Mois().

· On ne peut pas définir des formats différents pour des champs différents.

· Calc peut accepter des formules telles que « Différence de » ou « % de », mais ne peut pas avoir ses propres champs personnalisés (solution : créer de nouvelles colonnes pour calculer les valeurs souhaitées).

· Les options de l’API (interface de programmation) sont incomplètes pour écrire des macros qui fonctionnent avec les Pilotes de données -- par exemple, la possibilité de décider, par l’intermédiaire d’un autre programme comme le langage BASIC des macros d’OpenOffice.org, que les tableaux ont des totaux généraux ou qu’ils ont accès aux Pilotes de données créés à partir de données externes.

AutoFiltre

L’importation et l’exportation d’AutoFiltre se font correctement et les lignes qu’on désire masquer le sont. Il y a cependant un certain nombre de différences entre Microsoft Excel et Calc : 

· Il n’y a qu’un Autofiltre actif à la fois, pour un document de tableur, à moins qu’on utilise des noms de plages de base de données. Les lignes restent cachées, mais les menus déroulants de la première ligne disparaissent si l’on applique l’AutoFiltre ailleurs. Pour avoir plus d’un AutoFiltre actif à la fois, définissez un nom de plage de base de données (Données > Définir la plage) pour les données. Il sera alors possible  d’avoir plus d’un AutoFiltre actif sur une feuille (ce qu’Excel ne sait pas faire.)

· Les autres numéros de ligne visibles ne changent pas de couleur pour vous avertir qu’il y a un filtre en place.

· Les valeurs erronées n’apparaissent pas parmi les options des listes déroulantes quand des cellules de la colonne comportent des erreurs.

· Dans les listes déroulantes, l’équivalent du « Personnalisé » de Microsoft Excel est appelé « Standard ». 

Diagrammes 

Types de diagrammes proposés dans Excel, mais non dans Calc : 

· Barres de secteur est converti en Secteur Normal

· Secteurs de secteur est converti en Secteur Normal 

· Radar plein est converti en Radar Lignes Seules

· Radar avec marquage des données est converti en Toile Points et Lignes, mais dans le sens contraire des aiguilles d'une montre plutôt que dans le sens des aiguilles d'une montre d'Excel

· Bulles sont converties en diagrammes XY Lignes Seules

· Surface 3D est converti en Colonnes 3D Profond Boites

D’autres différences :

1) Les diagrammes sont plus lents à se mettre à jour sous Calc que sous Excel.

2) Il y a moins d’options pour gérer les axes de données. Par exemple, il n’y a pas d’option pour l’inversion de l’axe Y (valeurs négatives en haut, positives en bas). 

Formats des nombres

Il n’y a aucun format  « comptabilité » (avec le symbole monétaire au bord gauche de la cellule). Réserver sur la gauche une colonne qui contiendrait le symbole monétaire pourrait constituer une solution alternative.

Lignes de grille

Dans Microsoft Excel, les lignes de la grille sont une propriété de chaque feuille de travail (onglet). Dans Calc, c’est une propriété générale du document que vous pouvez modifier grâce au menu suivant :

Outils > Options > OpenOffice.org Calc > Affichage

Importation, exportation et partage de  XE "Présentations" présentations

Dégradés de couleurs et bordures

Impress ne gère pas certaines fonctionnalités de formatage de Microsoft PowerPoint. Par exemple, les dégradés à trois couleurs, les doubles et triples bordures, ou encore les bordures en rond-pointillés ne sont pas supportés.

Lors de l'importation de diapositives provenant de PowerPoint, Impress modifie les dégradés à trois couleurs en dégradés à deux couleurs, les doubles et triples bordures en simple bordure, et celles en rond-pointillés en tirets ultra-fins.

Pour améliorer le résultat de l’importation, n’hésitez pas à effectuer quelques ajustements dans PowerPoint avant d’importer votre présentation dans Impress.

Modifier les dégradés de trois couleurs en dégradés de deux couleurs, modifier les bordures doubles et triples en bordures simples avec une largeur adéquate peut s'avérer pertinent.

Les bordures de rond-pointillés, transformées en tirets ultra-fins durant l’importation, ressemblent de très près au style de PowerPoint et n’ont donc pas besoin d’être éditées manuellement.

Multimédia

Les commentaires audio ne sont pas supportés par Impress.

Il ne semble pas y avoir de réglages pour la personnalisation d’animations multimédia, comme la possibilité de jouer un son pour les diapos suivantes. 

Animations de diagrammes

Il n’y a aucune fonction d’effet dans les diagrammes comme c’est le cas dans PowerPoint, telle la présentation d’une série ou d’une catégorie à la suite. À l’importation, les diagrammes apparaissent simplement. Une façon de contourner cela est d’avoir plusieurs copies du diagramme, chacune avec l’affichage désiré.

Package pour CD-ROM

Cette option de Microsoft PowerPoint permet à un fichier PowerPoint d’être sauvegardé sur un CD ou tout autre support amovible, ceci en assurant que tous les fichiers relatifs y soient inclus. Cette fonctionnalité n’est pas incluse dans Impress, et il n’est pas possible d’ouvrir ces fichiers avec Impress.

Réglage des actions et des interactions

Microsoft PowerPoint permet d'exécuter ces actions à partir d'un clic avec la souris ou d'un pointage avec la souris. Impress ne propose ces interactions que lors d'un clic de souris, et non lors d'un simple pointage avec la souris. En conséquence, lors de l'importation d'une présentation PowerPoint les actions pointage avec la souris sont transformées en action de clic de souris. L'option qui permet sous Microsoft PowerPoint de mettre en surbrillance un objet au survol ou au clic de la souris n'existe pas sous Impress et sera donc ignorée lors de l'importation.

Les animations personnalisées de PowerPoint et les effets sur les objets d’Impress

L'application et le rendu des animations personnalisées de Impress sont très proches de celles utilisées par Microsoft PowerPoint. Vous trouverez un tableau de noms d'animations au chapitre 7 de cet ouvrage : « Différences pratiques entre Impress et PowerPoint ».

Transitions de Diapos PowerPoint/Impress 

Tout comme pour les animations personnalisées, le nom des effets de transition peut varier entre Microsoft PowerPoint et Impress. Pour plus de renseignements, rendez-vous au chapitre 7 de cet ouvrage : « Différences pratiques entre Impress et PowerPoint ».

Chapitre

3

   Importer d'autres éléments de Microsoft Office

Introduction

Ce chapitre explique comment importer les dictionnaires personnels et les enregistrements d’Insertion Automatique de Microsoft Office dans OpenOffice.org. L’auteur ne connaît pas de méthode simple pour importer les enregistrements de la fonction Correction Automatique de Microsoft Office dans OpenOffice.org.

Dictionnaires personnels

Les dictionnaires sont utilisés lors de la vérification orthographique de document. Les dictionnaires personnels sont des dictionnaires améliorés qui contiennent des mots applicables à certains secteurs ou activités, à des mots particuliers ou à des orthographes spécifiques. 

OpenOffice.org n’inclut pas de fonction d’importation des dictionnaires personnels de Microsoft Office. Cependant, une macro a été créée pour importer ces derniers. Voici un lien pour la télécharger : http://

 HYPERLINK "http://ooomacros.org/user.php" \l "114694"
ooomacros.org

 HYPERLINK "http://ooomacros.org/user.php" \l "114694"
/

 HYPERLINK "http://ooomacros.org/user.php" \l "114694"
user.php

 HYPERLINK "http://ooomacros.org/user.php" \l "114694"
#114694.

Pour importer les dictionnaires personnels de Microsoft Office, veuillez suivre les étapes décrites ci-dessous (les détails sont donnés dans les sections suivantes).

1) Créez un nouveau dictionnaire dans OpenOffice.org (facultatif) ;

2) Téléchargez le fichier contenant la macro ;

3) Localisez le lieu d’enregistrement des dictionnaires personnels dans Microsoft Word ;

4) Importez le dictionnaire dans OpenOffice.org.

Créer un nouveau dictionnaire dans OpenOffice.org

Cette étape est facultative. Vous pouvez ajouter des mots directement dans un dictionnaire existant de OOo.

1) Outils > Options > Paramètres Linguistiques > Linguistique > Nouveau.

2) Boîte de dialogue Nouveau dictionnaire de l'utilisateur (Figure 5) : Donnez un nom au dictionnaire.


[image: image11]
3) Choisissez une langue pour le dictionnaire si vous voulez le restreindre à cette langue ou bien laissez l’option [Toutes] sélectionnée.

4) Cliquez sur OK pour enregistrer votre choix et retournez sur la page précédente.

5) Cliquez sur OK pour fermer la boîte de dialogue Options.

Télécharger le fichier qui contient la macro

1) Dans un navigateur web, ouvrez la page http://www.ooomacros.org/user.php#114694 et cliquez sur le lien Download Dictionary Import/Export.

2) Une page de téléchargement SourceForge s’ouvre. Cliquez sur le lien ImportExportDictionary1-1.zip pour obtenir le fichier.

3) Choisissez un serveur alternatif près de chez vous pour améliorer la vitesse de téléchargement.

4) Enregistrez le fichier et mémorisez son emplacement.

5) Décompressez le fichier enregistré précédemment. Vous obtenez un fichier nommé ImportExportDictionary1-1.sxw.

Localiser le lieu d’enregistrement des dictionnaires personnels dans Microsoft Word

Dans Microsoft Word, choisissez Outils > Options > Grammaire et Orthographe > bouton Dictionnaires  Personnels. Recherchez le nom du dictionnaire personnel que vous voulez transférer. Le nom par défaut est PERSO.DIC.

L'emplacement par défaut est : C:\Program Files\Fichiers communs\Microsoft Shared\Proof\, mais dans les systèmes multi-utilisateurs, on le trouve parfois sous C:\Documents and Settings\Username\Application Data\Microsoft\Proof\. Dans Microsoft Word, le chemin d’accès s’affiche partiellement au bas de la boîte de dialogue Dictionnaires Personnels.

Vous pouvez aussi utiliser l’explorateur de Windows pour localiser un fichier. Pour PERSO.DIC, dans les dernières versions de Windows, vous aurez peut-être besoin d’inclure les fichiers cachés et systèmes dans votre recherche. 

Importer le dictionnaire dans OpenOffice.org

1) À partir de la version 2.3.0 d'OpenOffice.org, la sécurité des macros est élevée par défaut. Il faut régler ce paramètre sur moyen pour pouvoir exécuter correctement la macro d'import/export. Choisissez Outils > Options > OpenOffice.org > Sécurité > bouton Sécurité des macros. Dans la fenêtre Sécurité des macros, cochez Niveau de sécurité moyen. Validez votre choix en cliquant sur OK. Cliquez sur OK pour fermer la boîte de dialogue Options.

2) Ouvrez le fichier contenant la macro d’import/export téléchargé à l’étape 2 ci-dessus.

3) Une boîte de dialogue demandant l’autorisation pour exécuter les macros s’affiche. Cliquez sur Autoriser les Macros.

4) Cliquez sur le bouton  Run Macro (en haut du document).

5) Dans la boîte de dialogue Import & Export Dictionnary (Figure 6), au niveau du champ Text File, saisissez le chemin d’accès au dictionnaire personnel à importer ou cliquez sur le bouton pour aller sélectionner le fichier. Cliquez sur Ouvrir.

6) Dans la liste de choix, sélectionnez le dictionnaire OOo auquel vous voulez ajouter les mots ; il peut s’agir de celui que vous avez créé précédemment. 


[image: image12]
7) Cliquez sur Import. Deux boîtes de dialogue s’affichent l’une après l’autre. La première indique le nombre de mots présents le dictionnaire OOo auquel vous ajoutez des mots (si vous venez de créer le dictionnaire OOo, ce nombre est probablement 0) et la seconde affiche le nombre de mots contenus dans le dictionnaire OOo après l’importation. Cliquez sur OK pour fermer les deux boîtes de dialogue.

8) Cliquez sur Close dans la boîte de dialogue Import & Export Dictionary.

9) Fermez le fichier texte Import/Export – le tour est joué !

Pour vérifier que le dictionnaire personnel OOo contient tous les mots contenus dans celui de Microsoft Word, allez dans Outils > Options > Paramètres Linguistiques > Linguistique, sélectionnez le dictionnaire auquel les mots ont été ajoutés et cliquez sur Éditer. La liste des mots est affichée dans la boîte de dialogue Édition du Dictionnaire de l’utilisateur.

Les entrées dans AutoTexte

 XE "AutoTexte" AutoTexte permet de stocker du texte formaté ou du texte contenant des graphiques, des tableaux et des champs et d’insérer  rapidement les éléments ainsi enregistrés dans des documents.

OpenOffice.org stocke les entrées AutoTexte dans des fichiers au format XML situés dans des répertoires dédiés. Microsoft Word quant à lui stocke ses enregistrements d’Insertion Automatique dans des modèles de document, principalement dans Normal.dot. 

Pour importer les entrées d'Insertion Automatique d'un modèle Microsoft Word, suivez ces étapes :

1) Localisez le modèle Microsoft Word à partir duquel vous voulez importer les entrées d'Insertion Automatique. Généralement, les modèles se trouvent dans :
C:\Windows\Application Data\Microsoft\Templates, ou sous :
C:\Documents and Settings\Nom_de_l'utilisateur\Application Data\Microsoft\Templates.

2) Dans OOo, sélectionnez Édition > AutoTexte (ou appuyez sur Control+F3).

3) Vous pouvez créer une nouvelle catégorie ou utiliser une catégorie existante.

Pour créer une nouvelle catégorie :

1) Dans la boîte de dialogue AutoTexte (Figure 7), cliquez sur le bouton Catégories.

2) Dans la boîte de dialogue Édition des catégories, saisissez un nom pour la nouvelle catégorie, choisissez le chemin de sauvegarde voulu et cliquez sur le bouton Nouvelle. La nouvelle catégorie apparaît dorénavant dans la liste de sélection.
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Cliquez sur OK pour fermer la boîte de dialogue Édition des catégories et retournez à celle d’AutoTexte.

Pour importer les entrées d'Insertion Automatique :

1) Dans la boîte de dialogue AutoTexte, sélectionnez la catégorie dans laquelle vous voulez importer les entrées d'Insertion Automatique de Microsoft Word. Cliquez sur le bouton AutoTexte puis Importer.

2) Dans la fenêtre ouverte, sélectionnez le modèle Microsoft Word voulu et cliquez sur Ouvrir. Les enregistrements AutoTexte devraient être visibles dans la liste de gauche.

3) Cliquez sur Fermer.

Les enregistrements dans AutoCorrection

 XE "AutoCorrection" AutoCorrection est une fonction qui corrige automatiquement les mots au cours de la saisie. Vous pouvez ajouter des enregistrements à la fonction AutoCorrection pour personnaliser le fonctionnement d’OpenOffice.org.

L’auteur n’a pas trouvé de solution pour importer les enregistrements de la fonction Correction Automatique de Microsoft Office dans OpenOffice.org. Vous pouvez consulter un fil de discussion en anglais à ce sujet à l’adresse suivante :

http://

 HYPERLINK "http://www.oooforum.org/forum/viewtopic.php?t=10248"
www.oooforum.org

 HYPERLINK "http://www.oooforum.org/forum/viewtopic.php?t=10248"
/forum/

 HYPERLINK "http://www.oooforum.org/forum/viewtopic.php?t=10248"
viewtopic.php

 HYPERLINK "http://www.oooforum.org/forum/viewtopic.php?t=10248"
?t=10248.

Des informations de ce fil de discussion sont reportées ci-dessous, car il serait  possible d’importer grâce à elles la première centaine d’enregistrements.

Une macro Mircosoft Word est disponible à l’adresse http://

 HYPERLINK "http://word.mvps.org/FAQs/Customization/ExportAutocorrect.htm"
word.mvps.org

 HYPERLINK "http://word.mvps.org/FAQs/Customization/ExportAutocorrect.htm"
/FAQs/Customization/

 HYPERLINK "http://word.mvps.org/FAQs/Customization/ExportAutocorrect.htm"
ExportAutocorrect.htm pour créer un document Microsoft Word contenant les entrées d’Insertion Automatique.

Les fichiers AutoCorrection d'OpenOffice.org sont normalement stockés sous ./user/autocorr/acorrXXXX.dat (où XXXX correspond à un code pays donné). 

	Astuce
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	Vous pouvez obtenir une liste des codes pays de Microsoft Office Online: 
http://office.microsoft.com/fr-fr/help/HP052590231033.aspx


Ces fichiers zippés contiennent le fichier DocumentList.xml (si ce n’est pas le cas, le fichier crée par les enregistrements d’Insertion Automatique sera vide) ce qui donnera quelque chose ressemblant à :

<block-list:block-list> 
<block-list:block block-list:abbreviated-name="(C)" block-list:name="©"/> 
<block-list:block block-list:abbreviated-name="yuor" block-list:name="your"/> 
</block-list:block-list> 

Dans ce cas, il n’est pas difficile de créer un fichier texte semblable et de le zipper en le nommant acorrXXXX.dat.
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Chapitre

4

   Généralités sur les différences pratiques entre OpenOffice.org et Microsoft Office

Aide

Les fonctions d’Aide dans OpenOffice.org (OOo) sont similaires à celles que l’on trouve dans la suite Microsoft Office (MSO).

Passer le pointeur de la souris sur un bouton, une infobulle décrivant le bouton apparaît. Pour activer ou désactiver cette fonctionnalité, utiliser les menus suivants Outils > Options > OpenOffice.org > Général, et cocher l’option  XE "Infobulle" Infobulle.

Appuyer sur les touches Maj et F1 simultanément, ou sélectionner le menu Aide > Qu’est‑ce que c’est ?, ou cliquer sur le bouton  [image: image15.png]


, change le pointeur de souris en un point d’interrogation. Le pointeur de souris « point d’interrogation » positionné sur un bouton ou une zone dans une fenêtre de dialogue affiche une description plus détaillée jusqu’au clic suivant.

	Remarque
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	Appuyer sur les touches Maj et F1 simultanément équivaut à activer l’option  XE "Infoballon" Infoballon dans le menu Outils > Options > OpenOffice.org > Général, à la différence que  la fonctionnalité est valable jusqu’au clic suivant.


Sélectionner un objet : appuyer sur la touche F1 affiche une aide contextuelle sur cet objet.
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L’équivalent du « Compagnon Office » de MSO est ici appelé l’«  XE "Assistant" Assistant ».  Lorsqu'une aide est disponible sur un événement qui se produit, il s'active et prévient l'utilisateur, sauvegarde d'un fichier ou correction automatique d'un mot par exemple. 

L’Assistant peut être activé ou désactivé en utilisant le menu Outils > Options > OpenOffice.org > Général, et en cochant l’option Assistant.

 XE "Zoom" Zoom – le facteur d’agrandissement

Pour changer l’échelle de zoom à laquelle le document est affiché à l’écran, sélectionnez le menu Affichage > Zoom, ou faites un clic droit ou un double-clic sur le nombre suivi du signe % dans la barre d’état.

Dans Writer, l’option de zoom Optimal fait en sorte que le document soit affiché entre les marges droite et gauche.

Le facteur de zoom est automatiquement ajusté quand des panneaux latéraux sont affichés.

AutoCorrection et AutoFormat

Les fonctionnalités  XE "AutoCorrection" AutoCorrection et  XE "AutoFormat" AutoFormat fonctionnent quasiment de la même façon dans OpenOffice.org et dans Microsoft Office.

En plus de ces fonctionnalités, Writer possède une fonction  XE "Insertion automatique" insertion automatique. Si elle est activée, Writer essaiera de deviner quel mot vous êtes en train de saisir et vous offrira la possibilité de le compléter pour vous.

Pour accepter la suggestion, pressez Entrée. Dans le cas contraire, continuez votre saisie.

Les réglages de cette fonctionnalité (l’activer, la désactiver, changer la touche qui valide une suggestion...) sont accessibles par le menu Outils > AutoCorrection puis dans l’onglet Insertion automatique (Figure 8).
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 XE "Menus" Menus

Les menus d'OpenOffice.org sont similaires à ceux de Microsoft Office, mais l'emplacement de certaines fonctions peut parfois être différent. Par exemple, OOo considère que le format de la page est une question de format. Celui-ci se trouve donc dans le menu Format (Format > Page), contrairement à MSO, où il est situé dans le menu Fichier. De plus, OOo propose certaines fonctionnalités que MSO ne propose pas  (par exemple l’export vers le format PDF). 

Pour plus d’informations sur les réglages des menus (par exemple, ajouter/retirer des éléments), référez-vous au chapitre 8 de ce manuel, « Personnaliser OpenOffice.org ».

 XE "Menus personnalisés" Menus personnalisés

OpenOffice.org ne personnalise pas les menus (fonction menus personnalisés). Cette fonctionnalité, présente dans Microsoft Office, est celle qui réorganise les menus de telle sorte que ceux que vous utilisez le plus fréquemment soient affichés en premier et que ceux dont vous vous servez peu soient cachés.

Dans OpenOffice.org, la pertinence de certains éléments de menus  dépend de la position du curseur, et ils peuvent donc, dans certains cas, apparaître  inactifs et grisés. Par exemple, la fonction Trier (dans le menu Outils > Trier) n’est pas disponible si aucun texte n’est sélectionné.

Barres d’outils

L’emplacement et l'apparence de certaines icônes diffèrent de ceux établis par défaut dans MSO. De plus de nombreuses icônes, quand elles sont utilisées, peuvent devenir des sous-menus ou des sous-barres d’outils.

Il est possible d'ancrer des barres d’outils de OOo à différents endroits, ou de les rendre flottantes. Pour déplacer une barre d’outils, placez le pointeur de souris sur la poignée de la barre d’outils (ou de la barre de titre si la barre d’outils est flottante), gardez le bouton gauche de la souris enfoncé et déplacez la barre vers sa nouvelle position.

Les sous-barres d’outils sont toujours flottantes. Référez-vous au chapitre 4 « Menus and Toolbars » du manuel « Getting Started » (anglais), pour plus d’informations sur la façon de déplacer, ancrer et paramétrer les barres d’outils.

Pour obtenir des informations sur le paramétrage des barres d’outils (comme ajouter/retirer des icônes) se référer au chapitre 8 de ce manuel, « Personnaliser OpenOffice.org ».

Glisser-déposer

Le  XE "Glisser-déposer" glisser-déposer fonctionne dans OpenOffice.org, mêmes si les modifications visuelles du pointeur de souris dans OOo sont moins présentes que dans Microsoft Office. Par exemple, le pointeur se déplaçant sur une portion de texte sélectionné ne prend pas l'apparence d'une flèche, ce qui n'empêche pas pour autant d'effectuer un glisser-déposer classique.

En revanche, il n’y a pas d’équivalent dans OOo à la combinaison de touches Maj+Clic+déplacer.

Panneaux latéraux – fenêtres ancrées ou flottantes

Microsoft Office XP a introduit le concept de  XE "panneaux latéraux" panneaux latéraux, l’équivalent des fenêtres ancrées ou flottantes de OOo. Dans OOo ces fenêtres comportent :

1) Les navigateurs pour aider à se déplacer dans le document (l’équivalent dans MSO serait l’explorateur de document de Word).

2) Les styles et formatages pour gérer les styles.

3) La Gallery, une visionneuse de fichiers Cliparts.

4) L’Assistant de fonction, qui aide à créer de façon interactive des fonctions (uniquement disponible dans Calc).

5) Le navigateur de sources de données, à partir duquel il est possible de glisser-déposer des champs d’une base de données dans un document (disponible dans Calc et dans Writer).

Il n’y a pas d’équivalent à la fonction multi-copies du presse-papier de MSO.

 XE "Ancrer et désancrer" Ancrer et désancrer

Certaines fenêtres d’OpenOffice.org, telles que celle du Navigateur et celle de Styles et Formatage, sont ancrables. Vous pouvez les déplacer, les redimensionner ou les ancrer sur l’un des bords.

	Pour ancrer une fenêtre, utilisez une des méthodes suivantes : 

1) Cliquez et maintenez le bouton gauche enfoncé sur la barre de titre d’une fenêtre flottante, puis glissez-la sur le côté jusqu’à voir apparaître une boîte dans la fenêtre principale (Figure 9), puis relâchez le bouton. Cette méthode dépend de la configuration de votre gestionnaire de fenêtres, il se peut donc qu’elle ne fonctionne pas pour vous.

2) Appuyez sur la touche Ctrl et double-cliquez sur une partie neutre de la fenêtre flottante pour l’ancrer à la suite des autres barres d’outils. Si cela ne fonctionne pas, essayez en double-cliquant sans la touche Ctrl.
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Pour libérer une fenêtre, appuyez sur la touche Ctrl et double-cliquez sur une partie neutre de la fenêtre ancrée.

	Remarque
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	La fenêtre Styles et Formatage peut, de la même façon, être ancrée ou désancrée en utilisant la touche Ctrl et le double-clic dans la zone grisée, à côté des icônes en haut de la fenêtre.


Il est possible d’avoir deux fenêtres dans la même zone. Par exemple, la fenêtre Styles et Formatage et le Navigateur peuvent se positionner sur la droite de la fenêtre principale, l’une au-dessus de l’autre plutôt que l’une à côté de l’autre.

Les boutons visible/invisible et ancrer/désancrer sont alors utilisables pour les deux fenêtres ancrées.

Redimensionnement

Les fenêtres peuvent être redimensionnées en déplaçant leurs bordures. Quand le curseur se transforme en flèche à double-sens, cliquez et redimensionnez la fenêtre à votre convenance.

Le navigateur

Le navigateur (Figure 10) est activé/désactivé par la touche F5, par l’icône Navigateur [image: image18.jpg]


 dans la barre d’outils standard, ou par le menu Édition > Navigateur. Cette fenêtre affiche les différents objets du document courant et permet une navigation rapide. 

Certains détails peuvent différer d’une application à l’autre. Dans Writer, par exemple, le navigateur montre la liste des titres et s’utilise de façon similaire à l’explorateur de document Word de MSO. La liste déroulante en bas de la fenêtre du navigateur permet de sélectionner le document ouvert qui affiche ses informations dans le navigateur.

Pour plus d’informations, consultez la section « Using the Navigator », du chapitre 4 du manuel « Getting started» (anglais), « Menus and Toolbars », et les descriptions du navigateur dans les manuels respectifs de chaque application.
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Styles et formatage

La fenêtre Styles et formatage est activée/désactivée par la touche F11 (Figure 11), par l’icône Styles et formatage de la barre d’outils formatage, ou par le menu Format > Styles et formatage.
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Pour changer la catégorie d’éléments affichés, utiliser les boutons situés en haut de la fenêtre. Dans Writer, par exemple, les boutons sont Paragraphe, Caractère, Cadre, Page et Liste. La liste déroulante en bas de la fenêtre Styles et formatage détermine le type de style qui sera affiché dans la fenêtre. Dans Writer, les options pour les styles de caractères sont Hiérarchie, Tous les styles, Styles utilisés et Styles personnalisés.

Le style de la sélection courante apparaît en surbrillance dans la liste des styles.

Référez-vous au chapitre 6 « Introduction to styles » et au chapitre 7 « Working with styles » du « Writer Guide » (anglais) pour plus d’informations sur les types de styles et le fonctionnement des autres icônes de cette fenêtre.

Gallery
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La  XE "Gallery" Gallery (Figure 12) est activée/désactivée par le bouton Gallery [image: image19.png]


, dans la barre d’outils standard ou par le menu Outils > Gallery.

	Remarque
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	Il n’y a pas de raccourci clavier pour activer la Gallery.


La Gallery dans OpenOffice.org est l’équivalent de la Bibliothèque Multimédia de Microsoft Office, à cette différence près qu’elle n’est pas liée au Web et n’intègre pas de fonction de recherche. En effet, pour que le fichier d’installation de OOo soit le plus léger possible au téléchargement, seuls quelques ClipArts sont disponibles par défaut. Pour télécharger des ClipArts du domaine public, visitez l’adresse http://

 HYPERLINK "http://www.openclipart.org/"
www.openclipart.org

 HYPERLINK "http://www.openclipart.org/"
/.

Les médias dans la Gallery sont organisés en thèmes. Les thèmes sont affichés sur la partie gauche de la fenêtre Gallery.

Pour plus d’informations sur l’utilisation de la Gallery , lisez le chapitre 14, « Working with the Gallery » dans le guide « Getting started » (anglais).

Source de données

Le Navigateur de sources de données (Figure 13) est activé/désactivé par la touche F4, par l’icône Source de données [image: image21.png]


 dans la barre d’outils standard, ou par le menu Affichage > Sources de données.
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Un usage courant de cette fenêtre consiste à mettre en place un modèle pour du publipostage. Glisser-déposer les champs de la source de données pour créer ces champs dans le document courant.

Le Navigateur de sources de données s'ancre uniquement au-dessus de la fenêtre principale.

Pour plus d’informations sur l’utilisation des sources de données, référez-vous au chapitre 10 du manuel « Getting started » : « Getting Started with Base » (anglais).

 XE "Aperçu" Aperçu

Fichier > Aperçu dans OpenOffice.org est l’équivalent de Aperçu avant impression de Microsoft Office. Vous pouvez choisir de voir et d’imprimer des pages dans différents modes, une page, deux pages, plusieurs pages ou pages en regard (appelé « aperçu du livre »)

Le bouton Zoom dans OpenOffice.org permet de changer le facteur de zoom de la vue courante. Il ne permet pas de sélectionner la zone à agrandir grâce au pointeur de la souris.

Raccourcis clavier

Ces raccourcis claviers standards sont les mêmes que dans Microsoft Office :

1) Couper (Ctrl+X) 

2) Copier (Ctrl+C) 

3) Coller (Ctrl+V) 

4) Annuler (Ctrl+Z) 

5) Restaurer (Ctrl+Y) 

6) Enregistrer (Ctrl+S) 

7) Ouvrir (Ctrl+O) 

8) Nouveau (Ctrl+N) 

 XE "Balises actives" Balises actives

OpenOffice.org intègre maintenant les balises actives. La prise en charge de ces Smart Tags évolue de version en version.

Caractères spéciaux ou symboles

La fonction est accessible par le menu Insertion > Caractères spéciaux.

Vous ne pouvez pas saisir de caractères spéciaux dans OpenOffice.org par le biais de codes hexadécimaux standards comme dans Microsoft Office.

	Remarque
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	Il n’y a pas de deuxième onglet pour les caractères spéciaux courants tels que le tiret cadratin. Le contournement est d’utiliser les fonctionnalités de formatage automatique, d’autocorrection, ou encore d’enregistrer une macro. Un tutoriel existe :

http://www.framasoft.net/article4178.html


 XE "Gestion des fichiers" Gestion des fichiers

Emplacements par défaut

Utilisez Outils > Options > OpenOffice.org > Chemins pour déterminer les emplacements par défaut de vos fichiers. Les deux emplacements ayant un intérêt (pour l’instant) sont Mes documents et Modèles.

Pour Mes documents, il n’y a qu’un seul emplacement possible. Il n’est pas possible d’avoir un dossier spécifique pour chacune des applications de la suite OOo. Ce dossier est l’emplacement par défaut pour l’action Fichier > Enregistrer, et l’emplacement affiché par défaut dans les boîtes de dialogues Ouvrir et Enregistrer sous.

Pour les modèles, il est possible de spécifier plus d’un dossier. Ces dossiers s'affichent à gauche dans la boîte de dialogue qui apparaît lors de l’utilisation du menu  Fichier > Nouveau > Modèles et Documents.

Pour plus d’informations sur la définition des emplacements par défaut, référez-vous au chaptitre 5, « Setting Up OpenOffice.org » dans le manuel « Getting Started » (anglais).

Créer de nouveaux fichiers

Dans OpenOffice.org comme dans Microsoft Office, il existe différentes façons de créer de nouveaux fichiers. Une différence notable tient au fait que vous pouvez démarrer la création de n’importe quel type de fichiers OOo à partir de n’importe quelle application de la suite.

Par exemple, vous pouvez créer une feuille de calcul alors que vous êtes en train de travailler sous Writer.

Les différentes façons de créer un nouveau document sont :

1) Le menu Fichier > Nouveau.

2) Cliquer sur l’icône Nouveau dans la barre de fonction principale. Cette icône dispose d’une liste déroulante à sa droite permettant de choisir le type de fichier à créer.

3) À partir de l’icône « Démarrage rapide de OpenOffice.org ». 

4) La combinaison de touches Ctrl+N.

5) Avec l’assistant, par le menu Fichier > Assistants.

 XE "Gestion des modèles" Gestion des modèles

Pour faciliter l’utilisation de vos modèles, comme créer ou supprimer des dossiers (qui correspondent à des catégories) et importer des modèles dans ces dossiers, utilisez le menu :

Fichier > Modèle de document > Gérer > Double-clic sur le dossier concerné > Commandes .

Modèles par défaut

Chaque module de OOo ne possède qu’un modèle unique par défaut. Pour changer ce modèle par défaut :

1) Sauvegardez le modèle en cours par le menu Fichier > Modèle de document > Enregistrer.

2) Sélectionnez Fichier > Modèle de document > Gérer,

3) Double-cliquez sur le dossier dans lequel vous avez enregistré le modèle à l’étape 1.

4) Cliquez sur le modèle dont vous voulez faire le nouveau modèle par défaut.

5) Clic droit ou sélectionner Commandes, puis  Définir comme modèle par défaut.

	Remarque
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	Le modèle par défaut dans MSO est toujours un fichier appelé Normal.dot. Dans  OOo, il n’y a pas de nom spécifique pour les modèles par défaut. Ils peuvent avoir n’importe quel nom. Si aucun modèle n’a été spécifié, les propriétés du modèle par défaut sont celles implémentées directement dans OOo.


Boîtes de dialogues Ouvrir et Enregistrer sous
Si vous êtes sous Microsoft Windows, vous avez la possibilité d’utiliser soit les options d'OpenOffice.org (boîtes de dialogue Ouvrir et Enregistrer sous), soit les options fournies en natif par Windows. Pour voir ou modifier ces options, utilisez le menu Outils > Options > OpenOffice.org > Général > Utiliser les boîtes de dialogue OpenOffice.org.

Cette option est également disponible dans un environnement GNU/Linux.

	Remarque
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	Les boîtes de dialogue utilisées par Windows ne sont pas celles utilisées par Microsoft Office !


Cette section traite des boîtes de dialogue Ouvrir et Enregistrer sous d'OpenOffice.org. Voir la Figure 14 pour un exemple de la boîte de dialogue « Ouvrir ». La boîte de dialogue « Enregistrer sous » a un comportement similaire.

Les trois boutons en haut à droite sont, de gauche à droite :

1) Au répertoire supérieur dans la hiérarchie des dossiers. Si vous laissez le bouton de la souris enfoncé, au lieu de simplement cliquer, vous aurez accès à un plus grand choix de niveau de dossiers.

2) Créer un nouveau répertoire.

3) Répertoire par défaut, qui permet d’accéder au répertoire spécifié dans le menu Outils > Options > OpenOffice.org > Chemins.

Pour les documents OpenOffice.org qui ont été enregistrés dans plus d’une version, vous pouvez utiliser la liste déroulante « version » pour sélectionner la version que vous voulez visualiser en mode lecture seule.

	Remarque
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	Pour les documents Microsoft Office, seule la version courante peut être ouverte.
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Le champ Type de fichier fonctionne de la même façon dans OpenOffice.org et dans Microsoft Office ; utilisez-le pour spécifier le type de fichier à ouvrir ou le format sous lequel enregistrer le fichier.

La boîte à cocher « En lecture seule » permet d’ouvrir le fichier pour le lire ou l’imprimer uniquement. En conséquence, la plupart des barres d’outils et la plupart des options de menus sont désactivées. Une icône Édition de fichier est disponible dans la barre d’outils principale  pour permettre l’ouverture de ce fichier en édition. Le fichier ainsi ouvert ne peut être enregistré sous le même nom que le fichier initial.

Il est possible d’ouvrir des fichiers situés sur internet en utilisant leur URL. 

 XE "Gestion des fichiers" Gestion des fichiers dans les boîtes de dialogue Ouvrir ou Enregistrer sous OOo

Pour renommer un fichier :

1) Clic droit sur le nom d’un fichier pour faire apparaître un menu contextuel.

2) Cliquez sur Renommer, et le nom du fichier sera sélectionné.

3) La saisie remplace tout ou partie du nom de fichier sélectionné.

Pour supprimer un fichier :

1) Clic droit sur le nom d’un fichier pour faire apparaître un menu contextuel.

2) Cliquez sur Supprimer. Une boîte de confirmation apparaîtra.

	Remarque
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	Au lieu de faire un clic droit puis supprimer, vous pouvez sélectionner le nom de fichier et appuyer sur la touche suppr.


Il est impossible de déplacer des fichiers par copier-coller dans ces boîtes de dialogue.

 XE "Protection par mot de passe" Protection par mot de passe

Pour empêcher la lecture de l’intégralité d’un document, une boîte à cocher Enregistrer avec mot de passe dans la boîte de dialogue « Enregistrer sous » est disponible. Cette option n’est disponible que pour les fichiers enregistrés dans un format d'OpenOffice.org.

Gestion des informations personnelles

Pour inclure ou exclure les informations personnelles du document (par exemple le nom de l’auteur), utilisez le menu Fichier > Propriétés > Général. Le bouton Supprimer efface ces données. La boîte à cocher Utiliser les données d’identité permet d’inclure ou d’exclure par défaut ce type de données (comme « auteur du document »)

 XE "Signatures numériques" Signatures numériques

OpenOffice.org permet l’utilisation de signatures numériques pour garantir l’intégrité du fichier, comme le font les versions récentes de Microsoft Office.

Création de fichier au format PDF 

Toutes les applications d'OpenOffice.org ont de façon native la possibilité d’exporter les documents au format PDF. Cette fonctionnalité est accessible en cliquant sur l’icône Export Direct au format PDF de la barre d’outils standard [image: image27.png]


, ou par le menu Fichier > Exporter au format PDF.

La seconde méthode donne accès à plus d'options par exemple la qualité d’impression, la sélection de pages à inclure dans le fichier PDF, l'interface utilisateur ou encore à la sécurité du fichier.

Création de pages Web (fichier HTML)

Toutes les applications OpenOffice.org peuvent être utilisées pour créer des pages Web. Cette section a pour but de vous donner un aperçu des capacités HTML de ces applications. Pour plus de détails, référez-vous au chapitre 16, « Creating Web pages » du manuel « Getting Started » (anglais).

Writer (Traitement de texte)

Les fonctionnalités HTML de Writer permettent entre autres d’enregistrer le document au format HTML, de créer directement des fichiers au format HTML et de créer différents types de pages Web par l’intermédiaire d’un assistant.

Calc (Tableur)

Calc peut enregistrer ses fichiers au format HTML. Si le fichier contient plusieurs feuilles de données, les feuilles se retrouveront l’une à la suite de l’autre dans le fichier HTML généré. Les liens vers les différentes feuilles seront placés en tête du document. Calc permet aussi l’insertion de liens directement dans les cellules d’une feuille en utilisant la boîte de dialogue Insertion > Hyperlien.

Draw (Dessin)

Il est possible d’exporter les dessins en tant que fichier au format Macromedia Flash, en utilisant le menu Fichier > Exporter... puis en choisissant le format .swf.

Il permet aussi d’exporter les dessins en une série de pages Web au format HTML. 

Impress (Présentation)

Exporter une présentation à partir d’Impress est similaire à cette fonction dans Draw, en utilisant le menu Fichier > Exporter... puis en choisissant le format HTML. La seule différence est la possibilité d’exporter les notes de chaque diapositive en même temps que la diapositive.

Propriétés du document

Quelques exemples de différences dans les propriétés du document :

1) Résumé (MSO) ou Description (OOo) : OOo ne possède pas les champs Responsable et Catégorie.

2) Statistiques : Writer affiche le nombre de mots du document (aussi disponible dans Outils > Statistiques)

3) Personnalisation (MSO) ou Utilisateur (OOo) : OOo ne propose que quatre champs. Pour changer la dénomination des champs, cliquez sur le bouton Champs d’information.

4) Utilisez l’onglet Internet pour modifier les options de rafraîchissement et de redirection dans le cas d’une page HTML.

Rechercher des fichiers

Il n’y a pas dans OOo de fonction native pour rechercher des fichiers contenant un texte spécifique. Malgré tout, un composant a été développé et peut être installé pour bénéficier de cette fonctionnalité. Vous le trouverez à l’adresse suivante :
  http://

 HYPERLINK "http://qa.openoffice.org/issues/show_bug.cgi?id=41011"
qa.openoffice.org

 HYPERLINK "http://qa.openoffice.org/issues/show_bug.cgi?id=41011"
/issues/show_bug.cgi?id=41011 (anglais).

Lier des objets entre différents fichiers

Pour plus d’informations concernant les liens des objets et l’encapsulation (OLE), et ce qui se passe lors de l’importation de fichiers contenant des liens DDE, consultez le chapitre 2 de ce manuel, « Partager des fichiers avec des utilisateurs de Microsoft Office ».

Dans OpenOffice.org vous pouvez faire de la copie et du collage spécial à partir de cellules de Calc vers un document Writer en utilisant la technologie DDE (Dynamic Data Exchange). Vous pouvez de même créer des champs utilisant la même technologie. 

Quel que soit votre système d’exploitation, il n’est pas possible de créer un lien sur un  diagramme.

Enregistrements des informations de récupération

Pour activer/désactiver l’enregistrement automatique des informations de récupération et déterminer le délai entre deux sauvegardes, utilisez le menu :

Outils > Options > Chargement/Enregistrement > Général > Enregistrer les informations de récupération automatique

	Attention
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	L'enregistrement automatique ne permet pas de revenir à la version initiale d'un document. Il enregistre seulement le document à un instant donné. Pour enregistrer une copie de sauvegarde, à utiliser en cas d’erreur, utiliser la fonction Toujours créer une copie de sauvegarde dans la fenêtre Chargement/Enregistrement, qui créera cette copie à chaque utilisation de la fonction Enregistrer. Dans le cas contraire, une seule copie de sauvegarde sera effectuée à la fermeture du fichier.


Gestion des versions

Avec la gestion des versions vous pouvez sauvegarder plus d’une version d’un fichier sous un seul nom de fichier. Dans Microsoft Office, chaque version contient toutes les modifications faites dans le document. Dans OpenOffice.org chaque version est complète. Pour cela, utilisez le menu Fichier > Version.

Pour sauvegarder une version de fichier, consultez la section Boîtes de dialogues Ouvrir et Enregistrer sous, page 82 de ce manuel.

Travailler avec plusieurs documents ouverts

OpenOffice.org utilise la technologie SDI ( XE "Interface à document unique" Interface à document unique). Cela signifie que chaque document possède sa propre fenêtre. Le menu Fenêtre de la barre d’outils principale affiche tous les documents ouverts dans OpenOffice.org (quelle que soit l’application).

Deux des points forts d’OOo sont l’accessibilité aux informations du document actif et la facilité de navigation entre les différents documents ouverts. Chaque fenêtre OpenOffice.org affiche menus, barres d’outils et autres fonctionnalités directement liées au document de cette fenêtre courante.

Quand plusieurs documents OpenOffice.org sont ouverts, vous pouvez basculer du document actif à un autre de plusieurs façons :

1) À partir du menu Fenêtre, sélectionner le document que vous voulez rendre actif.

2) Utiliser le bouton Réduire de la barre de titre pour réduire le document actif et ainsi révéler les autres documents ouverts.

3) Sélectionner un document à partir du bureau ou de la barre de tâches du système pour le rendre actif.

4) Fermer le document courant pour accéder aux autres.

5) Utiliser la combinaison de touches Alt+Tab pour naviguer entre les documents ouverts.

Dans Microsoft Office, la combinaison de touches Ctrl+F6 permet de basculer entre les documents. Dans OpenOffice.org, on utilise F6 pour accéder au menu et à chacune des barres d’outils ; la combinaison de touches Ctrl+F6 permet, quant à elle, de rendre le document actif.

Rechercher et remplacer

Les fonctions Rechercher et Remplacer sont combinées dans OpenOffice.org, à la différence de Microsoft Office. Il n’y a pas de menu ou de raccourci clavier spécifique à la fonction Remplacer. Utiliser Édition > Rechercher & Remplacer, ou la combinaison de touches Ctrl+F , ou cliquer sur l’icône Rechercher & Remplacer [image: image28.png]


, de la barre d’outils standard.


[image: image29]
Il n’y a pas d’équivalent à l’option Rechercher toutes les formes du mot de Microsoft Office.

Après avoir effectué une recherche et fermé la boîte de dialogue, le raccourci clavier Ctrl+Shift+F répète la recherche.

Les recherches sont basées sur les paragraphes. Il n’est pas possible d’effectuer des recherches en dehors des balises de paragraphe. Par exemple, OpenOffice.org ne peut rechercher deux paragraphes vides. Pour contourner ce problème, une macro,  XE "IannzFindReplace" IannzFindReplace,  a été développée. Pour l’obtenir, allez à l’adresse (anglais) :

http://homepages.paradise.net.nz/hillview/OOo/. 

	Remarque
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	Les sauts de page manuels sont gérés de façon transparente par changement du format du premier paragraphe de la nouvelle page. L'option chercher un type de format - sauts de page « manuels » est impossible donc inactive.


Astuces pour Rechercher & Remplacer

Il est courant d’effectuer plusieurs rechercher-remplacer dans la même sélection, malheureusement OpenOffice.org ne se rappelle pas la sélection initiale. Avant d’effectuer ces multiples opérations, créer un signet pour cette sélection dans Writer, ou définir un nom de plage de cellules dans Calc. De cette façon, en utilisant le navigateur, la même sélection peut être facilement retrouvée.

Effectuer un « rechercher tous » sélectionne toutes les portions de texte correspondant aux critères de recherche. Il est possible d’effectuer, sur cet ensemble de sélection, la plupart des opérations qui peuvent être effectuées sur une sélection simple.

Attributs

Le bouton Attributs n’est disponible que dans la boîte de dialogue « Rechercher & Remplacer » de Writer. Ce bouton permet l’affichage d’une boîte de dialogue comportant une série de boîtes à cocher pour rechercher les endroits où des attributs ont été modifiés par rapport au standard. Par exemple, en sélectionnant l’attribut « Graisse » la recherche va trouver le texte qui a été mis en gras alors que le texte par défaut est non-gras (et inversement).

	Remarque
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	Les options des attributs restent valides entre deux rechercher-remplacer différents. Cela peut être ennuyeux, pensez à décocher toutes les options, après chaque recherche.


Formats

Le concept est similaire à celui utilisé dans Microsoft Office. Notez qu’en utilisant les formats, il existe une option pour inclure la recherche dans les styles. Par exemple, rechercher un texte en gras ne trouvera pas un texte qui est en gras parce que son style comporte cette caractéristique. Il le trouvera si l’option « rechercher des styles » est active.

Expressions régulières

Les « expressions régulières », dans OpenOffice.org, sont de façon significative différentes de l’utilisation des jokers dans Microsoft Office. Se référer à Aide > Aide de OpenOffice.org > Index > et saisir « Expressions régulières » dans la zone de recherche puis cliquer sur Afficher. Quelques exemples courants sont listés dans le Tableau 3. Pour utiliser les expressions régulières, cliquer sur le bouton Autres Options dans la boîte de dialogue « Rechercher & Remplacer » et vérifier que l’option est cochée. À l’ouverture de la boîte de dialogue « Rechercher & Remplacer », la case à cocher Expressions régulières est toujours décochée.

Tableau 3 : Exemples d’expressions régulières

	Problème
	Recherche
	Remplace

	Remplacer plusieurs tabulations par une seule tabulation 
	\t*
	\t

	Remplacer plusieurs espaces par un seul espace. « [:espace:] » trouve les espaces insécables ainsi que les espaces normaux mais pas les tabulations. Saisir un caractère espace standard dans la zone de recherche.
	[:space:]*
	 

	Effacer tous les caractères « blanc » de début de ligne (espace ou tabulation quelle que soit la combinaison) au début d’un paragraphe.
	^([:space:]|\t)*
	

	Effacer tous les caractères « blanc » de fin de ligne (espace ou tabulation quelle que soit la combinaison) à la fin d’un paragraphe.
	([:space:]|\t)*$
	

	Rechercher un paragraphe commençant par le caractère « a » (le reste du paragraphe peut varier) et remplacer tout le paragraphe par une ligne blanche.
	^a.*
	

	Effacer les marques de paragraphe à la fin des lignes. Par exemple après le copier-coller d’un courriel.
	$
	

	Remplacer les marques de paragraphe par une virgule pour n’avoir qu’une ligne au lieu de plusieurs.
	$
	,

	Remplacer les virgules par une marque de paragraphe.
	,
	\n

	Remplacer les césures de ligne (Maj+Entrée) par une marque de paragraphe. (Notez que \n est utilisé dans les deux cas. Dans Rechercher, il est interprété comme un saut de ligne, dans Remplacer comme une marque de paragraphe. Il n’est pas possible de saisir un saut de ligne dans le champ de saisie de Remplacer.)
	\n
	\n

	Trouver le mot « des » uniquement (et non les mots contenant le groupe de caractères « des »).
	\<des\>
	

	Trouver le groupe de caractères « ant » à la fin d’un mot, par exemple « traduisant » ou « relisant » mais pas « antipathique » !
	ant\>
	

	Trouver les mots entiers finissant par « ant ». Notez qu’il y a un espace entre les caractères ^ et ].
	[^ ]*ant\>
	

	Sélectionner tous les groupes de chiffres en début de ligne où le groupe contient un caractère ’point’. Par exemple 1.1., 1.13.2 et 4.1.15.9. 
	^[0-9.]* 
	

	Remarque
	L’astérisque « * » signifie « toute occurrence du caractère précédent ». L’équivalent à « * » de Microsoft Office est « .* » car « . » signifie un unique caractère (comme le « ? » de MSO).


Une macro qui rend plus facile l’usage des expressions régulières dans Writer, et permet de rechercher des sauts de page ou de multiples paragraphes vides, est disponible dans le document IannzFindReplace.sxw, disponible à l’adresse (anglais) :

http://homepages.paradise.net.nz/hillview/OOo/.

Recherche de similarités

La recherche de similarités élargit le champ de recherche de façon à ce que le résultat n’ait pas besoin d’être exactement ce qui est spécifié dans le champ de saisie. Pour spécifier le niveau de similitude, utiliser la boîte à cocher Recherche de similarité, puis le bouton « ... » en regard, dans la boîte de dialogue « Rechercher & remplacer » (Autres options).

Recherche de styles

Writer et Calc possèdent tous les deux une option Rechercher des styles dans la boîte de dialogue « Rechercher & remplacer » (qui se change en y compris les styles quand l’attribut format est utilisé). Vérifiez cela en premier lieu si vous recherchez un style particulier. Le champ « Rechercher » se transforme en une liste déroulante contenant l’ensemble des styles utilisés dans le document.

Vérification grammaticale

Il n’y a pas de vérification grammaticale dans OpenOffice.org. En revanche, un certain nombre de vérificateurs grammaticaux sont en cours de développement :

· An Gramadóir est un vérificateur grammatical basé sur le langage Perl, initialement développé pour l’irlandais. Il gère  également le français. Vous trouverez plus d’informations à l’adresse (anglais) : http://

 HYPERLINK "http://borel.slu.edu/gramadoir/index.html"
borel.slu.edu

 HYPERLINK "http://borel.slu.edu/gramadoir/index.html"
/

 HYPERLINK "http://borel.slu.edu/gramadoir/index.html"
gramadoir

 HYPERLINK "http://borel.slu.edu/gramadoir/index.html"
/index.html.

· Antidote est un vérificateur grammatical pour le français. C’est un produit commercial. Pour plus d'informations, allez à l’adresse suivante :
http://www.druide.com/a_correcteur.html.

· Language Tool est un vérificateur grammatical basé sur le langage Python, initialement développé pour l’allemand. Les règles pour le hongrois et l’anglais sont aussi disponibles. Plus d’informations sont disponibles aux adresses (anglais) : http://

 HYPERLINK "http://tkltrans.sourceforge.net/"
tkltrans.sourceforge.net

 HYPERLINK "http://tkltrans.sourceforge.net/"
/

 HYPERLINK "http://tkltrans.sourceforge.net/"

et http://

 HYPERLINK "http://www.danielnaber.de/"
www.danielnaber.de

 HYPERLINK "http://www.danielnaber.de/"
/

 HYPERLINK "http://www.danielnaber.de/"
 .

· CoGrOO est un vérificateur grammatical pour le portugais. Pour plus d’informations, allez aux adresses :
http://cogroo.incubadora.fapesp.br/portal (anglais et portugais)
http://cogroo.sourceforge.net/ (portugais)

[image: image32.png]



Chapitre

5

   Différences pratiques entre Writer et Word

Présentation

Ce chapitre présente les différences pratiques entre OpenOffice.org  XE "Writer" Writer et Microsoft  XE "Word" Word. La documentation proposée dans ce chapitre reprend celle du chapitre 4, « Généralités sur les différences pratiques entre  OpenOffice.org et Microsoft Office ».

L’interface de Writer

La Figure 16 représente le plan de travail principal de Writer. Hormis les quelques exceptions énumérées dans ce chapitre, les barres d’outils et les menus sont identiques à ceux de Word.
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Modes d’affichage

Selon les versions, Word possède 4 ou 5 modes d’affichage différents (dans le cas présent les 5 modes disponibles dans Word 2003), ainsi nommés :

Mode Normal : mode d’affichage recommandé (par Microsoft) pour la majeure partie de la saisie et de la mise en forme. Writer ne propose pas de véritable équivalent.

Mode Aperçu avant impression : ce mode d’affichage montre (plus ou moins) le document comme il apparaîtra à l’impression. Il s’agit là du plus proche équivalent de l’affichage Mise en page d’impression de Writer.

Mode Web : montre le document comme il doit en théorie apparaître en ligne. L’équivalent dans Writer est l’option Mise en page Web. Pour accéder à ce mode d’affichage, allez dans Affichage > Mise en page Web.

Mode Page : cet affichage formate votre écran pour rendre la lecture du document plus agréable. Writer ne possède pas de mode équivalent, mais vous pouvez aller dans Affichage > Zoom pour sélectionner la vue qui vous convient le mieux.

Mode Plan : pour travailler sur la hiérarchie des titres. Comme son nom l’indique, ce mode permet d’afficher le document sous forme de plan. On peut afficher les titres sans le texte. Si l’on déplace un titre, le texte qui l’accompagne se déplace avec lui. Dans Writer, on se sert du Navigateur, dont on détaillera les fonctions plus loin dans ce chapitre.

Writer permet aussi d’afficher la  XE "Source HTML" source HTML, laquelle n’apparaît que lorsqu’on met en forme un document HTML. Pour avoir accès à cette fonction, cliquez sur Affichage > Source HTML. 

Quand les champs de code sont activés, Writer affiche moins d’informations sur le champ que Word. Pour obtenir des renseignements détaillés, faites un clic droit sur le champ voulu, puis cliquez sur Champ (autre solution : sélectionnez le champ, allez dans le menu Édition > Champ).

Barre d’état

La barre d’état est similaire à celle de Word, sauf qu’elle n’indique pas l’emplacement du curseur sur la page (numéro de ligne croisé avec le numéro de caractère). Elle montre néanmoins la position du curseur à l’intérieur d’un tableau dans un format de style tableur ; par exemple, la cellule d’en haut à gauche s’appellera A1.

Le  XE "Navigateur, Writer" Navigateur

Word ne possède pas d’équivalent du Navigateur ; c’est un outil si utile qu’il vaut la peine de prendre le temps de s’y intéresser de plus près.

Pour lancer le Navigateur (Figure 17), pressez la touche F5 ou cliquez sur l’icône Navigateur de la barre d’outils Standard.
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Pour obtenir un descriptif détaillé de la fonction des différents boutons, pressez Maj+F1 et placez le pointeur de souris au-dessus du bouton.

La rubrique Titres située en tête de la zone de liste du Navigateur est l’équivalent le plus proche du Mode Plan de Word.

En plus de cette liste de boutons, le navigateur possède une liste déroulante en bas de la fenêtre. Grâce à cette liste déroulante, il est possible de sélectionner l’un des documents Writer ouverts, de façon à pouvoir utiliser son contenu par glisser/déposer. L’action qui s’effectue au moment du déposé dépend du mode paramétré par le bouton Mode Glisser.

Pour voir les options disponibles, cliquez sur la flèche située près du bouton Mode Glisser (Insérer comme : hyperlien, lien, ou copie).

Au sein d’un document maître, le navigateur se présente de façon assez différente. Pour plus de détails, se reporter au chapitre 13, « Travailler à partir de Documents Maîtres » du « Writer Guide» (anglais).

	Remarque
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	Les graphiques, les index, les objets OLE et les références ne peuvent être glissés et déposés en mode Insérer comme lien ou Insérer comme copie.


 XE "Formats et Styles, Writer" Formats et styles

Pour un guide d’utilisation plus détaillé sur l’emploi des styles, se reporter à la rubrique « Utiliser les modèles et les styles » (page 125) et au chapitre 13 « Working with Styles » du manuel « Getting Started » (anglais),  ou encore au chapitre 6 « Introduction to Styles » et 7 « Working with Styles », du « Writer Guide » (anglais).

Vous pouvez identifier les différents boutons de la fenêtre Styles et formatages en utilisant la combinaison Maj+F1 (Figure 18). La liste déroulante au bas de la fenêtre vous permet de changer le groupe de styles affichés. Par exemple, Styles Utilisés ne propose que les styles déjà utilisés dans le document.
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Clavier

Quand une portion de texte possède un attribut de style ou de formatage à la fin d’un paragraphe (par exemple en gras ou qu’il s’agit d’un hyperlien) mais que cet effet de caractère ne doit pas s’appliquer à la portion de texte suivante, pressez la touche flèche droite avant de taper.

Supprimer un marqueur de paragraphe : pressez la touche Supprimer à la fin d’un paragraphe a pour effet de déplacer le texte du paragraphe suivant dans le paragraphe courant, et c’est le formatage du paragraphe supérieur qui prévaut. Pressez la touche Retour Arrière au début d’un paragraphe, et c’est le format du paragraphe inférieur qui s’appliquera à l’ensemble. 

	Astuce
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	Voici un moyen mnémotechnique pour se souvenir de cette fonction : le format du paragraphe dans lequel se trouve le curseur définira le format du paragraphe combiné, à moins que le paragraphe courant soit vide. Dans ce cas, un retour arrière conservera la mise en forme du paragraphe qui précède.


Ctrl+Début dans un tableau : dans Word, Ctrl+Début positionne toujours le curseur en début de document. Dans Writer, Ctrl+Début positionne d’abord le curseur en début de cellule, puis en début de tableau, et enfin en début de document. La fonction Ctrl+Fin se comporte de la même manière.

Comment sélectionner simultanément plusieurs parties de texte

Pour copier, couper, mettre en forme ou supprimer des parties de texte à divers endroits du document, utilisez :

1) Ctrl+sélection par clic, double-clic ou glisser.

ou

1) Cliquez une fois sur le champ « STD » (STanDard) dans la barre d’état.
Le champ affiche alors « EXT » (EXTended selection).

2) Un clic supplémentaire et il devient « AJT » (AJouTer à la sélection).

	Remarque
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	Le mode AJT est l’équivalent d’un Ctrl+clic et EXT est l’équivalent d’un Maj+clic.


Sélections multiples et tableaux

Les restrictions suivantes s’appliquent quand les sélections comportent des tableaux :

1) Il est possible de créer des sélections multiples au sein d’une cellule, et même d’y inclure des parties d’autres cellules, mais une seule sélection est possible si celle-ci comporte au moins une cellule entière.

2) Une sélection qui commence dans un tableau donné ne peut s’étendre au-delà de ce même tableau. 

3) Une sélection qui commence à l’extérieur d’un tableau inclura ce tableau en entier (c’est-à-dire qu’une sélection ne peut commencer en dehors d’un tableau et ne contenir qu’une portion de ce tableau).

Comparaison entre les touches de raccourci

Tableau 4 : Différences entre les touches de raccourci établies par défaut dans Word et dans Writer (liste non exhaustive)

	Action
	Raccourci Word
	Raccourci Writer 

	Souligner les mots, mais pas les espaces
	Ctrl + Maj + W
	Pas d’équivalent

	Dictionnaire de synonymes 
	Maj + F7
	Ctrl + F7

	Afficher/cacher les caractères non imprimables
	Ctrl + Maj + *
	Ctrl + F10

	Retrait négatif première ligne
	Ctrl + T
	Pas d’équivalent par défaut

	Annuler retrait négatif première ligne
	Ctrl + Maj + T
	Pas d’équivalent par défaut

	Retrait
	Ctrl + R
	Pas d’équivalent par défaut

	Annuler retrait
	Ctrl + Maj + M
	Pas d’équivalent par défaut

	Exposant
	Ctrl + Maj + =
	Ctrl + Maj + P

	Indice
	Ctrl + =
	Ctrl + Maj + B

	Rétablir le formatage par défaut d’un caractère
	Ctrl + Barre d’espace
	Clic droit > Par défaut

	Rétablir le formatage par défaut d’un paragraphe
	Ctrl + Q
	Clic droit > Par défaut

	Retourner au dernier point d’édition
	Maj + F5
	Dans le navigateur, vous disposez d’une fonction « Repères de texte » qui vous permet de naviguer entre les différentes modifications

	Déplacer le paragraphe vers le haut
	Pas d’équivalent
	Ctrl + Haut

	Déplacer le paragraphe vers le bas
	Pas d’équivalent
	Ctrl + Bas

	Rechercher
	Ctrl + F
	Ctrl + F

	Remplacer
	Ctrl + H
	Ctrl + F


Reportez-vous au document  XE "AltKeyHandler" AltKeyHandler.sxw (disponible à l’adresse http://homepages.paradise.net.nz/hillview/OOo/) pour obtenir des macros qui ajoutent la prise en charge de la touche Alt comme raccourci – y compris la fonctionnalité de retrait semblable à celle que propose Word.

Utilisation de la souris

Voici quelques différences entre les deux traitements de texte :

1) Dans Writer, pas de sélection rapide d’un paragraphe ou d’une ligne par un simple clic à gauche du paragraphe.

2) Ctrl+clic ne sélectionne pas une phrase, mais un triple clic le fait (un quadruple clic sélectionne le paragraphe).

 XE "Tableaux, Writer" Tableaux

Sélections comprenant des tableaux

Un tableau étant considéré comme un paragraphe formant un tout, lorsqu’on sélectionne une partie de texte à l’aide du clavier (Maj+flèche) en commençant la sélection, par exemple, quelques lignes au-dessus du paragraphe, le tableau entier est sélectionné, ainsi que la ligne qui le suit.

Pour afficher la grille du tableau quand celui-ci n'a pas de bordures, faites un clic droit sur le tableau et cochez Bordures des tableaux. Ou allez dans le menu : Outils > Options... > OpenOffice.org > Apparence, puis cochez la case Bordure des tableaux.

Lignes de titre

Par défaut, les nouveaux tableaux ne possèdent pas de ligne de titre. Cette configuration peut être modifiée en se rendant dans Outils > Options > OpenOffice.org Writer > Tableau.

Lorsque vous créez un nouveau tableau en passant par le menu Tableau > Insérer > Tableau..., vous pouvez choisir d’activer ou de désactiver la ligne de titre.

Il est possible de choisir si la ou les ligne(s) de titre se répète(nt) au début de chaque page en sélectionnant la ou les ligne(s) voulue(s), puis en allant dans Tableau > Répéter les lignes de titre. Ce choix ne modifie pas la mise en forme des lignes, il ne fait que définir si elles doivent se répéter à chaque saut de page.

Régler la largeur des colonnes et la hauteur des lignes à l’aide du clavier

Les différents procédés de réglage pour la largeur des colonnes en passant par Outils > Options... > OpenOffice.org Writer > Tableau, sont :

1) Fixe : la largeur totale du tableau reste la même, mais la colonne contiguë rétrécit ou s’élargit en fonction.

2) Fixe, proportionnel : la colonne sélectionnée et la colonne de fin se modifient de façon proportionnelle ; la largeur totale reste ainsi la même.

3) Variable : seule la colonne sélectionnée est modifiée, la largeur totale du tableau l’est aussi.

Pour régler la largeur des colonnes (ou la hauteur des lignes), utilisez la touche Alt et les flèches de direction comme suit : 

1) Alt+flèche ajuste le côté droit (le bas pour les lignes).

2) Alt+Maj et les flèches ajuste le côté gauche (le haut pour les lignes).

3) Alt+Ctrl+gauche ou droite ajuste la cellule sélectionnée uniquement.

Copier et coller des cellules dans un tableau

Writer n’insère jamais de nouvelle ligne ou de nouvelle colonne quand il colle des données, il remplace toujours le contenu des cellules existantes. On sait ainsi ce qu’on obtiendra à l’arrivée. Pour éviter d’effacer le contenu de cellules, insérez d’abord le nombre de lignes ou de colonnes requis.

Insérer et supprimer des lignes ou des colonnes

Lorsque vous utilisez la fonction Tableau > Insérer > Ligne ou Tableau > Insérer > Colonne, ou bien clic droit > Ligne > Insérer... ou Colonne > Insérer..., vous pouvez choisir d’insérer l’objet avant ou après la ligne ou la colonne active.

Quand vous utilisez les icônes de la barre d’outils Tableau, les nouvelles lignes s’insèrent sous la ligne active, et les colonnes s’insèrent à droite de la colonne active (dans Word, c’est l’inverse).

	Remarque
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	Il s’agit là d’une incohérence, puisque Calc insère les lignes et les colonnes au-dessus et à gauche.


Dans la version GNU/ XE "Linux" Linux, vous pouvez insérer une ligne ou une colonne à l’aide du clavier : Alt+Inser > flèche (c’est-à-dire presser simultanément les touches Alt et Inser, les relâcher, puis enfoncer la touche flèche.) Pour  supprimer une ligne ou une colonne à l’aide du clavier : Alt+Suppr > flèche.

L’insertion ou la suppression correspond à la direction de la flèche choisie. Par exemple, Alt+Inser > Haut insère une ligne au-dessus de la ligne active.

Harmoniser la hauteur des lignes et la largeur des colonnes

Sur la barre d’outils Tableau figure un long bouton cliquable nommé Optimiser. Il propose un menu déroulant permettant d’harmoniser facilement la hauteur des lignes et la largeur des colonnes des cellules sélectionnées.

Scinder et fusionner

Fusionnez les cellules à la fin de votre travail, comme vous le feriez dans Word.

Pour fusionner ou scinder des cellules, sélectionnez celles qui vous intéressent, puis vous avez trois possibilités :

· Un clic droit, Cellule > Fusionner ou Scinder...

· Menu Tableau > Fusionner les cellules ou Scinder la cellule.

· Par la barre d'outils Tableau, bouton Fusionner les cellules, ou Scinder la cellule.

Pour scinder un tableau (horizontalement) : Menu Tableau > Scinder le tableau.

Pour fusionner deux tableaux, ceux-ci doivent se trouver l’un au-dessus de l’autre. Cliquez alors sur Tableau > Fusionner le tableau. Si le tableau actif est précédé et suivi d’autres tableaux, on vous demandera lequel vous souhaitez lui adjoindre.

Trier

Pour trier les cellules d’un tableau :

1) Sélectionnez les cellules à trier ; ne pas inclure les titres. La fonction Trier ne devient disponible que lorsque des cellules sont sélectionnées.

2) Outils > Trier.

Contrairement à Word, la boîte de dialogue de la fonction de tri utilise le numéro des colonnes plutôt que leur nom.

Saisir des nombres et des formules

Dans Writer, contrairement à Word, le fonctionnement des tableaux est très semblable à celui des feuilles de calcul. Par exemple, les résultats des calculs changent à mesure qu’on saisit les données dans le tableau (il n’est plus nécessaire de sélectionner la cellule concernée et de presser F9 pour rafraîchir le résultat d’un calcul).

Quand la reconnaissance des nombres est activée, Writer met automatiquement en forme les nombres que vous saisissez selon un format défini. Pour modifier cette fonction, faites un clic droit sur un tableau et cliquez sur Reconnaissance des nombres pour la désactiver.

Pour modifier le format des nombres, sélectionnez les cellules, puis Menu Tableau > Format numérique..., ou clic droit > Format numérique...

Pour saisir une formule du type Somme :

1) Sélectionnez la cellule où doit figurer le résultat.

2) Pressez F2 pour afficher la barre de Formule, ou Menu Tableau > Formule.

3) Cliquez le bouton Formule pour afficher le menu.

4) Sélectionnez la fonction désirée. Pour faire la somme de plusieurs cellules, par exemple, sélectionnez « somme » (attention : dans la zone de saisie la fonction choisie n’est pas traduite en français, vous obtiendrez donc « sum ». Mais si vous taper vous-même « somme » ça fonctionnera aussi).

5) Cliquez sur la première cellule et glissez  jusqu’à la dernière cellule que vous voulez inclure dans le champ d’action de la formule (dans le cas de la somme, les cellules qu’il faut additionner). Vous obtiendrez donc dans la zone de saisie sum <lettre/chiffre:lettre/chiffre> correspondant.

6) Pressez Entrée pour terminer. 

Pour saisir une formule du type « cette cellule plus cette cellule moins cette cellule » :

1) Sélectionnez la cellule où le résultat doit apparaître.

2) Pressez F2 pour afficher la barre de Formule.

3) Cliquez sur une cellule.

4) Tapez ou sélectionnez l’opération désirée.

5) Cliquez sur la cellule suivante.

6) Répétez les étapes 4 et 5 jusqu’à ce que vous ayez terminé.

7) Pressez Entrée pour terminer.

Créer un tableau à partir d’une source de données

Pour créer un tableau à partir d’une source de données :

1) Affichez l’explorateur de Source de données (F4), ou Menu Affichage > Sources de données.

2) Dans la fenêtre d’exploration de données, naviguez jusqu’à la requête voulue ou au tableau voulu.

3) Glissez/Déposez le nom du tableau ou de la requête dans le document.

4) Sélectionnez les champs désirés et attribuez-leur d’autres propriétés comme demandé dans la boîte de dialogue.

Les graphiques dans Writer

Les graphiques copiés dans une feuille de calcul Calc et collés dans un document Writer deviennent, par défaut, des objets incorporés. Dans Writer, contrairement à ce qui se passe dans Microsoft Word, seules les données pertinentes pour le graphique sont incorporées. Dans Microsoft Office, copier et coller un graphique  l’incorpore aussi, mais si le classeur Excel a une taille de 8 Mo (ce qui n’a rien d’improbable pour une feuille de calcul), alors chaque graphique collé dans un document Word augmenterait le poids du document Word de 8 Mo.

Aucun lien ne peut être attribué à un graphique.

Personnaliser l’interface utilisateur

La plupart des fonctions se trouvent aux mêmes endroits dans les deux programmes, mais certaines ont un emplacement légèrement différent, et le degré de contrôle peut varier. Le  Tableau 5 résume où trouver ces fonctions de configuration.

Tableau 5 : Personnaliser l’interface utilisateur

	Action
	Dans Word
	Dans Writer

	Changer d’unité de mesure
	Outils > Options > Général
	Outils > Options > OpenOffice.org Writer > Général

	Désactiver l’Insertion automatique
	N’existe pas
	Outils > AutoCorrection. Dans l’onglet Insertion Automatique, désélectionnez Compléter les mots.

	Activer/Désactiver l’Assistant
	? > Aide sur Microsoft Word > Options
	Outils > Options > OpenOffice.org > Général

	Configurer la fenêtre de document (règles, barre d’état, barres d’outils par défaut, etc.)
	Affichage > sélectionnez les éléments requis
	Affichage > sélectionnez les éléments requis

	Personnaliser les barres d’outils
	Outils > Personnaliser
	Outils > Personnaliser

	Personnaliser les menus
	Outils > Personnaliser
	Outils > Personnaliser

	Afficher les noms de police avec la police qu’ils désignent (dans la liste déroulante de polices dans la barre d’outils)
	Outils > Personnaliser > Options
	Outils > Options > OpenOffice.org > Affichage, Aperçu des polices

	Toujours afficher des menus complets (inclure les objets indisponibles et peu utilisés)
	Outils > Personnaliser > Options
	Par défaut

	Afficher/cacher les Infobulles sur les barres d’outils
	Outils > Personnaliser > Options
	Outils > Options > OpenOffice.org > Général

	Toujours créer une copie de sauvegarde
	Outils > Options > Enregistrement
	Outils > Options > Charger/Enregistrer > Général, sélectionnez Toujours créer une copie de sauvegarde

	Enregistrer automatiquement  toutes les x minutes
	Outils > Options > Enregistrer
	Outils > Options > Chargement/Enregistrement > Général, sélectionnez Enregistrer les informations de récupération automatique toutes les, et choisissez une valeur dans la liste Minutes

	Afficher les marques de paragraphe, les tabulations, etc.
	Outils > Options > Affichage
	Outils > Options > OpenOffice.org Writer > Aide au formatage, cochez les objets voulus

	Modifier l’emplacement des fichiers
	Outils > Options > Dossiers par défaut
	Outils > Options > OpenOffice.org > Chemins

	Modifier les informations sur l’utilisateur
	Outils > Options > Utilisateur
	Outils > Options > OpenOffice.org > Données d’identité

	Configurer les options d’AutoCorrection et d’AutoFormat
	Outils > Correction automatique
	Outils > AutoCorrection > Options, sélectionnez les objets voulus


 XE "Éditer et réviser un document" Rédiger, éditer et réviser un document

Dans la plupart des cas, les techniques de rédaction, d’édition et de révision de texte dans OpenOffice.org Writer sont similaires à celles utilisées dans Microsoft Word, mais les détails varient souvent.

Tableau 6: Rédiger, éditer et réviser un document

	Action
	Dans Word
	Dans Writer

	Atteindre rapidement d’autres parties d’un document
	Édition > Atteindre
	Édition > Navigateur (ou F5), double-cliquez sur la partie voulue – titre, image, tableau, etc

	Choisir la langue de la vérification orthographique 
	Outils > Langue
	Outils > Options > Paramètres linguistiques > Langue. (Remarque : OpenOffice.org ne propose pas de vérification grammaticale.)

	Ignorer une partie de texte pendant la vérification orthographique
	Sélectionnez le texte ; Outils > Langue > Ne pas vérifier (ou) Format > Style > Modifier > Format > Langue
	Sélectionnez le texte ; clic droit,  Caractères > Police > Langue = [Aucun(e)] ou bien la langue de la partie de texte sélectionnée, si celle-ci est étrangère

	Revérifier l’orthographe
	Outils > Grammaire & Orthographe  > Revérifier le document
	Revérifie toujours.

	Chercher et remplacer du texte, une mise en forme ou des styles
	Édition > Remplacer > Plus ; choisissez en conséquence
	Édition > Rechercher & remplacer > Autres options ; la marche à suivre est ensuite quelque peu différente

	Utiliser les caractères génériques dans Rechercher et remplacer
	Édition > Remplacer > Plus > cochez la case Utiliser les caractères génériques
	Édition > Rechercher & remplacer, cliquez sur Autres options et cochez Expressions régulières ; les caractères génériques eux-mêmes sont différents. Se reporter à la section sur les Expressions régulières dans le chapitre 4, « Différences pratiques générales entre Microsoft Office et OpenOffice.org »

	Sélectionner, créer ou éditer un dictionnaire personnel
	Outils > Options > Grammaire et orthographe > Dictionnaires personnels
	Outils > Options > Paramètres linguistiques > Linguistique

	Créer un dictionnaires d’exceptions (exclure)
	Fichier > Nouveau, saisir le mot voulu, Enregistrer sous > texte seulement,  extension de fichier .EXC
	Même démarche que pour créer un dictionnaire personnel, mais après avoir cliqué sur le bouton Nouveau, sélectionnez Exception (-) dans la boîte de dialogue Nouveau dictionnaire

	Suivi des modifications (choix des options)
	Outils > Options > Modifications
	Outils > Options > OpenOffice.org Writer > Modifications

	Protéger un document pour l’édition
	Outils > Protéger le document
	Édition > Modifications > Protéger l’historique
(Le mot de passe doit contenir au moins 5 caractères)

	Marquage et suivi des modifications 
	(dans Word 2000) Outils > Suivi des modifications > Afficher les modifications
	Édition > Modifications > Afficher

	Insérer un commentaire associé à une modification
	Surlignez le texte ; Insertion > Commentaire
	Édition > Modification > Commentaire

	Insérer des notes (commentaires non associés à une modification)
	Surlignez le texte ; Insertion > Commentaire
	Insertion > Note

	Afficher les modifications dans une Infobulle
	Outils > Options > Affichage > Info-bulles
	Outils > Options > OpenOffice.org > Général

	Fusionner des documents
	Outils > Fusion de documents
	Édition > Modifications > Fusionner le document

	Valider ou rejeter une modification
	Affichage > Barre d’outils > Révision
	Édition > Modifications > Accepter ou rejeter

	Modifier les propriétés d’un document 
	Fichier > Propriétés
	Fichier > Propriétés

	Obtenir un comptage des mots
	Outils > Statistiques
	Outils > Statistiques

	Créer une entrée d’insertion automatique
	Sélectionnez le texte ; Insertion > Insertion automatique > Nouveau
	Édition > AutoTexte, ou Ctrl+F3

	Insertion automatique
	Tapez le raccourci et pressez F3
	Tapez le raccourci et pressez F3 ; ou tapez le Nom et pressez Entrée. Writer fait la distinction entre le « nom » et le « raccourci » d’une insertion automatique. Ce n’est pas le cas de Word


Dans Writer, une insertion automatique se termine toujours par une marque de paragraphe. Pour un raccourci court dans le fil du texte, il est donc conseillé d’utiliser l’AutoCorrection.

 XE "Définir la mise en page, Writer" Définir la mise en page

Dans cette section, nous aborderons la question des marges, des titres et des pieds de page.

La mise en page est appréhendée de façon différente dans Writer et dans Word.

La mise en page dans Word

La mise en page est une propriété du document considéré comme un tout. Si vous modifiez la mise en page (par exemple, que vous définissez l’orientation du document en format paysage), cela affecte le document dans son ensemble. Vous pouvez ensuite attribuer une mise en page différente à des sections spécifiques.

La mise en page dans Writer

La mise en page est une propriété du style de page. Si vous modifiez la mise en page pour un style de page, que vous choisissez par exemple la mise en page Par défaut pour obtenir un titre et des numéros de page, seul ce style sera affecté par la modification.

L’utilisation des styles de page confère à Writer des fonctions très utiles. Par exemple, vous pouvez configurer le style Première page de façon que, après avoir tapé la première page de votre document, la mise en page passe automatiquement au style Index (ou tout autre style de votre choix). Vous pouvez alors configurer le style Index pour qu’il soit suivi par le style Par défaut.

Tableau comparatif des mises en page

Tableau 7 : Mise en page

	Action
	Dans Word
	Dans Writer

	Définir les marges
	Fichier > Mise en page > Marges
	Format > Page... > Page

	Définir des en-têtes et des pieds de page différents sur la première page, les pages paires ou impaires
	Fichier > Mise en page > Disposition > En-têtes et pieds de page
	Format > Page, sélectionnez les onglets voulus.
Définissez des styles de page différents pour la Première page, la page Gauche (paires), et Droite (impaires), à l’aide des onglets En-tête et Pied de page

	Éditer les en-têtes et les pieds de page
	Affichage > En-têtes et pieds de page, puis taper ou insérer un champ ; vous pouvez aussi double-cliquer dans des zones d’en-tête ou de pied de page existantes
	Lorsque vous avez défini les zones d’en-tête et de pied de page pour une page, celles-ci restent actives en permanence. Un clic simple suffit pour y saisir du texte ou y insérer des champs

	Passer des chiffres romains au chiffres arabes pour la numérotation en pied de page
	Insérez un saut de section,  Insertion > Numéros de page > Format, cocher « À partir de », sélectionner les chiffres arabes voulus dans le champ Format
	Insérez un saut de page manuel et appliquez un style de page différent

	Définir la mise en page grâce au style de paragraphe
	Il est possible de définir un style de paragraphe avec un retrait de la marge de gauche, et un style d’en-tête aligné à droite ou à gauche
	Il est possible de définir le style de paragraphe avec un retrait de la marge de gauche, et un style d’en-tête aligné à droite ou à gauche 

	Définir la mise en page grâce aux colonnes
	Insérez des sections continues pour passer d’une colonne simple à des colonnes multiples au sein d’une même page
	Format > Page > Colonnes, ou
Insertion > Section > Colonnes, ou Format >  Colonnes

	Définir la mise en page grâce aux cadres ou aux zones de texte
	Les cadres sont utilisés dans Word 97 mais le plus souvent remplacés par des zones de texte dans Word 2000 et 2002. On peut leur associer un enchaînement, comme dans un formulaire 
	Insertion > Cadre (il est possible d’associer un cadre à un enchaînement, comme dans un formulaire. Les « zones de texte » sont des champs, pas des outils de positionnement

	Définir la mise en page grâce aux tableaux
	Tableau > Insérer > Tableau (formatez à l’aide de la boîte de dialogue)
	Insertion > Tableau (formatez à l’aide de la boîte de dialogue)

	Associer des en-têtes de mode Portrait avec des pages en mode paysage
	Utilisez une zone de texte associée à un en-tête et changez l’orientation du texte
	Changez l’orientation du texte dans un cadre

	Commencer la numérotation des pages avec un chiffre plus grand que 1
	Insertion > Numéros de page > Format
	Dans le premier paragraphe ou la première page, Format > Paragraphe > Enchaînements > Sauts, sélectionnez Insérer et Avec le style de page, choisissez le style de page, indiquez le numéro de page

	Afficher et éditer les pages en vis-à-vis 
	Fichier > Aperçu avant impression ; cliquez sur le bouton Zoom pour permettre l’édition
	Fichier > Aperçu. Impossible de modifier le document en mode Aperçu

	Réduire le document à une page
	Fichier > Aperçu avant impression, cliquer sur le bouton Ajuster
	Voir : http://homepages.paradise.net.nz/hillview/OOo/ShrinkToFit.sxw.


 XE "Utilisez les modèles et les styles, Writer" Utiliser les modèles et les styles

Tableau 8 : Utiliser les modèles et les styles

	Action
	Dans Word
	Dans Writer

	Trouver quel modèle est associé à un document
	Outils > Modèles et compléments
	Fichier > Propriétés >  Général

	Définir un modèle par défaut
	Le modèle « Normal » est défini par défaut
	Fichier > Modèle de document > Général. Vous pouvez alors définir par défaut le modèle de votre choix

	Créer un nouveau modèle
	Fichier > Enregistrer sous, définir le fichier comme Modèle de document (.DOT)
	Fichier > Modèle de document > Enregistrer

	Éditer un modèle
	Fichier > Ouvrir, sélectionnez le modèle
	Fichier > Modèle de document > Éditer

	Copier des styles d’un modèle à l’autre
	Outils > Modèles et compléments > Organiser
	Fichier > Modèle de document > Gérer. Là, vous pouvez copier des styles d’un document à l’autre en utilisant le copier/déposer

	Créer un nouveau document à partir d’un modèle
	Fichier > Nouveau (ouvre une liste de modèles)
	Fichier > Nouveau > Modèles et documents

	Appliquer un modèle différent à un document
	Outils > Modèles et compléments > Attacher, sélectionnez le modèle, Ouvrir
	Ouvrez un nouveau document basé sur le modèle voulu ; copiez le contenu de l’ancien document dans le nouveau

	Appliquer un style à du texte
	Sélectionnez dans la Liste de styles (Word 2000) ou dans la boîte de dialogue des Styles (XP). Il est aussi possible d’utiliser la barre des tâches.
	Format > Styles et formatage (ou pressez F11), double-cliquez sur le style voulu dans la liste ; après la deuxième utilisation, le style de paragraphe apparaît dans la liste Appliquer le style sur la barre d’outils Formatage

	Modifier la définition d’un style
	Format > Style > Modifier (Word 2000). Dans XP, il est aussi possible de le sélectionner dans la barre des tâches et de cliquer sur Modifier
	Sélectionnez un style dans la fenêtre Styles et formatage, faites un clic droit et choisissez Modifier

	Créer un nouveau style
	Format > Style > Nouveau
	Faites un clic droit sur la fenêtre Styles et formatage, puis cliquez sur Nouveau

	Utiliser la numérotation des chapitres
	Format > Style, sélectionnez le style > Format > Puces et numéros
	Outils > Numérotation

	Lettrines
	Format > Lettrine
La lettrine ne peut être qu’un seul caractère, et ne peut faire partie d’un style
	Format > Paragraphe > Lettrines
La lettrine peut faire partie d’un style, et peut être supérieure ou égale à un caractère ou à un mot


Taille de la police

Quand un style est basé sur un autre, il est possible de paramétrer la police pour qu’elle représente un pourcentage de la taille de la police d’origine. Il suffit de saisir dans le champ Taille de police le nombre voulu suivi du sigle % (par exemple 120%). Ainsi, les modifications apportées au style d’origine apparaîtront plus clairement dans ce style. Pour revenir à une taille de police absolue, indiquer le nombre suivi par les caractères « pt » (par exemple 12pt). Il est également possible de spécifier de combien de points la police devra être plus grande ou plus petite, par exemple +2pt pour deux points de plus, ou -2pt pour deux points de moins.

Espacement entre les paragraphes et saut de page avant le texte

Certaines propriétés concernant le paragraphe ne fonctionnent pas de la même manière dans Writer que dans Word. En particulier :

1) L’espacement avant le texte, s’il se trouve en haut d’une page, est ignoré.

2) Espacement entre deux paragraphes : pour deux paragraphes qui se suivent et dont les espacements (avant/après) sont différents, c’est le plus grand des deux espacements qui s’applique entre les deux paragraphes.

3) Saut de page avant le texte : s’il se trouve en haut d'une page, il ne crée pas une page blanche.

Ces fonctions permettent d’utiliser les styles sans devoir appliquer directement des mises de forme de paragraphe pour régler des problèmes par la suite.

 XE "Champs, Writer" Champs

Pour une comparaison de l’utilisation des champs dans Writer et dans Word, consulter le chapitre 2, «Partager de fichiers avec des utilisateurs de Microsoft Office ».

Tableau 9 : Utilisation des champs

	Action
	Dans Word
	Dans Writer

	Insérer un champ
	Insertion > Champ (ou) CTRL+F9 pour un champ vierge
	Insertion > Champ, puis choisissez le champ désiré

	Définir un champ de numéro séquentiel
	Insertion > Champ, sélectionnez SEQ (séquence)
	Insertion > Champ > Autres > Variables, puis Séquence dans la zone Type de champ

	Insérer un repère de texte
	Sélectionnez le texte ; Insertion > Signet
	Sélectionnez le texte ; Insertion > Repère de texte

	Associer un renvoi à un repère de texte
	Insertion > Renvoi, choisissez la catégorie Signet 
	Insertion > Renvoi > Repère de texte


	Associer un renvoi à un en-tête
	Insertion > Renvoi, choisissez la catégorie En-tête
	Définissez l’en-tête comme repère ou faites Insertion > Renvoi > Références > Définir une référence pour marquer l’en-tête, puis faites Insertion > Renvoi >  Références >  Insérer une référence

	Associer un renvoi à une figure ou à un tableau
	Insertion > Renvoi, choisissez la catégorie
	Insertion > Renvoi >  Références >  Insérer une référence > Figure, ou Tableau

	Utiliser du contenu conditionnel
	Passez par l’insertion de champs, ou utilisez les styles (liste complète des solutions)
	Insertion > Champ > Autres > Variables (une façon de procéder parmi d’autres)


 XE "Documents complexes ou volumineux, Writer" Travailler sur des documents complexes ou volumineux

Il existe des différences majeures dans l’utilisation des documents maîtres. Ce tableau n’a pas la prétention de les évoquer toutes.

Tableau 10 : Travailler sur des documents complexes ou volumineux

	Action
	Dans Word
	Dans Writer

	Créer une table des matières, une liste de figures, ou un index alphabétique
	Insertion > Tables et index
	Insertion > Index > Index

	Insérer des entrées d’index
	ALT+MAJ+X
	Insertion > Index > Entrées

	Créer une base de données bibliographique
	Fonction indisponible
	Outils > Base de données bibliographique

	Insérer des références bibliographiques dans le texte
	Créez un lien avec le champ de la base de données
	Insertion > Index > Entrée de bibliographie

	Insérer des notes de bas de page et des notes de fin
	Insertion > Note de bas de page
	Insertion > Note de bas de page

	Insérer d’autres fichiers
	Insertion > Fichier, sélectionnez Insérer ou Insérer au fichier
	Insertion > Fichier

	Renvoi entre plusieurs documents
	Utilisez les champs IncludeText
	Vous devrez vous souvenir du nom de la référence désignée. La référence apparaîtra correctement dans le document maître. Ou bien utilisez la macro OutlineCrossRef3-fr-3 macro disponible sur : http://sourceforge.net/project/shownotes.php?release_id=403754&group_id=87718 

	Utiliser les documents maîtres
	Certains spécialistes déconseillent d’utiliser les documents maîtres dans Word
	Fichier > Envoyer > Créer un document maître ; utilisez le Navigateur (F5) pour insérer des sous-documents


 XE "Objets graphiques, Writer" Travailler avec des objets graphiques

La plupart des objets graphiques devront être réalisés ailleurs que dans Word ou Writer, avec les fichiers d’objets graphiques incorporés au fichier Word ou Writer. Vous pouvez néanmoins réaliser des objets graphiques simples à l’aide des outils de dessin disponibles dans Word ou Writer. Ce tableau aborde les fonctions de base. 

Tableau 11 : Travailler avec des objets graphiques

	Action
	Dans Word
	Dans Writer

	Créer des objets de dessin
	(Word 2000) Affichage > Barres d’outils > Dessin ; (XP) Insertion > Dessin > Nouveau dessin
	Cliquez sur l’icône Afficher les fonctions de dessin dans la barre d’outils Standard

	Combiner des objets de graphisme et des objets de dessin
	(Word 2000) Édition > Modifier l’image > Ajuster les délimiteurs à l’image ; (XP) Utiliser les trames de dessin
	Placez tous les objets dans un cadre

	Insérer des fichiers de graphisme dans un document texte (incorporer ou insérer comme lien)
	Insertion > Image > À partir du fichier, choisissez Insérer ou Lier au fichier
	Insertion > Image > À partir d’un fichier

	 XE "Ancrage d'un objet graphique, Writer" Ancrage d’un objet de graphisme
	Format > Image > Habillage > Avancé > Positionnement de l’image
	Utilisez les icônes des barres d’outils Propriétés de l’objet de dessin ou Cadre (ces barres d’outils remplacent la barre d’outils de Formatage quand un objet de dessin ou un cadre est sélectionné) ou faites un clic droit et sélectionnez l’option voulue dans le menu contextuel, ou encore cliquez sur Format > Image

	Disposer le texte autour de l’objet de graphisme
	Format > Image (ou Objet) > Habillage
	Utilisez les icônes de la barre d’outils Cadre, ou faites un clic droit et sélectionnez l’option voulue dans le menu contextuel, ou encore cliquez sur Format > Image > Adaptation du texte

	 XE "Rogner un objet graphique, Writer" Rogner un objet de graphisme
	Format > Image > Rogner, (ou) cliquez sur l’icône Rogner de la barre d’outil Image
	Format > Image > Rogner
(Pas d’outil pour déplacer la zone rognée)

	Créer une légende pour un graphique
	Sélectionnez le graphique ; Insertion > Référence > Légende
	Sélectionnez le graphique ; Insertion > Légende

	Annoter un graphique
	Utilisez les objets de dessin ; groupez-les, ou placez-les dans un cadre ou sur une trame de dessin (XP)
	Placez tous les objets dans un cadre

	Insérer un filigrane
	Format > Arrière-plan > Motifs et texture
	Format > Page  >  Arrière-plan ou bien créez un objet de dessin, Adaptation du texte > À l’arrière-plan, Ancrage > À la page


Fusionner du courrier

La méthode de fusion du courrier diffère de façon significative de Writer à Word. Se reporter au chapitre 11 « Using Mail Merge » du « Writer Guide » (anglais).

 XE "Enveloppes, Writer" Enveloppes

Ajouter une enveloppe

Menu Insertion > Enveloppe

Supprimer une enveloppe

1) Placez le curseur au début de la page d’enveloppe.

2) Si la fenêtre Styles et formatage n’est pas ouverte, pressez F11 ou cliquez sur Format > Styles et formatage pour l’afficher.

3) Sélectionnez l’option Style de page. C’est la quatrième icône en partant de la gauche.

4) Double-cliquez sur Standard.

5) Supprimez les éléments restants.

 XE "Styles de page, Writer" Styles de page

Modifier un style de page

Dans Writer, toutes les pages possèdent un style de page. Pour modifier le style de la page où se trouve le curseur, cliquez sur Format > Page.

	Attention
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	Lorsque le style de page est modifié, toutes les pages possédant ce style le seront aussi.


Créer un style

Pour créer un nouveau style de page :

1) Si la fenêtre Styles et formatage n’est pas ouverte, pressez F11.

2) Cliquez sur le bouton Styles de page (quatrième icône en partant de la gauche).

3) Faites un clic droit dans une zone vide de la fenêtre Styles et formatage > sélectionnez Nouveau.

Boîte de dialogue Style de page

Cliquez sur Format > Page. La fenêtre Style de page s’ouvre.

Onglet Gérer

Nom : rien de compliqué ici, juste un nom pour aider l’utilisateur à se rappeler à quoi correspondent les paramètres.

Style de suite : ce paramètre définit quel style appliquer après le saut de page (manuel ou automatique). Attribuez un style de page différent quand le style ne doit s’appliquer qu’à une seule page (par exemple la première page d’un chapitre). Sinon, laissez le même style de page que dans la rubrique Nom afin de garder le même style pour les pages suivantes.

Onglet page

Format : définit le format du papier. Les autres paramètres portent le même nom que dans Word (sur l’onglet Format du papier dans la fonction Mise en page).

Marges : comme dans Word. Chaque paramètre représente la distance entre la zone de texte et le bord de la page, mais consultez la rubrique « Onglets En-tête et Pied de page » pour plus de détails car l’emplacement des en-têtes et des pieds de page par rapport aux marges n’est pas le même que dans Word.

Paramètres de mise en page : la Mise en page sert à spécifier si le style de page doit s’appliquer en regard (être utilisé pour les pages de gauche et de droite). Writer propose ici plus d’options que Word, sauf pour la première page, celle-ci étant définie par le paramètre Style de suite mentionné dans l’onglet Gérer ci-dessus. Format se rapporte au format des numéros de page. Contrôle de repérage/Style de paragraphe référence sert à mieux aligner la limite de la zone de texte au haut de la page (consultez l’aide pour plus de détails).

Onglet Arrière-plan

Sert à définir une couleur ou une image (filigrane) d’arrière-plan. (Pour plus de souplesse, créez un objet de dessin, puis utilisez les fonctions Adaptation du texte > À l’arrière plan, Ancrage > À la page.)

Onglets  XE "En-tête et Pied de page, Writer" En-tête et Pied de page

Les en-têtes et les pieds de page sont imprimés entre les marges de la page plutôt qu’au sommet ou au bas des marges comme c’est le cas dans Word. On peut aussi présenter la chose ainsi : pour le sommet d’une page, la zone entre le bord de la page et la marge supérieure est toujours vierge, vient ensuite l’en-tête, suivi de la zone de texte principale .

Hauteur : Adaptation dynamique de la hauteur permet à la taille de l’en-tête ou du pied de page de s’agrandir ou de diminuer en fonction de son contenu.

Espacement définit la distance entre l’en-tête ou le pied de page et la zone de texte principale. Utilisation de l’espacement dynamique permet à l’en-tête ou au pied de page d’occuper plus d’espace dans la zone entre l’en-tête/pied de page et la zone de texte principale.

Les marges gauche et droite sont des indentations des marges de la page et ne peuvent avoir une valeur négative.

Le bouton Options sert à définir les bordures et les arrière-plans de la zone d’en-tête ou de pied de page. Dans certaines versions de Word, cette méthode sert à créer des filigranes. Puisqu’il est possible d’avoir un dessin en arrière-plan du document principal, ce n’est pas la façon recommandée d’insérer un filigrane dans Writer.

Onglets Bordures, colonnes et note de bas de page

Ces onglets servent à définir les bordures (les lignes autour de la zone de texte), le nombre et la largeur des colonnes de style journal, et la zone attribuée aux notes de bas de page (si notes de bas de page il y a) pour le style de page.

Sauts de page et numérotation des pages

Modifier le style utilisé pour une page et modifier la séquence de numérotation 

Pour insérer un saut de page et changer le style ou la numérotation, voici la première méthode possible :

1) Ctrl+Entrée.

2) Le curseur se place au début du premier paragraphe de la nouvelle page.

3) Format > Paragraphe > Enchaînements.

4) Les sauts sont activés.

5) Sélectionnez Avec le style de page, indiquez le style de page à utiliser et le numéro de page de départ.

Deuxième méthode :

1) Insertion > Saut Manuel

2) Par défaut, Saut de page est sélectionné.

3) Choisissez le style de page dans la liste Style de page.

4) Cochez Modifier le numéro de page.

5) Saisissez le nouveau numéro de départ.

Insérer des numéros de page

1) Choisissez un style de page où les en-têtes ou les pieds de page sont activés.

2) Positionnez le curseur sur l’en-tête ou le pied de page (à l’aide de la souris ou des touches de raccourci Ctrl+Page Précédente pour l’en-tête ou Ctrl+Page Suivante pour le pied de page).

3) Le cas échéant, tapez : Page <espace>.

4) Insertion > Champ > Numéro de page.

5) Le cas échéant, tapez <espace> sur <espace>, puis cliquez sur Insertion > Champ > Nombre de pages.

Pour insérer un champ qui calcule un nombre de pages différent (par exemple, si votre document compte une page de titre, mais que vous souhaitez que les pages suivantes affichent page 1 sur 2 au lieu de page 1 sur 3) :

1) Pressez F2 pour afficher la barre de formule texte.

2) Tapez =page – 1.

3) Pressez Entrée.

	Remarque
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	Hélas, ce champ ne se met pas à jour automatiquement. Il faut donc presser F9 pour rafraîchir avant d’imprimer.


Attribuer aux numéros de page les mêmes places et orientation sur une disposition portrait ou paysage

1) Créez un style pour des pages disposition paysage. Définissez les pages pour le style paysage de façon qu’elles coïncident avec le style portrait lorsqu’elles pivotent (haut = gauche, bas = droite, gauche = bas et droit = haut). Pour une numérotation des pages à gauche, activez les en-têtes ; à droite : activez les pieds de page. Sélectionnez Utilisation de l’espacement dynamique.

2) Créez un style pour un en-tête ou un pied de page façon paysage basé sur le style associé à l’en-tête ou au pied de page façon portrait. (Dans la fenêtre Styles et formatage, sélectionnez le style utilisé pour l’en-tête ou le pied de page façon portrait > clic droit > Nouveau.) Définissez la position de la police à 270°. Si la numérotation des pages est activée en bas, choisissez l’alignement à gauche ; pour le haut, choisissez à droite.

3) Insérez le saut de page et choisissez le style de page que vous venez de créer (voir ci-dessus) ; ne modifiez pas la numérotation.

4) Dans l’en-tête/pied de page approprié (comme pour l’étape 1), insérez le champ numéro de page.

 XE "Texte conditionnel, Writer" Texte conditionnel

Dans Word, la seule façon de saisir du texte conditionnel est d’utiliser le champ « Si »
. Dans Writer, l’équivalent est le « Texte conditionnel ».

Pour insérer un champ conditionnel dans Writer : Insertion > Champ > Autres > Fonctions > Texte conditionnel ou Ctrl+F2 > Fonctions > Texte conditionnel.

Il existe aussi un champ « Texte masqué» qui cache le texte quand la condition est active.

Travailler avec les champs appropriés à du texte conditionnel, dans Word comme dans Writer, requiert que seules de petites quantités de texte puissent être conditionnelles. Dans certains cas, cependant, il peut être fort commode d’avoir des sections ou des paragraphes entiers masqués de façon conditionnelle. Quelques exemples :

Un test où le même document pourra être utilisé pour le test lui-même et pour les réponses types.

Des documents techniques où le même document, comportant des variations, peuvent être utilisés pour des modèles d’appareils similaires.

Writer propose un champ pour cacher des paragraphes de façon conditionnelle et la possibilité de masquer des sections selon condition. Voici un exemple pour illustrer comment ceci est possible :

1) Assurez-vous que le texte masqué est visible : Outils > Options > OpenOffice.org Writer > Aides au formatage, cochez « Champs : Texte masqué » et « Champs : Paragraphes masqués ».

	Remarque

[image: image39.png]



	Les sections masquées selon condition ne sont pas visibles en dépit de ces paramètres si la condition commandant de les masquer est active.


2) En haut du document : Insertion > Champ > Autres > Variables.

3) Nom : DocType. Valeur : Réponse type.

4) Au début d’une réponse comptant un seul paragraphe : Insertion > Champ > Autres > Fonctions > Paragraphe masqué. Pour le type de condition tapez DocType== « Test » (Pour faciliter l’insertion répétée, créez une entrée d’auto-correction).

5) Pour des réponses plus longues : saisissez la réponse type, sélectionnez-la, Insertion > Section, cochez Masquer, et saisissez DocType == « Test » pour la condition.

6) Pour imprimer le document pour un test, double-cliquez sur le champ en haut du document créé lors des étapes 2 et 3, et définissez la valeur comme Test. Imprimez comme à l’accoutumée.

	Remarque 1
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	Le champ « Liste de saisie » a un nom, mais ne s’agissant pas d’une variable, sa valeur ne peut être utilisée dans la condition.

	Remarque 2
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	Continuer à ajouter des sections est plus aisé si la sélection n’inclut pas le dernier paragraphe. Mais si le dernier paragraphe est sélectionné, il suffit d’aller à la fin du document (Ctrl+Fin ) puis de presser Alt+Entrée.


 XE "Documents maîtres, Writer" Documents maîtres

L’Aide d'OpenOffice.org explique les fonctions de base liées à l’utilisation des documents maîtres. Vous pouvez aussi vous reporter à la rubrique « Travailler sur des documents complexes ou volumineux » à la page 125, ou pour davantage de détails, consulter le chapitre 13 « Working with Master Documents » du « Writer Guide » (anglais).

Il est possible d’insérer des renvois entre plusieurs sous-documents, mais les noms des références doivent être saisis directement plutôt que sélectionnés dans une liste.

Utilisez Insertion > Champs > Autres > Références.

Une macro facilitant l’insertion de références dans des en-têtes, y compris des références au sein de documents qui constitueront des sous-documents dans un document maître, est disponible dans un document intitulé  XE "OutlineCrossRef" OutlineCrossRef3-fr-3.zip, que vous trouverez à l’adresse http://ooomacros.org/user.php#113812.

	Remarque
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	Il n’existe aucun moyen de faire en sorte qu’une page en mode paysage dans un sous-document conserve cette orientation lorsqu’on l’incorpore dans le document maître. Solution de rechange : la page en orientation paysage doit faire partie du document maître plutôt qu’en constituer un sous-document, ou définissez le sous-document entier comme page en orientation paysage.


Chapitre

6

   Différences d'utilisation entre Calc et Excel

Introduction

Ce chapitre résume les différences d'utilisation entre OpenOffice.org Calc 2.3 et Microsoft Excel. Les informations fournies dans ce chapitre sont basées sur celles du chapitre 4 : « Généralités sur les différences pratiques entre OpenOffice.org et Microsoft Office ».

L’interface de Calc

La Figure 19 représente l’espace de travail principal de Calc.[image: image83.png]= Nouveau dictionnaire de I'uti
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Terminologie

Le Tableau 12 résume les différences de terminologie entre Calc et Excel.

Tableau 12 : terminologies comparées de Excel et Calc

	Objet
	Excel
	Calc

	Cellule individuelle (A1)
	Cellule
	Cellule

	Fichier complet
	Classeur
	Classeur

	Un onglet dans un classeur (feuille 1)
	Feuille de calcul
	Feuille

	Message qui apparaît dans la cellule quand le pointeur la survole
	Commentaire
	Note


Interface utilisateur

Calc utilise une  XE "Interface à document unique" Interface à document unique (SDI). Cela signifie que chaque document s’ouvre dans sa propre fenêtre. Excel utilise une  XE "Interface à documents multiples" Interface à documents multiples (MDI), où tous les documents ouverts s’affichent dans une fenêtre unique. Quand vous fermez cette fenêtre, tous les fichiers se ferment également.

Deux des points forts de Calc sont l’accessibilité des informations concernant le document actif et la facilité de navigation dans une SDI. Chaque fenêtre Calc affiche des menus, des barres d’outils et d’autres éléments qui concernent directement le document ouvert dans cette fenêtre.

Lorsque plusieurs documents OpenOffice.org sont ouverts, vous pouvez passer d’un document actif à un autre document ouvert de différentes façons :

1) Dans le menu Fenêtre, sélectionnez le document que vous voulez activer.

2) Utilisez le bouton Restaurer dans la barre de titre pour réduire le document actif et afficher les autres documents ouverts.

3) Sélectionnez un document à partir du Bureau ou de la barre des tâches pour l’activer.

4) Fermez le document actif pour accéder aux autres documents ouverts.

5) Utilisez le raccourci clavier Alt+Tab pour naviguer entre les documents ouverts.

Glisser-déposer

Le glisser-déposer fonctionne de façon légèrement différente dans Calc et dans Excel :

1) Dans Excel, lorsque vous sélectionnez une cellule ou un groupe de cellules à déplacer, vous devez positionner le pointeur de la souris avec assez de précision sur son contour pour que le glisser-déposer soit accessible. Dans Calc, après avoir sélectionné une cellule ou un groupe de cellules, vous pouvez positionner le pointeur de la souris n’importe où dans la plage.

2) Dans Calc, pour glisser-déposer une seule cellule, il faut : 

1) Sélectionner la cellule.

2) Cliquer et déplacer la souris pour atteindre une cellule adjacente.

3) Revenir en arrière pour que seule la cellule à déplacer soit sélectionnée. Vous pouvez alors glisser-déposer la cellule.

· Dans Calc, pour laisser la cellule (ou le groupe de cellules) d’origine intacte pendant le glisser-déposer (en d’autres termes, pour créer une copie), faites glisser la ou les cellules normalement, puis juste avant de la ou les déposer, pressez et maintenez enfoncée la touche Ctrl, puis relâchez le bouton de la souris.

Raccourcis clavier

Tableau 13 : Sélection de raccourcis clavier par défaut dans Excel et Calc 

	Fonction
	Raccourci Excel
	Raccourci Calc

	Adapter les références relatives ou absolues (par exemple, A1, $A$1, $A1, A$1) dans la zone de saisie
	F4
	Maj+F4

	Modifier le commentaire d’une cellule (« note » dans Calc)
	Maj+F2
	Ctrl+F1

	Recopier vers la droite ou vers le bas
	Ctrl+R ou Ctrl+D
	Pas d’équivalent

	Atteindre une cellule donnée
	F5
	F5 (affichage du Navigateur)

	Insérer une Fonction
	Pas d’équivalent standard
	Ctrl+F2

	Saisir dans toutes les cellules sélectionnées
	Ctrl+Entrée
	Alt+Entrée

Alt+Maj+Entrée (applique aussi le format de cellule)

Dans les 2 cas, les cellules doivent être contiguës.


Listes de plages

Excel permet à tous les paramètres d’être des listes de plages. Quelques exemples :

=SOMME(A1;A3) est la somme de deux cellules (la fonction compte 2 paramètres).

=SOMME((A1;A3)) est équivalent, mais avec un paramètre qui est une liste de plages.

=INDEX((A2:A3;C2:C3);1;1;2)

Calc n’accepte les listes de plages que dans la fonction INDEX. Par exemple : 

=INDEX((A2:A3;C2:C3);1;1;2) affiche le contenu de la première cellule de la seconde plage de la liste des plages.

 XE "Supprimer le contenu des cellules, Calc" Supprimer le contenu des cellules

Dans Excel, la touche Suppr (supprimer) efface instantanément le contenu de la cellule. Dans Calc, une boîte de dialogue s’ouvre et vous demande de préciser ce que vous voulez supprimer : 

1) Chaînes de caractères

2) Nombres

3) Date & Heure

4) Formules

5) Notes

6) Formats

7) Objets

Les éléments cochés par défaut sont : Chaînes de caractères ; Nombres ; Date & Heure ; Formules ; et Notes. Ainsi, l’action Suppr suivi de Entrée effacera les éléments cochés par défaut.

Vous pouvez éviter la boîte de dialogue et effacer immédiatement les éléments cochés par défaut en appuyant sur la touche Retour au lieu de la touche Suppr.

 XE "Remplir vers le bas ou vers la droite, Calc" Remplir vers le bas ou vers la droite

Utilisation de la fonction de remplissage vers le bas ou vers la droite

Dans Excel, il est possible de copier-coller une cellule vers une plage de cellules en-dessous ou à droite de celle-ci. Pour réaliser cette opération, sélectionnez une plage de cellules, avec la cellule source en haut (recopie vers le bas) ou à gauche (recopie vers la droite), puis utilisez le raccourci Ctrl+D (pour recopier vers le bas) or Ctrl+R (pour recopier vers la droite). Il existe également une commande dans le menu qui effectue la même tâche que le raccourci clavier. 

Dans Calc, les mêmes fonctions sont disponibles, mais seulement par une commande du menu, et non par des raccourcis clavier. De plus, dans Calc, on peut remplir vers le haut ou vers la gauche. La commande du menu est : Édition > Remplir > Vers le bas (ou haut, droite, ou gauche).

Utiliser la poignée de remplissage

Dans Calc comme dans Excel, la poignée de remplissage peut être utilisée pour copier le contenu d’une cellule vers le bas ou vers la droite. Elle fonctionne quelque peu différemment dans Calc et Excel.
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Pour utiliser la poignée de remplissage, sélectionnez la cellule source, positionnez le pointeur de la souris sur la poignée de remplissage pour qu’il devienne un signe plus (+), puis faites glisser vers le bas ou vers la droite.

1) Dans Excel, l’action ci-dessus copiera le contenu de la cellule.

2) Dans Calc, si la cellule source ne contient que des lettres, ou une suite de lettres et de nombres ne se terminant pas par un nombre (exemple : A4B), alors la cellule source sera recopiée exactement. 

3) Si la cellule est numérique, le nombre sera incrémenté de 1 dans chaque cellule supplémentaire (exemple : 5 ; 6 ; 7, ... ; ou 1,5 ; 2,5 ; 3,5 ; ...). Si le contenu de la source est une suite qui commence ou se termine par un nombre, l’élément numérique de la suite sera incrémenté de 1 (exemple : A1 ; A2 ; A3 ; ...).

4) Dans Calc, on peut recopier exactement le contenu de la cellule source, sans incrémentation, en maintenant la touche Ctrl enfoncée lorsqu’on fait glisser la poignée de remplissage.

Que l’on soit dans Excel ou Calc, si l’on sélectionne deux cellules adjacentes contenant des données numériques et utilise la poignée de remplissage, on obtient la même incrémentation entre les cellules « remplies » que celle existant entre les deux cellules sources. Par exemple, si la cellule A1=1,0 et la cellule A2=1,1, en sélectionnant ces cellules et en utilisant la poignée de remplissage, on obtiendra : A3=1,2; A4=1,3; etc.

Format numérique par défaut

Calc et Excel utilisent des formats numériques par défaut différents.

1) Avec Excel, les cellules sont au format numérique « Standard ». Si vous saisissez 25,12345 dans une cellule, celle-ci affichera donc « 25,12345 ». 

2) Dans Calc, une cellule est formatée par défaut au format « Standard » de la catégorie « Nombre » . Ainsi, si on saisit 25,12345, la cellule affichera 25,12.

Interprétation du format de la cellule

Dans Calc, une cellule formatée en texte, même s’il s’agit d’un nombre, est considérée comme du texte, ce qui signifie qu’elle a la valeur numérique zéro dans les formules de calcul.

Par exemple, si la cellule A1 est formatée en texte et qu’elle contient le caractère « 1 », dans Excel une formule =A1+1 afficherait la valeur 2, mais dans Calc elle afficherait la valeur 1.

Dans les fonctions, une telle valeur sera ignorée plutôt que considérée comme un zéro. Par exemple, la fonction MOYENNE ne considérera pas une entrée texte comme un zéro, mais n’en tiendra pas compte. Si la cellule A1 a la valeur texte « 1 », et que la cellule A2 a la valeur numérique « 10 », =MOYENNE(A1:A2) donnera 10 et non 5.

 XE "Limitations, Calc" Limitations

Le nombre maximum de feuilles dans Calc est de 256. Dans Excel, le nombre de feuilles est d’après le site internet de Microsoft « Limité par la mémoire disponible (par défaut 3 feuilles) ».

 XE "Champs de formulaires, Calc" Champs de formulaires

Selon les cas, les listes déroulantes dans Calc peuvent ou non accepter la sélection multiple, alors qu’Excel possède deux modes de sélections multiples : multi et étendu. Dans Excel, le lien d’une liste déroulante à sélections multiples vers une cellule est ignoré. Dans Calc, le lien fonctionne, mais si plus d’un élément est sélectionné, la valeur de la cellule devient #N/A.

Dans Calc, chaque bouton d’option a son propre lien vers une cellule, fixant sa valeur à vrai ou faux suivant que cette option est sélectionnée ou pas. Dans Excel, le lien de la cellule donne le nombre du bouton de l’option sélectionnée.

Adressage relatif des feuilles

Dans Calc, il est possible d’avoir un adressage relatif des feuilles. Comme pour les références des colonnes et des cellules, le signe dollar est utilisé pour indiquer que le nom de la feuille est absolu.

=$feuille2.$A$1 indique toujours la première cellule de la feuille 2.

=feuille2.$A$1 Quand cette adresse se trouve sur la feuille 1 et qu’elle est copiée sur une autre feuille, elle indique la première cellule de la feuille suivante. 

Ceci n’est pas possible avec Excel.

Noms de  XE "Noms de plage de cellules, Calc" plage de cellules et formules en « Langage naturel »

Il est possible, dans certaines versions d’Excel, d’attribuer le même nom à une plage de cellules sur différentes feuilles. Ceci n’est pas possible avec Calc. Cependant, si le même nom de plage dans Excel s’applique à chaque fois aux mêmes cellules, alors il peut être simulé dans Calc avec un nom de plage sans précision de la feuille. Le nom de la plage désigne ainsi les cellules spécifiées sur la feuille courante.

Calc utilise le langage naturel. C’est ainsi que les étiquettes des colonnes ou des lignes sont utilisées (sans qu’elles soient définies comme noms de plages) dans une formule. Dans Excel, pour faire référence à une cellule, on met une espace entre les étiquettes. Dans Calc, on utilise un point d'exclamation « ! » (parfois appelé « pling »).

Dans Calc, les noms sont entourés de guillemets simples (Calc le fait automatiquement si l’étiquette commence par une lettre et ne comporte que des caractères alphanumériques). Pour activer ou désactiver cette fonction, il faut utiliser : Outils > Options > OpenOffice.org Calc > Calcul > Rechercher automatiquement les étiquettes de colonnes et lignes.

 XE "Fonctions, Calc" Fonctions

	Attention 
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	Dans Excel et Calc, les valeurs fournies dans une fonction (appelées arguments sous Excel et paramètres sous Calc) peuvent avoir des séparateurs différents. Calc utilise toujours des points-virgules pour séparer les paramètres d’une fonction. Excel utilise soit des virgules soit des points-virgules, selon le système (par exemple des virgules dans les systèmes anglais et des points-virgules dans les systèmes français). Calc affichera le message d’erreur « #NOM? » si l’on utilise une virgule au lieu d’un point-virgule.


 XE "Dates dans les fonctions financières, Calc" Indication de la date dans les fonctions financières

Avec Excel, certaines fonctions financières admettent comme paramètres des chaînes de caractères pour les dates ; avec Calc les fonctions financières exigent un nombre, même si vous pouvez simplement saisir les dates au format date sans guillemets.

 XE "Fonctions complémentaires d'analyse, Calc" Fonctions complémentaires d’analyse

Chaque fois qu’une fonction de l’utilitaire d’analyse d’Excel a le même nom qu’une fonction de Calc, celle-ci y apparaît avec une extension _ADD. Ceci permet la compatibilité avec Excel sans changer le comportement des fonctions déjà présentes dans Calc.

Par exemple, les fonctions TAUX.NOMINAL et CONVERT de l’utilitaire d’analyse d’Excel sont appelées TAUX.NOMINAL_ADD et CONVERT_ADD dans Calc et donnent les mêmes résultats. Les fonctions dont le nom se termine par _ADD donnent le même résultat que les fonctions correspondantes de Microsoft Excel.

Utilisez les fonctions sans _ADD pour obtenir des résultats conformes aux normes internationales. Par exemple, la fonction NO.SEMAINE calcule le numéro de la semaine d’une date donnée selon la norme internationale ISO 6801, alors que NO.SEMAINE_ADD rend le même numéro de semaine que Microsoft Excel.

Différences de résultat des fonctions

Calc et Excel gèrent différemment l’absence du paramètre Référence dans la fonction Cellule, CELLULE(Type_info; Référence). En l’absence de Référence, Calc utilise la position de la cellule où se trouve cette formule. Excel utilise la référence de la cellule où se trouve le curseur.

Fonctions nommées différemment ou inexistantes

Parmi les fonctions d’Excel, certaines n'ont pas le même nom sous OpenOffice.org Calc. Par exemple dans Excel on trouve la fonction LIREDONNEESTABCROISDYNAMIQUE qui s'appelle GETPIVOTDATA dans Calc, comme en anglais. 

Il n’existe pas d’équivalent dans Excel pour la fonction ARABE de Calc, qui calcule la valeur d’un nombre en chiffres romains.

 XE "Pilote de données, Calc" Pilote de données ou tableau croisé dynamique

Les Pilotes de données sont l’équivalent dans Calc des tableaux croisés dynamiques d’Excel. Il existe cependant un certain nombre de limites. Les tableaux croisés dynamiques peuvent être importés d’Excel vers Calc (bien que les champs ne soient pas ombrés comme dans les tableaux croisés dynamiques), mais dès que vous voulez les retravailler, des limitations apparaissent.

Ces limitations sont les suivantes :

1) Il n’y a pas de rapport de graphique croisé dynamique, mais un Pilote de données peut servir de source de données pour un graphique.

2) L’interface utilisateur autorise un maximum de 8 champs dans les zones de données, de lignes ou de colonnes. (Une interface alternative qui en autorise davantage est disponible ici : http://homepages.paradise.net.nz/hillview/OOo/ dans un document intitulé MyDataPilot3.ods).

3) Il existe la possibilité de regrouper les données (par exemple, regrouper le champ date par semaine ou trimestre, mais pas par mois). La solution consiste à créer une nouvelle colonne avec une formule pour calculer le regroupement, par exemple  =Mois().

4) On ne peut pas définir des formats différents pour des champs différents.

5) Calc peut accepter des formules telles que « Différence de » ou « % de », mais ne peut pas avoir ses propres champs personnalisés (solution : créez de nouvelles colonnes pour calculer les valeurs souhaitées).

6) Les options de l’API (interface de programmation) sont incomplètes pour écrire des macros qui fonctionnent avec les Pilotes de données -- par exemple, la possibilité de décider, par l’intermédiaire d’un autre programme comme le langage BASIC des macros d’OpenOffice.org, que les tableaux ont des totaux généraux ou qu’ils ont accès aux Pilotes de données créés à partir de données externes.

AutoFiltres

Il y a un certain nombre de différences entre les AutoFiltres de Excel et de Calc :

1) Il n’y a qu’un Autofiltre actif à la fois, pour un document de tableur, à moins qu’on utilise des noms de plages de base de données. Les lignes restent cachées, mais les menus déroulants de la première ligne disparaissent si l’on applique l’AutoFiltre ailleurs. Pour avoir plus d’un AutoFiltre actif à la fois, définissez un nom de plage de base de données (Données > Définir la plage) pour les données. Il sera alors possible  d’avoir plus d’un AutoFiltre actif sur une feuille (ce qu’Excel ne sait pas faire.)

2) Les autres numéros de ligne visibles ne changent pas de couleur pour vous avertir qu’il y a un filtre en place.

3) Les valeurs erronées n’apparaissent pas parmi les options des listes déroulantes quand des cellules de la colonne comportent des erreurs.

4) Dans les listes déroulantes, l’équivalent du « Personnalisé » de Excel est appelé « Standard ».

5) L’élément « Top 10 » de la liste déroulante est à prendre au sens littéral, mais pour obtenir le même degré de contrôle, vous pouvez utiliser « Standard » et préciser « le plus grand », « le plus grand % », « le plus petit » ou « le plus petit % » dans le champ condition.

6) Utilisez des expressions régulières pour préciser les critères de sélection des lignes en fonction du texte des cellules. Pour cela :

1) Choisissez « Standard » dans la liste déroulante.

2) Cliquez sur le bouton Options pour afficher le reste de la boîte de dialogue.

3) Cochez « Expressions régulières ».

Le Tableau 14 montre des exemples permettant à un utilisateur d’Excel d’utiliser des expressions régulières.

Tableau 14 : Exemples d’expressions régulières pour AutoFiltre

	Commande spécifique Excel
	Champ Comparaison
	Expression Regulière
Equivalente

	Commence par x
	=
	^x.*

	Ne commence pas par x
	<>
	^x.*

	Finit par x
	=
	.*x$

	Ne finit pas par x
	<>
	.*x$

	Contient x
	=
	.*x.*

	Ne contient pas x
	<>
	.*x.*


Vous n’êtes pas limité à ces expressions régulières. Elles sont incluses ici pour montrer comment obtenir le même résultat pour Autofiltre dans Calc que dans Excel.

Conversion de texte en colonne

On ne peut pas le faire dans Calc sans un module extérieur. Se référer à l’adresse : http://ooomacros.org/user.php#104183 pour télécharger une macro permettant de rendre cette fonction possible.

 XE "Solveur, Calc" Solveur

Il n’y a pas pour le moment d’équivalent natif au Solver de Excel, mais un module externe  est disponible à l'adresse suivante :  http://kohei.us/ooo/solver/.  Il est pour GNU/Linux uniquement. Mais sous la plupart des distributions GNU/Linux, OpenOffice.org inclut ce solveur d'origine.

Si vraiment vous avez besoin d'un solveur, en attendant qu'il soit intégré par défaut dans la version officielle d'OpenOffice.org, vous pouvez aller voir le projet Go-oo à l'adresse suivante :

http://go-oo.org/
C'est une version d'OpenOffice.org « améliorée » qui contient divers ajouts qui ne sont pas encore intégrés officiellement.

 XE "Diagrammes, Calc" Diagrammes

Types de diagrammes disponibles avec Excel mais pas dans Calc : 

1) Barres de secteur est converti en Secteur Normal

1) Secteurs de secteur est converti en Secteur Normal

2) Radar plein est converti en Radar Lignes Seules

3) Radar avec marquage des données est converti en Toile Points et Lignes, mais dans le sens contraire des aiguilles d'une montre plutôt que dans le sens des aiguilles d'une montre d'Excel

4) Bulles sont converties en diagrammes XY Lignes Seules

5) Surface 3D est converti en Colonnes 3D Profond Boites

D’autres différences :

1) Les diagrammes sont plus lents à se mettre à jour sous Calc que sous Excel.

2) Il y a moins d’options pour gérer les axes de données. Par exemple, il n’y a pas d’option pour l’inversion de l’axe Y (valeurs négatives en haut, positives en bas).

Lignes de la grille et autres paramètres d'affichage

Dans Microsoft Excel, les lignes de la grille sont une propriété de chaque feuille de travail (onglet). Dans Calc, c’est une propriété générale du document que vous pouvez modifier grâce au menu suivant :

Outils > Options > OpenOffice.org Calc > Affichage

Lignes masquées

Il n’existe pas dans Calc la possibilité de ne choisir que les lignes visibles. Supprimer une plage de données contenant des lignes masquées supprimera aussi ces lignes. Il existe un moyen de contourner cette limitation : sélectionnez une par une les lignes visibles avant de les supprimer. Vous pouvez trouver à l’adresse suivante : http://homepages.paradise.net.nz/hillview/OOo/ la macro  IannzGotoSpecial.sxc qui permet de ne sélectionner que les cellules visibles.

Navigateur

Le Navigateur  d’OpenOffice.org (Figure 20) permet une visualisation hiérarchique des objets qui constituent le document. Avec le Navigateur, vous pouvez visualiser la liste des objets comme les feuilles de calcul, les plages et les bases de données, les plages liées, les diagrammes, les objets OLE (technologie Object Linking and Embedding), les notes et les objets graphiques. C’est là une manière aisée de naviguer simplement parmi les différents objets composant le document et des les sélectionner, mais vous pouvez aussi l’utiliser de façon plus puissante, pour copier des cellules ou insérer des liens dans une feuille de calcul à partir d’autres documents, ou d’une autre feuille de calcul du même classeur. (Se référer à la section « Travailler avec plusieurs feuilles de calcul » à la page 163).

Le Navigateur effectue des copies et des insertions de liens par le biais de glisser-déposer. Pour créer un lien grâce au Navigateur, il faut définir la donnée qui sera l’objet du lien comme une plage de données dans le document source. Si cette plage de données n’a pas été nommée dans le document source, le Navigateur ne sera pas en mesure de la lister comme objet pouvant être lié.

Le Navigateur affiche aussi les objets et peut créer des liens avec des feuilles de données Excel.
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Fenêtre Styles et formatage

Calc gère deux types de styles, cellule et page. Pour afficher la fenêtre Styles et formatage (Figure 21), pressez F11 ou utilisez le menu Format > Styles et formatage. Par un clic droit dans cette fenêtre, vous pouvez créer, modifier ou supprimer des styles.
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Formatage conditionnel

Pour pouvoir utiliser le formatage conditionnel, il faut au préalable avoir défini des styles. Vous pouvez ensuite utiliser le menu  Format > Formatage conditionnel. 

Liste des fonctions

La « Liste des fonctions » est une fenêtre flottante ou ancrable qui fournit les informations sur les fonctions utilisables. C’est une alternative à « l’Assistant fonctions ». Pour faire apparaître cette fenêtre, utilisez le menu Insérer > Liste des fonctions.

 XE "Erreurs, Calc" Gestion des erreurs

Certaines fonctions de Calc peuvent retourner des messages abscons comme Err:503.

Pour obtenir un message d’erreur plus explicite, sélectionnez la cellule comportant le message d'erreur et regardez complètement à droite dans la barre d’état.

Dans le cas présent, le message sera « Erreur : opération à virgule flottante non valide » (par exemple parce que vous avez tenté d’effectuer une division par zéro).

Une description complète de tous les messages d’erreurs est disponible dans l’aide de OpenOffice.org.

Travailler avec plusieurs feuilles de calcul, des pages Web et des bases de données

Travailler avec plusieurs feuilles de calcul

Le Navigateur de Calc permet de copier ou de lier des données provenant d’une autre feuille de calcul (document source).

Pour insérer un lien (ou une référence) ou copier une cellule ou une plage de cellules avec le Navigateur :

1) Ouvrez les documents source et cible. 

2) Ouvrez le navigateur à partir du document cible. Utilisez le menu Édition > Navigateur ou le raccourci clavier F5. Sélectionnez le type de mode glisser-déposer (en cliquant sur la flèche à droite de l’icône « Mode glisser ») :

1) Insérer comme hyperlien – crée un hyperlien vers le document source. 

2) Insérer comme lien – crée une copie liée de la donnée dans le document cible (i.e qui se modifiera en fonction des modifications faites dans la source).

3) Insérer comme copie – copie les données du document source dans le document cible, mais sans créer de lien. 

3) Sélectionnez le document source dans la liste déroulante située au bas de la fenêtre. 

4) Parcourez la liste Nom de plages (au besoin, ouvrez-la en cliquant sur le signe +). S’il n’y a pas de plage de données définie dans le document source, aucune sélection ne sera disponible pour effectuer l’insertion.

5) Sélectionnez et glissez la plage vers la feuille de calcul cible.

	Remarque
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	Si la plage de cellules de la feuille de calcul source que vous voulez insérer n’a pas été nommée, vous pouvez le faire à ce moment-là en utilisant la boîte de dialogue Définir des noms, accessible par le menu Insérer > Noms > Définir, ou en utilisant le raccourci clavier Ctrl+F3.

Seules les plages de données nommées peuvent apparaître dans le navigateur.
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Pour faire référence au contenu d’une cellule d’une autre feuille de calcul ou d’un autre classeur, la syntaxe est la suivante :

’url de l’autre document’#$NomdeLaFeuille.PlageDeCellules. 

Par exemple, sous Linux : 

’file:///home/hillview/Documents/Tests/Address.xls’#$feuille1.A1

ou sous Windows :

'file:///C:/Documents/Tests/Address.xls’#$feuillet1.A1

Pour saisir ces liens, vous devez :

1) Taper votre formule jusqu’à l'endroit où vous devez insérer la référence.

2) Sélectionner Fenêtre > [le document qui est votre source].

3) Sélectionner la cellule ou la plage de cellules souhaitée.

4) Sélectionner Fenêtre > [le document qui est votre cible].

5) Finir de compléter votre formule.

Un point peut s’avérer déconcertant : la valeur affichée est basée sur la valeur de la cellule (ou de la plage de cellules) au moment de la dernière sauvegarde du document.

Pour vérifier, il suffit donc de sauvegarder le document lié (source) et de mettre à jour le lien dans le document contenant le lien (cible). Pour ce faire, utilisez le menu Édition > Liens.

	Remarque
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	Les liens créés comme décrits précédemment, y compris par la méthode glisser-déposer du Navigateur, ne sont pas mis à jour automatiquement.

Pour les mettre à jour, utilisez le menu Édition > Liens > [le lien en question] > Actualiser.

La mise à jour s’effectue à partir du fichier sauvegardé, donc si chacun des deux fichiers est ouvert et que la source du lien est modifiée, le fichier doit être enregistré avant de faire la mise à jour du lien.


Pour assurer une mise à jour permanente des données entre deux feuilles de calcul, il faut utiliser les liens DDE (technologie Dynamic Data Exchange) :

1) Sélectionnez et copiez la plage de cellules qui doit être liée.

2) Positionnez-vous sur la feuille de calcul qui va contenir ce lien, sélectionnez une cellule vide, et par un clic droit l’option collage spécial...

3) Dans les options de la boîte de dialogue, cochez l’option Lier.

4) Cliquez sur OK pour insérer le lien DDE.

Les cellules ainsi créées ont un lien permanent avec le contenu de l’autre feuille de calcul et leurs valeurs peuvent être utilisées dans d’autres formules.

Liens vers des données HTML ou d’autres feuilles de données

Pour créer un lien vers des données issues d’Internet :

1) Dans un navigateur, allez à la page choisie.

2) Copiez l’URL.

3) Dans Calc, utilisez le menu Insertion > Lien vers les données externes...

4) Collez l’URL.

5) Attention, cette étape n’est pas évidente : pressez Entrée et attendez un instant. Une liste (appelée Feuille/plages disponibles) va alors se remplir avec les informations suivantes :

1) HTML_all (l’intégralité de la page)

2) HTML_tables (toutes les tables disponibles dans la page)

3) HTML_1... (chacune des tables disponibles listées par ordre dans la page)

6) Sélectionnez l’option souhaitée dans la liste.

7) Si vous voulez, utilisez l’option « Actualisation toutes les » et spécifier le délai en secondes.

Il est possible d’utiliser la même méthode pour créer des liens vers des données situées dans d’autres feuilles de données.

	Remarque
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	Le fichier source doit être enregistré avant que la mise à jour puisse se faire. (Dans OOo, la sauvegarde automatique écrase le fichier d’origine. Avec l’option Sauvegarde automatique activée, cette fonction peut donc être plus utile qu’il n’y paraît).


Liens vers des données issues d’une base de données

1) Affichez le navigateur de Sources de données (F4).

2) Dans la fenêtre Sources de données, choisissez la table ou la requête qui vous intéresse.
Si vous ne voyez pas l’intégralité des informations, utilisez le bouton  Afficher/Masquer de l’explorateur.

3) Glissez la table ou la requête sur la feuille de calcul (pour plus d’informations sur la façon de travailler avec les sources de données, comme référencer des sources de données, référez-vous au chapitre 11 « Getting Started with Base » du manuel « Getting Started » (anglais)).

Imprimer

Calc et Excel possèdent des fonctions d’impression similaires, mais il existe malgré tout quelques différences importantes.

Par défaut, si aucune plage d’impression n’a été définie au sein d’une feuille de calcul, Calc prendra la plage rectangulaire commençant à la cellule A1 jusqu’à la cellule ayant un contenu la plus en bas à droite de la feuille.

Si une plage d’impression a été définie sur une feuille du classeur, même sur une feuille différente de la feuille courante, alors il n’y a plus de plage d’impression par défaut sur aucune des feuilles. Dans ce cas, si une plage d’impression n’a pas été définie pour une feuille en particulier, aucune donnée de cette feuille ne sera imprimée.

Si vous ne souhaitez imprimer qu’une partie de la feuille de calcul, vous devez spécifier une plage d’impression.

Pour définir une plage d’impression, 2 solutions. Soit vous sélectionnez toute la zone que vous souhaitez imprimer et vous allez dans Format > Zones d'impression > Définir ; soit vous avez l’équivalent de Fichier > Mise en page > Feuille d'Excel (en n’utilisant que les trois premiers paramètres) :

1) Format > Zones d’impression > Éditer.

2) Dans la boîte de dialogue Éditer les zones d’impression (Figure 23), sélectionnez la plage pour chacun des champs.

3) Vous pouvez sélectionner des plages de données non contiguës pour l’impression, chacune des plages étant imprimée sur une page séparée. Les différentes plages sélectionnées sont séparées par un caractère « ; ».
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Vous pouvez également définir simplement plusieurs zones d'impression sur une même feuille : Format > Zones d'impression > Ajouter. Idem pour en supprimer une : Format > Zones d'impression > Supprimer.

Calc permet de prévisualiser les sauts de page à l’impression grâce au menu :

1) Affichage > Aperçu des sauts de page

On peut modifier d’autres paramètres tels que l’impression du quadrillage grâce au menu :

1) Format > Page  > Classeur > option Grille (fenêtre « Style de page »)

Pour imprimer :

1) Fichier > Imprimer...

2) Cliquez sur Options pour modifier les options d’impressions comme « Ignorer les pages vides pour l’impression » ou « Imprimer uniquement les feuilles sélectionnées ».

3) Les autres paramètres d’impression sont similaires à ceux d’Excel.

 XE "Macros, Calc" Macros

Les macros écrites en VBA pour Excel ne fonctionnent pas dans Calc, de même que les macros écrites en StarBasic pour Calc ne fonctionnent pas sous Excel. La réécriture des macros est indispensable quand une feuille de calcul est transférée d’une application à l’autre.

Pour plus d’informations sur la réécriture des macros, se référer à :

“Porting Excel/VBA to Calc/ XE "StarBasic" StarBasic” 
http://documentation.openoffice.org/HOW_TO/various_topics/VbaStarBasicXref.pdf
StarOffice 8 Programming Guide for BASIC 
http://docs.sun.com/app/docs/doc/819-0439
“Useful Macro Information for OpenOffice”, by Andrew Pitonyak, 
http://pitonyak.org/AndrewMacro.odt
OpenOffice.org Macros Explained, by Andrew Pitonyak, 
http://www.hentzenwerke.com/catalog/oome.htm
Et le site web d’Andrew Pitonyak sur les macros OOo :  http://pitonyak.org/oo.php
Cependant Sun et Novell collaborent au développement du support du VBA dans OpenOffice.org. Vous trouverez des informations sur ce site : http://wiki.services.openoffice.org/wiki/VBA
Ce développement n'est pas encore 100% opérationnel et donc pas encore intégré dans la version officielle d'OpenOffice.org. Mais une version non officielle permet de tester cette future fonctionnalité. Vous la trouverez sur le site : http://go-oo.org/
Il existe également une extension que l'on peut rajouter à OOo : OOOP-accessories. C'est une extension liée au projet OxygenOffice Professional. Vous la trouverez à cette adresse : http://sourceforge.net/projects/ooop
Reconnaissance des nombres

Grâce à la reconnaissance des nombres, lorsque l’utilisateur saisit un nombre, le format de la cellule change pour y correspondre au mieux. De la même façon, ce « formatage » s’applique aux données en provenance d’une autre application que Calc et qui sont insérées dans une feuille de calcul.

Plutôt que de comparer Excel et Calc sur ce sujet, cette section présente la façon dont la reconnaissance des nombres fonctionne sous Calc (elle est légèrement différente de celle d’Excel)

La reconnaissance des nombres dépend de la « localisation », c'est-à-dire des paramètres régionaux qui ont été définis. Pour modifier la localisation dans OOo, utilisez le menu Outils  > Options > Paramètres linguistiques > Langue.

Pour n’appliquer la localisation qu’à une cellule particulière, sélectionnez la cellule, faites un clic droit et sélectionnez l’option Formater les cellules > Cellule et dans l’onglet Nombres, modifiez l’option Langue.

Format par défaut des cellules

Le format par défaut des cellules est spécifié dans le Tableau 15. Pour déterminer la valeur par défaut d’un paramètre pour une localisation :

1) Sélectionnez une cellule qui n’a pas encore été formatée.

2) Sélectionnez Formater les cellules > Onglet Nombres (Figure 24).
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Cliquez sur la catégorie voulue.

4) Regardez les valeurs intitulées « standard » dans les zones de saisie Format et description de format.

Tableau 15 : Formatage par défaut des cellules pour différentes catégories de format de cellules.

	Catégorie
	Format par défaut
	Changement du format si les valeurs saisies sont de types différents

	Nombre
	Standard
	oui

	Date
	Deux formats par défaut, l’un pour les dates uniquement et l’autre pour les dates et les heures.
	oui

	Heure
	La valeur par défaut de la localisation 
	oui

	Valeur logique

(Booléen)
	VRAI ou  FAUX
	oui

	Pourcentage
	0,00%
	Non

	Monétaire
	La valeur par défaut de la localisation 
	Non

	Scientifique
	0,00E+000
	Non

	Fraction
	# ?/?
	Non


Catégories de saisie

Les catégories de saisie sont référencées dans le tableau suivant :

Tableau 16 : Catégories de saisie

	Catégorie
	Type de saisie
	Exemples
(basé sur la localisation France)

	Fonction ou formule
	Commence par un signe égal.
	=A1+A2 ou 

=SOMME(A2:A10)

	Booléen
	Vrai ou Faux (la casse n’a pas d’importance)
	VRAI ou 

FAUX

	Nombre
	Chiffres uniquement, avec en option un séparateur décimal et un séparateur de milliers, les nombres négatifs étant désignés par un signe « - » devant ou derrière, ou mis entre parenthèses.
	1 ; 1,1 ; -1

1 123 ; -123,1

	Pourcentage
	Semblable au nombre mais avec un signe % situé à droite.
	1% ; -1%
1,1% ; 0,1%

	Monétaire
	Semblable au nombre mais avec un signe monétaire à droite.
	1€ ; 1,10€ ; 1 123€

-1€ ; 1 123,00 EUR

	Scientifique
	Semblable au nombre mais peut en plus comporter un E (la casse n’a pas d’importance) suivi d’une puissance de 10.
	1,12E+003

-1,12E+03

	Fraction
	Signe négatif optionnel, quelques chiffres, une espace,  quelques chiffres, une barre de fraction, quelques chiffres.
	1 1/2 

-1 2/3

	Heure
	Un ou deux chiffres, un séparateur d’heure (correspondant à la localisation), un ou deux chiffres, un séparateur d’heure optionnel (correspondant à la localisation),  un séparateur de décimales optionnel (correspondant à la localisation), une série de chiffres.
	10:40

1:30

	Date
	Pour la plupart des représentations de dates. Si l’année n’est pas précisée, l’année courante est prise par défaut. Si le siècle n’est pas précisé, il sera pris par défaut grâce au paramétrage du menu Outils > Options > OpenOffice.org > Général. 

Si les valeurs saisies ne correspondent pas à une possibilité valide en fonction de la localisation, alors les caractères saisis sont interprétés comme du texte simple.

Quelques exemples : un ou deux chiffres (1 1) ; un séparateur de dates de la localisation ; trois séries de chiffres séparés par un séparateur décimal (1,1,1) ; une représentation textuelle (1 fév).
	01/01/2007

01/01/07

1 janv. 07

1 Janvier 2007

lundi 1 janvier 2007

	Date et heure
	Saisie sous forme d’une date (en chiffres), un séparateur de dates de la localisation, une espace et une saisie sous forme d’heure. Tout comme pour les dates, les chiffres doivent respecter la localisation.
	01/01/07 10:30

	Texte
	Tout ce qui ne rentre pas dans les critères mentionnés précédemment.
	28/28


Changement du format de la cellule en fonction de ce qui y est saisi

Calc fonctionne de la manière suivante :

1) Le système commence par déterminer la catégorie de la saisie.

2) Si la saisie est une fonction et que le format de la cellule est le format par défaut, c’est à dire non-explicitement défini, alors le format de la cellule sera déterminé par la hiérarchie des catégories dans la fonction. L’ordre étant dates, heure, monétaire, pourcentage, scientifique, fractions et nombres sauf si la fonction retourne une valeur d’un type différent. Quelques exemples de cette dernière exception :

· Une date additionnée à un nombre donne une date, puisque la date est plus élevée dans la hiérarchie que le nombre.

· Une fonction comme =Mois() retourne un nombre même si c’est une date qui est saisie.

Sinon : 

3) Si la catégorie est Booléen, alors le format de la cellule est modifié pour Booléen. Si la catégorie est Texte, alors le format de la cellule ne change pas.

Enfin : 

4) Si la cellule est de type Nombre-Défaut, Date-Défaut, Heure-Défaut ou Booléen et que la saisie entre dans une catégorie différente, alors c’est la valeur Défaut de la catégorie concernée qui sera choisie comme nouveau format.

 XE "Coller des valeurs, Calc" Coller des valeurs

Une des conséquences est que si vous copiez du texte qui contient des dates et le collez dans Calc, vous pouvez prédéterminer quel sera le résultat affiché. Par exemple : si votre localisation est France, où le format de date par défaut est JJ/MM/AA et que la date que vous avez copiée est au format MM/JJ/AA (le format USA par défaut). Si vous avez déjà mis comme format par défaut JJ/MM/AA dans la cellule cible, alors la date sera correctement interprétée ; sinon elle ne le sera pas. Dans ce dernier cas, vous pouvez encore changer le format vers JJ/MM/AA pour afficher la date en format français.
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Chapitre 

7

   Différences pratiques entre Impress et PowerPoint

Introduction

Ce chapitre résume les différences d'utilisation entre OpenOffice.org Impress et Microsoft PowerPoint. Les informations fournies dans ce chapitre sont basées sur celles du chapitre 4 : « Généralités sur les différences pratiques entre OpenOffice.org et Microsoft Office ».

L’interface de Impress

La Figure 25 représente le plan de travail principal de Impress. Les barres d’outils et les menus sont identiques à ceux de PowerPoint, aux quelques exceptions énumérées dans ce chapitre

Accéder aux différentes vues

La fenêtre principale se divise en trois parties, de gauche à droite : le volet Diapos, l’espace de travail, et le volet des Tâches.

Le volet Diapos permet de réaliser des actions spécifiques sur chaque diapositive ; un clic droit dans ce volet active un menu contextuel pour insérer rapidement une nouvelle diapositive, copier/coller sur des diapositives complètes, supprimer une diapositive ou la renommer ; il est également possible de sélectionner plusieurs diapositives non contiguës en maintenant la touche Ctrl enfoncée pendant la sélection afin de réaliser une modification d'ensemble.

Utiliser l’espace de travail, au centre, pour créer vos diapositives.

Le volet des Tâches permet de : charger des styles, définir une mise en page, ou appliquer des animations et des transitions entre les diapositives.

Les différentes vues sont résumées dans le Tableau 17
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Dans Microsoft PowerPoint, les boutons utilisés pour passer rapidement d’une vue à l’autre sont situés dans le coin en bas à gauche de l’espace de travail. Dans Impress, ils sont, sous forme d'onglets, au centre et en haut de l’espace de travail.

Dans PowerPoint le mode Commentaires n’est accessible que par le menu Affichage > Commentaires. Dans Impress, l'insertion de commentaires s'opère très simplement, par l’onglet Notes de l’espace de travail.

Pour accéder rapidement à la page maîtresse dans PowerPoint,  maintenir la touche Shift enfoncée et cliquer en même temps sur le bouton d’accès à l’Affichage Normal. Dans Impress, passer par le menu : Affichage > Masque  > Masque des Diapos

Il convient de noter cependant que le module Impress, comme l'ensemble de OpenOffice.org, est largement personnalisable, ce qui permet d'affecter un raccourci à une action spécifique en lui associant une combinaison de touches, ou un bouton que à insérer dans la barre d'outils de votre choix ; la façon de procéder est décrite au chapitre 8.

Impress dispose d’un affichage Prospectus pour un ajustement plus précis de l’aspect de votre documentation. C’est l’équivalent (mais en plus flexible) de l’option Masque du Document de MS PowerPoint.

Tableau 17. Comparaison de l’appellation des modes d’affichage entre PowerPoint et Impress.

	Appellation PowerPoint
	Appellation Impress
	Utilisation principale

	Normal
	Normal
	Éditer le contenu des diapos (texte et formatage)

	Trieuse de diapositives
	Trieuse
de diapositives
	Définir l’ordre du diaporama

	Diaporama
	Diaporama
	Démarrer la présentation depuis la diapositive courante

	Plan
	Plan
	Éditer le texte sans formatage

	Pages de commentaire
	Notes
	Inclure des notes à une diapositive

	Masque > Masque du Document
	Prospectus
	Changer le nombre et la position de plusieurs diapositives pour les imprimer sur une page

	Masque > Masque des Diapositives
	Masque
des Diapos
	Placer et modifier les objets uniformes dans toutes les diapositives de la présentation


 XE "Dégradés de couleurs et bordures, Impress" Dégradés de couleurs et bordures

Impress ne gère pas certaines fonctionnalités de formatage de Microsoft PowerPoint. Les dégradés à trois couleurs, les doubles et triples bordures, ou encore les bordures en rond-pointillés ne sont pas supportés.

Lorsque vous importez des diapositives provenant de PowerPoint, Impress modifie les dégradés à trois couleurs en dégradés à deux couleurs, les doubles et triples bordures en simple bordure, et celles en rond-pointillés en tirets ultra-fins.

Pour améliorer le résultat de l’importation, effectuer quelques ajustements dans PowerPoint.

Modifier les dégradés de trois couleurs en dégradés de deux couleurs. Modifier les bordures doubles et triples en bordures simples avec une largeur adéquate.

Les bordures de rond-pointillés, qui sont transformées en tirets ultra-fins durant l’importation, ressemblent de très près au style de PowerPoint et n’ont donc pas besoin d’être éditées manuellement.

 XE "Multimédia, Impress" Multimédia

 XE "Narration, Impress" Narration

La possibilité de synchroniser des commentaires vocaux avec les diapositives n’est pas disponible dans Impress.

Il n’y a pas d’options pour personnaliser des animations multimédias, comme par exemple jouer un son durant plusieurs diapositives.

Son

Il est possible d’ajouter des sons dans Impress via le menu Insertion > Vidéos et Sons.

Dans toutes les versions d'OpenOffice.org 2 antérieures à la 2.3.0, les sons ne pouvaient être lus qu’avec la diapositive associée ; il n'était donc pas possible d'insérer une musique de fond pour la totalité de la présentation ; cette régression (de OOo 2 par rapport à OOo 1) a disparu avec l'arrivée de la version 2.3.0 et ces fonctionnalités sont donc désormais disponibles.

Vidéo

Il est possible d’ajouter des vidéos dans Impress via le menu Insertion > Vidéos et Sons.

 XE "Animation des diagrammes, Impress" Animation des diagrammes

Contrairement à Microsoft PowerPoint, Impress ne propose pas de fonctionnalité d’animation de graphique, par exemple la présentation d’une série ou d’une catégorie à la fois. Une façon de contourner cette limitation consiste à importer une par une les différentes étapes du diagramme animé et de les afficher successivement dans Impress.

Une autre option peut vous aider à créer des diagrammes animés : Insertion > Image animée.... Elle vous permet de regrouper plusieurs images pour créer une seule image animée.

 XE "Package pour CD-ROM, Impress" Package pour CD-ROM

Cette option de Microsoft PowerPoint permet à un fichier PowerPoint d’être sauvegardé sur un CD ou tout autre support amovible, ceci en assurant que tous les fichiers relatifs y soient inclus. Cette fonctionnalité n’existe pas dans Impress où il n’est pas possible d’ouvrir ces fichiers.

En revanche, Impress peut exporter une présentation sous forme d’animation Flash, ce que ne sait pas faire MS PowerPoint. L'exportation peut se faire aussi dans une multitude d'autres formats dont le PDF, l'HTML, le SVG, le PNG... 

 TC "Champs, Impress" \f "A" \l 1 Champs

L'insertion de champs dans Impress se fait par le menu Insertion > Champs.

Le champ Date d’Impress existe sous deux formats :

· Fixe, qui  insère la date courante dans la diapo en tant que champ fixe. La date n'est pas mise à jour automatiquement.

· Variable, qui insère la date active dans la diapo sous forme de champ variable. La date est automatiquement mise à jour lorsque vous rechargez le fichier.

Il en est de même avec le champ Heure, il est fixe ou variable.

Les champs sont affichés avec un fond gris, et sont donc rapidement reconnaissables comme tels.

 TC "Actions et interactions, Impress" \f "A" \l 1 Réglages des actions et interactions

Sous Impress, les actions sont appelées interactions. Trois façons d'accéder aux interactions possibles d'un objet sélectionné :

· À partir du menu Diaporama > Interaction...

· À partir d'un clic droit sur l'objet sélectionné

· À partir de la barre d'outils Dessin en bas la fenêtre, cliquer sur l'icône tout à droite

Microsoft PowerPoint permet d'exécuter ces actions à partir d'un clic avec la souris ou d'un pointage avec la souris. Impress ne propose ces interactions que lors d'un clic de souris, et non lors d'un simple pointage avec la souris. En conséquence, lors de l'importation d'une présentation PowerPoint l'action pointage avec la souris est transformée en action de clic de souris. L'option qui permet sous PowerPoint de mettre en surbrillance un objet au survol ou au clic de la souris n'existe pas sous Impress et sera donc ignorée lors de l'importation.

Animer un diaporama

Animations personnalisées

L'application et le rendu des animations personnalisées de Impress sont très proches de celles de PowerPoint. 

Pour accéder aux animations personnalisées, vous avez trois possibilités :

· À partir du menu Diaporama > Animation personnalisée...

· À partir de l'onglet Animation Personnalisée dans le volet des tâches.

· À partir d'un clic droit sur l'objet sélectionné

Tous les réglages d'animations se font à partir de l'onglet Animation Personnalisée dans le volet des tâches. Pour ajouter une animation à l'objet sélectionné, cliquer sur le bouton Ajouter. Une boîte de dialogue apparaît (Figure 26).
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Quatre rubriques regroupent les effets disponibles :

· Entrée : effets appliqués lors de l'entrée de l'objet sur la diapositive. L'objet n'est pas visible au départ et apparaît avec l'animation sélectionnée.

· Accentuation : effets accentuant la visibilité d'un objet sur la diapositive. L'objet est visible au départ et à la fin de l'animation.

· Quitter : effets appliqués pour faire sortir l'objet de la diapositive. L'objet est visible au départ et disparaît avec l'animation sélectionnée.

· Trajectoires : effets permettant de déplacer l'objet suivant une trajectoire choisie.

Les effets sont classés par catégories : Basique, Captivant, Modéré et Spécial. Un seul objet supporte plusieurs animations.

La similitude entre Microsoft PowerPoint et OpenOffice.org Impress est ici évidente.

Différences entre les effets d'animation

Impress et Microsoft PowerPoint sont sur ce point encore très semblables. Même s'il arrive que le nom des effets varie, le résultat final de l'animation reste cependant sensiblement identique (Tableau 18).

Tableau 18: Comparaison de quelques noms d'effets d’animations entre PowerPoint et Impress.

	PowerPoint
	Impress

	Apparaître
	Apparition

	Balayer
	Balayer

	Cercle
	Cercle

	Damier
	Damier

	Losange
	Losange

	Glisser vers l'intérieur
	Arrivée lente

	Dissolution interne
	Dissolution interne

	Flash
	Flash

	Entrée brusque
	Insertion furtive

	Barres aléatoires
	Lignes aléatoires

	Toupie
	Toupie

	Vitesse légère
	Coup de frein

	Flottant
	Flotter

	Rotation
	Rotation

	Zoom
	Zoom

	Effets aléatoires
	Effets aléatoires


Effets de transition des diapositives

Tout comme pour les animations personnalisées, le nom des effets de transition peut varier entre PowerPoint et Impress. Le Tableau 19 résume les différences, tout le reste étant identique.

Tableau 19: Comparaison du nom des effets de transition entre PowerPoint et Impress.

	PowerPoint
	Impress

	Couper
	Pas de transition équivalente

	Couper par le noir
	Pas de transition équivalente

	Flash d'informations
	Pas de transition équivalente

	Dissolution
	Dissoudre

	Diagonale de bas vers gauche
	Quadrillage en diagonale vers la gauche en bas

	Diagonale de haut vers gauche
	Quadrillage en diagonale vers la gauche en haut

	Diagonale de bas vers droite
	Quadrillage en diagonale vers la droite en bas

	Diagonale de haut vers droite
	Quadrillage en diagonale vers la droite en haut

	Poussée verticale
	Poussée vers le bas


Adapter le texte au cadre

Impress et PowerPoint se comportent par défaut de la même façon pour ajuster un texte à une zone de texte. La largeur du cadre reste fixe et la hauteur augmente en fonction de ce que vous tapez.

Dans Impress, l'option Adapter au cadre autorise le texte à être saisi au-delà du cadre. Sélectionner un autre objet indique la fin de saisie, Impress ajuste votre texte comme pour une image. Résultat : un texte déformé pour s'adapter au cadre.

Pour accéder aux options d'adaptation du texte au cadre d'Impress :

1) Cliquer sur le cadre du texte pour le sélectionner.

2) Cliquer avec le bouton droit de la souris sur la zone de texte et choisir Texte... dans le menu déroulant. La boîte de dialogue Texte apparaît.
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Dans l'onglet Texte, les options permettent d'ajuster automatiquement la taille du cadre ou de la police de caractère comme suit : 

· Adapter la largeur du texte : ajuste le texte selon la largeur de votre image ou de votre objet de texte. 

· Adapter la hauteur du texte : ajuste le texte selon la hauteur de votre image ou de votre objet de texte. 

· Adapter au cadre : ajuste le texte pour qu'il s'adapte à la hauteur et à la largeur de votre image ou de votre objet de texte. Pour sélectionner cette option, vous devez d'abord décocher les deux options précédentes. 
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Chapitre

8

   Personnaliser OpenOffice.org

 XE "Personnaliser les barres d'outils" Personnaliser les barres d'outils

L’utilisation de la touche Alt pour faire glisser les icônes dans la barre d’outils ne fonctionne pas avec OpenOffice.org. Les autres notions de personnalisation des barres d’outils sont similaires à celles de Microsoft Office : les différentes étapes sont détaillées ci-dessous.

Personnaliser les barres d’outils

Trois façons différentes pour accéder au menu de personnalisation des barres d’outils :

1) Outils > Personnaliser... > Barres d’outils.

2) Cliquer sur la flèche noire au bout d’une barre d’outils et choisissez Personnaliser la barre d’outils...

3) Affichage > Barres d’outils > Personnaliser... > Barres d’outils (comme avec Microsoft Office).

Plutôt que faire glisser les boutons dans la barre d’outils comme dans Microsoft Office, utiliser la boîte de dialogue « Personnaliser » (Figure 28) :

1) Barres d’outils OpenOffice.org + nom du programme (exemple: Writer) >  Utiliser la liste déroulante pour choisir la barre d’outils.

2) Contenu de la barre d’outils : les cases à cocher indiquent si le bouton sera affiché ou non.

3) Les boutons Monter ou Descendre changent l’ordre d’affichage des boutons dans la barre d’outils.

4) Si la fonction désirée n’est pas dans la liste pour la barre d’outils sélectionnée, utiliser le bouton Ajouter.

5) Utiliser le bouton Modifier pour des actions telles que changer une icône, renommer ou restaurer les valeurs par défaut.


[image: image52]
	Remarque

[image: image53.png]



	Il n’y a pas d’éditeur de bouton intégré dans OOo. Pour utiliser une icône personnalisée, la sauvegarder au format bmp dans le répertoire {Installation}/share/config/symbol. OOo parcourt automatiquement ce répertoire à chaque ouverture de la boîte de dialogue Changement d’icône. Les icônes personnalisées doivent avoir une taille de 16×16 pixels et 256 couleurs maximum.


Créer une nouvelle barre d’outils

Pour créer une nouvelle barre d’outils : 

1) Sélectionner Outils > Personnaliser... > Barres d’outils.

2) Cliquer sur Nouveau pour afficher une boîte de dialogue dans laquelle vous devez nommer la nouvelle barre d’outils. Cliquer sur OK.

3) Personnaliser la nouvelle barre d’outils comme indiqué précédemment.

 XE "Personnaliser les menus" Personnaliser les menus

Il n’existe pas de différences significatives entre OpenOffice.org et Microsoft Office dans la façon de personnaliser les menus. Les différentes étapes sont indiquées ci-dessous. Vous pouvez même modifier la police de caractères des menus afin qu’elle soit identique à celle utilisée par le système.

Personnaliser le contenu des menus

Pour personnaliser le contenu des menus :

1) Sélectionner Outils > Personnaliser... > Menus (Figure 29).

2) Dans la liste de sélection Enregistrer dans, indiquer si vous voulez utiliser ce menu modifié pour toute l’application ou seulement pour un document précis. 

3) Dans Menus OpenOffice.org + nom du programme (exemple : Writer) > Menu, sélectionner le menu que vous voulez personnaliser dans la liste .
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Pour ajouter une fonction :

1) Contenu du menu : sélectionner l’entrée du menu que vous souhaitez modifier.

2) Cliquer sur le bouton Ajouter.

3) Sélectionner dans la boîte de dialogue Ajouter des commandes la nouvelle fonction en utilisant les listes de sélection Catégorie et Commandes.

4) Cliquer sur Ajouter pour insérer la ou les fonctions dans le menu. Une fois terminé, cliquer sur Fermer.

Personnaliser la police de caractères des menus 

La police utilisée par OOo pour les menus est différente de celle qu’utilise Microsoft Office (police du système). Pour utiliser cette dernière :

1) Outils > Options... > OpenOffice.org > Affichage.

2) Cocher la case Police du système pour l’interface utilisateur. 

3) Cliquer sur OK.

 XE "Personnaliser les raccourcis clavier" Personnaliser les raccourcis clavier

Pour personnaliser les raccourcis clavier, la procédure dans OOo est différente de celle de MSO :

1) Outils > Personnaliser... > Clavier.

2) Dans l’onglet Clavier de la boîte de dialogue Personnaliser (Figure 30), sélectionner le raccourci désiré dans la liste nommée Raccourcis claviers. 

3) Sélectionner la catégorie de la commande et la fonction désirée dans les listes en bas de la boîte de dialogue.

4) En haut à droite de la boîte de dialogue, indiquer si le raccourci clavier doit s’appliquer à toutes les applications OOo ou seulement à l’application en cours (Writer par exemple). 
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Cliquer sur Enregistrer. 

	Remarque
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	La touche Alt n’est pas disponible pour les raccourcis clavier. Pour utiliser cette fonction, charger la macro AltKeyHandler.sxw sur le site (anglais) :
http://homepages.paradise.net.nz/hillview/OOo/.


Personnaliser la saisie et l’édition

Correction automatique /  XE "Formatage automatique" Formatage automatique

Une des fonctionnalités d’OpenOffice.org est la possibilité de créer des exceptions dans les règles d’AutoCorrection et d’AutoFormat. Par exemple, vous pouvez utiliser LA FONCTION « COrriger la 2e majuscule en DÉbut de mot » mais exclure les situations où deux capitales sont souhaitées, comme pour OOo. Pour gérer les exceptions :

1) Outils > AutoCorrection. 

2) [image: image93.png]


Cliquer sur l’onglet Exception (Figure 31). 

Annuler et restaurer

Pour spécifier combien d’actions « annulation » sont possibles :

Outils > Options... > OpenOffice.org > Mémoire vive, et indiquer le nombre d'opérations annulables dans la case  Nombre d’opérations. 

Vérifier l’orthographe

Pour configurer les options de vérification d’orthographe dans OpenOffice.org, utiliser :

Outils > Options... > Paramètres linguistiques > Linguistique 

Les options de vérification d’orthographe sont les mêmes dans toutes les applications OOo.

	Remarque
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	Contrairement aux dictionnaires par défaut, les dictionnaires personnalisés ne sont pas compressés. Utiliser trop de dictionnaires personnalisés, ou contenant plus de 1000 entrées réduit les performances lors de la vérification.


Installer les dictionnaires pour d’autres langues 

Pour installer les dictionnaires d’autres langues :

Sélectionner Fichier > Assistants > Installer de nouveaux dictionnaires... . 

Un document OOo s’ouvrira avec des liens vers différentes langues que vous pouvez installer. Suivre alors les instructions pour procéder à l’installation.

Vous pouvez aussi télécharger directement la macro DicOOo à la page : http://fr.openoffice.org/DicOOo/index_dicooo.htm 

Paramètres de sécurité

Pour configurer la protection contre les virus pour les macros et les paramètres de sécurité de Java, utiliser :

Outils > Options... > OpenOffice.org > Sécurité 

Pour les autres paramètres de sécurité, consulter les rubriques Protection par mot de passe et Options de vie privée dans le chapitre 4 de ce même guide : « Généralités sur les différences d'utilisation entre OpenOffice.org et Microsoft Office ».

 XE "Paramètres personnels" Paramètres personnels

Pour savoir où sont stockés les paramètres de personnalisation, utiliser :

Outils > Options... > OpenOffice.org > Sécurité 

La boîte de dialogue montre que cette information est stockée par défaut dans un dossier appelé « user ».

Stocker la configuration dans un modèle 

Vous trouverez ici des explications sur la façon d’enregistrer les changements des menus, des raccourcis clavier, des barres de statut et des barres d’outils dans un modèle, de manière à ce que les personnalisations soient automatiquement chargées quand vous travaillez sur un document utilisant ce modèle.

1) Créer et sauvegarder le modèle qui contiendra la configuration. Effectuer une copie de sauvegarde de ce modèle, sans les changements de configuration, est aussi une bonne précaution à prendre.

2) Procéder aux changements souhaités dans la configuration (voir « Personnaliser les menus », « Personnaliser les barres d’outils » et « Personnaliser les raccourcis clavier » ci-dessus). Notez que toutes les modifications que vous ne souhaitez pas appliquer par défaut, devront être annulées par la suite.

3) Outils > Personnaliser...

4) À chaque étape de la personnalisation du modèle, c’est-à-dire pour chaque onglet de la boîte de dialogue que vous désirez modifier, sélectionner le modèle désiré (celui que vous avez créé et sauvegardé lors de l’étape 1) et cliquer sur Sauvegarder. 

5) Écraser le fichier (le message d’avertissement peut être ignoré). 

6) Annuler les changements pré-existants non souhaités (comme indiqué à l’étape 2). 
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�Figure � SEQ "Figure" \*Arabic �22� : Établir des liens entre des feuilles de calcul.





�Le menu « Aide »





�Figure � SEQ "Figure" \*Arabic �4�: Choix des options de compatibilité





�Figure � SEQ "Figure" \*Arabic �2� : La boîte de dialogue Enregistrer sous d’OpenOffice.org, où s’affichent certains des formats d'enregistrement disponibles





�Figure � SEQ "Figure" \*Arabic �7�: Créer une nouvelle catégorie AutoTexte





�Figure � SEQ "Figure" \*Arabic �8� : Réglages pour l’insertion automatique





�Figure � SEQ "Figure" \*Arabic �9� : Ancrer une fenêtre





�Figure � SEQ "Figure" \*Arabic �10� : Le Navigateur dans Writer





�Figure � SEQ "Figure" \*Arabic �12� : La Gallery dans Writer





�Figure � SEQ "Figure" \*Arabic �13� : Le Navigateur de sources de données dans Writer





�Figure � SEQ "Figure" \*Arabic �16� : Le plan de travail principal de Writer en mode d’affichage Aperçu





�Figure � SEQ "Figure" \*Arabic �17�: Le Navigateur





�Figure � SEQ "Figure" \*Arabic �23� : Boîte de dialogue Éditer les zones d'impression





�Figure � SEQ "Figure" \*Arabic �25� : La fenêtre principale d’Impress





�Figure � SEQ "Figure" \*Arabic �27�: Changer les propriétés d'adaptation au cadre





�Figure � SEQ "Figure" \*Arabic �26�: Fenêtre des animations personnalisées.





�Figure � SEQ "Figure" \*Arabic �31� : Onglet Exceptions de la boîte de dialogue AutoCorrection





�Figure � SEQ "Figure" \*Arabic �1�: Choisir le format par défaut pour l’enregistrement des fichiers





�Figure � SEQ "Figure" \*Arabic �11�: Fenêtre Styles et formatage dans Writer





�Figure � SEQ "Figure" \*Arabic �18�: Fenêtre Styles et formatage





�Figure � SEQ "Figure" \*Arabic �19� : Les éléments de la fenêtre de Calc





�Figure � SEQ "Figure" \*Arabic �24�: Formatage des cellules





�Figure � SEQ "Figure" \*Arabic �29�: L'onglet Menus de la fenêtre Personnaliser





�Figure � SEQ "Figure" \*Arabic �14� : La boîte de dialogue Ouvrir dans OpenOffice.org.





�Figure � SEQ "Figure" \*Arabic �30� : Définir un raccourci clavier pour l’application d’un style





�Figure � SEQ "Figure" \*Arabic �3� : Modifier les paramètres des objets OLE





�Figure � SEQ "Figure" \*Arabic �5�: Créer un nouveau dictionnaire dans OpenOffice.org





�Figure � SEQ "Figure" \*Arabic �6�. Choisir un dictionnaire OOo pour des mots importés de Microsoft Word





�Figure � SEQ "Figure" \*Arabic �15� : La boîte de dialogue Rechercher & Remplacer





�Figure � SEQ "Figure" \*Arabic �21� : Fenêtre Styles et formatage, montrant les styles par défaut de Calc.





�Figure � SEQ "Figure" \*Arabic �20�: Le Navigateur





�Figure � SEQ "Figure" \*Arabic �28�: L'onglet Barres d'outils de la fenêtre Personnaliser








�	 : Pour les macros aidant à travailler avec les références, consultez le document � HYPERLINK "http://homepages.paradise.net.nz/hillview/OOo/"��http://homepages.paradise.net.nz/hillview/OOo/�.


�	 : À la connaissance de l’auteur.
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